link between Cisco switch and Juniper router is problematic

m4rtinm4rtin Member Posts: 170
I have a following network setup:

imagexh.th.png

The problem is that I can not exchange traffic between router and computer. This applies to 192.168.1.0/30 and 192.168.2.0/30 networks. As far as I understand, switch configuration seems to be fine and configuration of computer network interfaces as well. Only thing left is the configuration of the Juniper network interface. It's following:
[email protected]> show configuration interfaces ge-1/3/0 
description "-> Catalyst4500-Gi2/4";
vlan-tagging;
encapsulation flexible-ethernet-services;
gigether-options {
    no-flow-control;
}
unit 333 {
    description "-> T60";
    vlan-id 333;
    family inet {
        rpf-check;
        address 192.168.1.1/30;
    }
}
unit 444 {
    description "-> PC";
    vlan-id 444;
    family inet {
        rpf-check;
        address 192.168.2.1/30;
    }
}

[email protected]>
I cant's see MAC addresses on VLAN's 333 and 444 on switch interface facing the router:
C4500#show mac address-table interface gi2/4
Multicast Entries
 vlan    mac address     type    ports
-------+---------------+-------+--------------------------------------------
 333    ffff.ffff.ffff   system Gi2/4,Gi6/46,Po2
 444    ffff.ffff.ffff   system Gi2/4,Gi6/47,Po2

C4500#
Gi2/4     -> M10i ge-1/3/0   connected    trunk        full   1000 1000BaseLH
Any ideas, what is wrong with the link between Cisco switch and Juniper router?icon_rolleyes.gif

Comments

  • mikej412mikej412 Member Posts: 10,086 ■■■■■■■■■■
    Is the Cisco Switch trunk using 802.1Q encapsulation?
    :mike: Cisco Certifications -- Collect the Entire Set!
  • m4rtinm4rtin Member Posts: 170
    mikej412 wrote: »
    Is the Cisco Switch trunk using 802.1Q encapsulation?
    yes, "switchport trunk encapsulation dot1q" is set. Cisco configuration facing M10i is following:
    interface GigabitEthernet2/4
     description -> M10i ge-1/3/0
     switchport trunk encapsulation dot1q
     switchport trunk native vlan 999
     switchport trunk allowed vlan 333,444
     switchport mode trunk
     switchport nonegotiate
     flowcontrol receive off
    end
    

    I have tried with different SFP's as well, but there is still no L2 connectivity between the switch and the routericon_rolleyes.gif Any ideas?
  • brocbroc Member Posts: 167
    It looks like to me you are missing the native vlan ID on the Juniper side. It is probably using the default vlan 1 when the Cisco switch is using vlan 999.
    "Not everything that counts can be counted, and not everything that can be counted counts.”
  • mikej412mikej412 Member Posts: 10,086 ■■■■■■■■■■
    Can you confirm that VLANs 333 and 444 exist in the switch VLAN database? They should be there if you created them or entered those access port configurations.
    :mike: Cisco Certifications -- Collect the Entire Set!
  • m4rtinm4rtin Member Posts: 170
    broc wrote: »
    It looks like to me you are missing the native vlan ID on the Juniper side. It is probably using the default vlan 1 when the Cisco switch is using vlan 999.

    I set "switchport trunk native vlan 1" on Cisco side, but it didn't help. Configuration of the interface facing the Juniper looks like this:
    interface GigabitEthernet2/4
     description -> M10i ge-1/3/0
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 333,444
     switchport mode trunk
     switchport nonegotiate
     flowcontrol receive off
    end
    

    mikej412 wrote: »
    Can you confirm that VLANs 333 and 444 exist in the switch VLAN database? They should be there if you created them or entered those access port configurations.

    Yes, both VLAN's 333 and 444 are present. Both are in FWD status on port Gi2/4.

    What else to test/try?icon_rolleyes.gif
  • mikej412mikej412 Member Posts: 10,086 ■■■■■■■■■■
    m4rtin wrote: »
    Gi2/4     -> M10i ge-1/3/0   connected    trunk        full   1000 [B]1000BaseLH[/B]
    
    Are you running single mode fiber?

    You can try Unidirectional Link Detection on the Cisco Switch (if you have an open port) to check the cable -- or just double check you don't have the transmit/receive connections reversed on one end (i.e., transmit<-->transmit and receive<-->receive).
    :mike: Cisco Certifications -- Collect the Entire Set!
  • AldurAldur Juniper Moderator Member Posts: 1,460
    Quick question - Why are you using "encapsulation flexible-ethernet-services"?

    [FONT=Verdana,Arial,Helvetica][FONT=Verdana,Arial,Helvetica]"flexible-ethernet-services--For Gigabit Ethernet IQ interfaces and
    Gigabit Ethernet PICs with small form-factor pluggable transceivers
    (SFPs) only, use flexible Ethernet services encapsulation when you
    want to configure multiple per-unit Ethernet encapsulations. This
    encapsulation type allows you to configure any combination of route,
    TCC, CCC, Layer 2 VPNs, and VPLS encapsulations on a single physical
    port. Aggregated Ethernet bundles cannot use this encapsulation type.
    If you configure flexible Ethernet services encapsulation on the
    physical interface, VLAN IDs from 1 through 511 are no longer reserved
    for normal VLANs."

    It really doesn't seem necessary with your setup and might be causing some problems.
    [/FONT][/FONT]
    "Bribe is such an ugly word. I prefer extortion. The X makes it sound cool."

    -Bender
Sign In or Register to comment.