Etherchannel Question

iprouteiproute Member Posts: 269
Hey guys. I have a question regarding etherchannel. It seems when using both PAgP and LACP, as soon as I force the ports of the channel to be 1000/Full, the channel won't form. It works perfectly with auto/auto.

Here's the config and show etherchannel summary for both switches.

Switch 1:
DSW1_CiscoLab#sh run int po1
Building configuration...

Current configuration : 31 bytes
!
interface Port-channel1
end

DSW1_CiscoLab#sh run int gi0/1
Building configuration...

Current configuration : 102 bytes
!
interface GigabitEthernet0/1
 channel-protocol pagp
 channel-group 1 mode desirable non-silent
end

DSW1_CiscoLab#sh run int gi0/2
Building configuration...

Current configuration : 102 bytes
!
interface GigabitEthernet0/2
 channel-protocol pagp
 channel-group 1 mode desirable non-silent
end

DSW1_CiscoLab#sh run int gi0/3
Building configuration...

Current configuration : 102 bytes
!
interface GigabitEthernet0/3
 channel-protocol pagp
 channel-group 1 mode desirable non-silent
end

DSW1_CiscoLab#sh run int gi0/4
Building configuration...

Current configuration : 102 bytes
!
interface GigabitEthernet0/4
 channel-protocol pagp
 channel-group 1 mode desirable non-silent
end

DSW1_CiscoLab#sh etherchannel sum
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         PAgP      Gi0/1(P)    Gi0/2(P)    Gi0/3(P)    
                                 Gi0/4(P)  

Switch 2:
DSW2_CiscoLab#sh run int po1
Building configuration...

Current configuration : 66 bytes
!
interface Port-channel1
 switchport mode dynamic desirable
end

DSW2_CiscoLab#sh run int gi0/1
Building configuration...

Current configuration : 137 bytes
!
interface GigabitEthernet0/1
 switchport mode dynamic desirable
 channel-protocol pagp
 channel-group 1 mode desirable non-silent
end

DSW2_CiscoLab#sh run int gi0/2
Building configuration...

Current configuration : 137 bytes
!
interface GigabitEthernet0/2
 switchport mode dynamic desirable
 channel-protocol pagp
 channel-group 1 mode desirable non-silent
end

DSW2_CiscoLab#sh run int gi0/3
Building configuration...

Current configuration : 137 bytes
!
interface GigabitEthernet0/3
 switchport mode dynamic desirable
 channel-protocol pagp
 channel-group 1 mode desirable non-silent
end

DSW2_CiscoLab#sh run int gi0/4
Building configuration...

Current configuration : 137 bytes
!
interface GigabitEthernet0/4
 switchport mode dynamic desirable
 channel-protocol pagp
 channel-group 1 mode desirable non-silent
end

DSW2_CiscoLab#sh etherchannel summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         PAgP      Gi0/1(P)    Gi0/2(P)    Gi0/3(P)    
                                 Gi0/4(P)    

When I add the following, the channel goes down and doesn't come back up.

Switch 1:
DSW1_CiscoLab#sh run int po1
Building configuration...

Current configuration : 56 bytes
!
interface Port-channel1
 speed 1000
 duplex full
end

DSW1_CiscoLab#show etherchannel sum
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SD)         PAgP      Gi0/1(D)    Gi0/2(D)    Gi0/3(D)    
                                 Gi0/4(D)    

Switch 2:
DSW2_CiscoLab#sh run int po1
Building configuration...

Current configuration : 91 bytes
!
interface Port-channel1
 switchport mode dynamic desirable
 speed 1000
 duplex full
end

DSW2_CiscoLab#sh etherchannel sum
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SD)         PAgP      Gi0/1(D)    Gi0/2(D)    Gi0/3(D)    
                                 Gi0/4(D)  

As I understand it, both sides have to match on speed/duplex (among other things). In this case, they match but still won't form a channel.

Both switches are Catalyst 2960Gs running the same version of IOS.

What am I missing?

Thanks.
CCNP Progress
ROUTE [X] :: SWITCH [X] :: TSHOOT [X]

Comments

  • networker050184networker050184 Mod Posts: 11,962 Mod
    I believe you need the speed/duplex to match on the physical interfaces and the port-channel.
    An expert is a man who has made all the mistakes which can be made.
  • iprouteiproute Member Posts: 269
    Thanks for the reply. By applying the commands to the port channel interface, it applies them to the member interfaces as well.

    Switch 1:
    DSW1_CiscoLab#sh run int po1
    Building configuration...
    
    Current configuration : 56 bytes
    !
    interface Port-channel1
     speed 1000
     duplex full
    end
    
    DSW1_CiscoLab#sh run int gi0/1
    Building configuration...
    
    Current configuration : 127 bytes
    !
    interface GigabitEthernet0/1
     speed 1000
     duplex full
     channel-protocol pagp
     channel-group 1 mode desirable non-silent
    end
    
    DSW1_CiscoLab#sh run int gi0/2
    Building configuration...
    
    Current configuration : 127 bytes
    !
    interface GigabitEthernet0/2
     speed 1000
     duplex full
     channel-protocol pagp
     channel-group 1 mode desirable non-silent
    end
    
    DSW1_CiscoLab#sh run int gi0/3
    Building configuration...
    
    Current configuration : 127 bytes
    !
    interface GigabitEthernet0/3
     speed 1000
     duplex full
     channel-protocol pagp
     channel-group 1 mode desirable non-silent
    end
    
    DSW1_CiscoLab#sh run int gi0/4
    Building configuration...
    
    Current configuration : 127 bytes
    !
    interface GigabitEthernet0/4
     speed 1000
     duplex full
     channel-protocol pagp
     channel-group 1 mode desirable non-silent
    end
    

    Switch 2:
    DSW2_CiscoLab#sh run int po1  
    Building configuration...
    
    Current configuration : 91 bytes
    !
    interface Port-channel1
     switchport mode dynamic desirable
     speed 1000
     duplex full
    end
    
    DSW2_CiscoLab#sh run int gi0/1
    Building configuration...
    
    Current configuration : 162 bytes
    !
    interface GigabitEthernet0/1
     switchport mode dynamic desirable
     speed 1000
     duplex full
     channel-protocol pagp
     channel-group 1 mode desirable non-silent
    end
    
    DSW2_CiscoLab#sh run int gi0/2
    Building configuration...
    
    Current configuration : 162 bytes
    !
    interface GigabitEthernet0/2
     switchport mode dynamic desirable
     speed 1000
     duplex full
     channel-protocol pagp
     channel-group 1 mode desirable non-silent
    end
    
    DSW2_CiscoLab#sh run int gi0/3
    Building configuration...
    
    Current configuration : 162 bytes
    !
    interface GigabitEthernet0/3
     switchport mode dynamic desirable
     speed 1000
     duplex full
     channel-protocol pagp
     channel-group 1 mode desirable non-silent
    end
    
    DSW2_CiscoLab#sh run int gi0/4
    Building configuration...
    
    Current configuration : 162 bytes
    !
    interface GigabitEthernet0/4
     switchport mode dynamic desirable
     speed 1000
     duplex full
     channel-protocol pagp
     channel-group 1 mode desirable non-silent
    end
    
    CCNP Progress
    ROUTE [X] :: SWITCH [X] :: TSHOOT [X]
  • phoeneousphoeneous Go ping yourself... Member Posts: 2,333 ■■■■■■■□□□
    Are you plugging into the dual-purpose ports? What happens when you try the etherchannel on ports gi3 and gi4 and set speed and duplex? Just curious what happens.
  • networker050184networker050184 Mod Posts: 11,962 Mod
    Do the ports come up when not in the etherchannel? Any messages in the log? Have you tried bouncing the etherchannel after changing both sides?
    An expert is a man who has made all the mistakes which can be made.
  • creamy_stewcreamy_stew Member Posts: 406 ■■■□□□□□□□
    Interesting, I'm looking to implement etherchannel in a production environment. This scares me :)

    Have you looked for err-disabled ports? Especially due to etherchannel misconfig.

    edit: this is probably not an etherchannel issue. I now remember I had a problem adding an additional 2960G. I would get some sort of VTP error logs (all switches running transparent) When I switched to auto, the logs went away. Not really a problem, except ALL the other switches were hard set to 1000/full.
    Itchy... Tasty!
    [X] DCICN
    [X] IINS

    [ ] CCDA
    [ ] DCICT
  • mikej412mikej412 Member Posts: 10,086 ■■■■■■■■■■
    What kind of cable are you using? Auto-MDIX is disabled when you manually set the speed or duplex -- so if it's copper and straight through that could be an issue.

    Checking for err-disable is another good idea. If you changed the config while the ports were no shut, you may not have been fast enough making the configuration changes on both sides.
    :mike: Cisco Certifications -- Collect the Entire Set!
  • iprouteiproute Member Posts: 269
    mikej412 wrote: »
    What kind of cable are you using? Auto-MDIX is disabled when you manually set the speed or duplex -- so if it's copper and straight through that could be an issue.

    Hey all - been away for a few. This is the most likely cause. I'm using straight through cables relying on auto MDIX (basically, I have to make cross-overs if I want them). I'll try some crossover cables and check this tomorrow (my lab is at work, I am at home).

    Thanks for all the responses.
    CCNP Progress
    ROUTE [X] :: SWITCH [X] :: TSHOOT [X]
  • iprouteiproute Member Posts: 269
    Confirmed. With a cross over cable, the port comes right up (I tried it only with one as I don't see a need to make 4 cross over cables for this test :)).
    DSW1_CiscoLab#sh etherchannel summary
    Flags:  D - down        P - bundled in port-channel
            I - stand-alone s - suspended
            H - Hot-standby (LACP only)
            R - Layer3      S - Layer2
            U - in use      f - failed to allocate aggregator
    
            M - not in use, minimum links not met
            u - unsuitable for bundling
            w - waiting to be aggregated
            d - default port
    
    
    Number of channel-groups in use: 1
    Number of aggregators:           1
    
    Group  Port-channel  Protocol    Ports
    ------+-------------+-----------+-----------------------------------------------
    1      Po1(SU)         PAgP      Gi0/1(P)    Gi0/2(D)    Gi0/3(D)    
                                     Gi0/4(D)    
    
    DSW1_CiscoLab#
    

    Thanks Mike for this valuable nugget of info.

    Thanks for all the replies.
    CCNP Progress
    ROUTE [X] :: SWITCH [X] :: TSHOOT [X]
  • chrisonechrisone Senior Member Member Posts: 2,200 ■■■■■■■■■□
    Interesting, I'm looking to implement etherchannel in a production environment. This scares me :)

    Shouldn't be a problem even if you brought down the switch, as long as you don't implement it during business hours. Ask for a scheduled downtime "network maintenance" and you should be solid to work free of stress.
    Certs: CISSP, OSCP, CRTP, eCTHPv2, eCPPT, eCIR, LFCS, CEH, AZ-900, VHL:Advanced+, Retired Cisco CCNP/SP/DP
    2021 Goals
    Courses: eLearnSecurity - PTXv2 (complete), SANS 699: Purple Team Tactics (completed), PentesterLabs Pro (ongoing)
    Certs: eCPTXv2, CRTE, AZ-500, SC-200 (March 5th)
Sign In or Register to comment.