Options

ipv6 eigrp clarification

tomaifauchaitomaifauchai Member Posts: 301 ■■■□□□□□□□
Hi,
I was kinda lost today when i tried to form an adjencency over eigrp in ipv6 and i finally found that we must do a "No shutdown" on a routing protocol ?
I have 12.4T IOS running in GNS3.

Here the config needed.

R1

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 2000::1/126
ipv6 enable
ipv6 eigrp 1
R3

interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 2000::2/126
ipv6 enable
ipv6 eigrp 1

On both router
ipv6 router eigrp 1
no shutdown


And then,
*Mar 1 00:01:35.591: %DUAL-5-NBRCHANGE: IPv6-EIGRP(0) 1: Neighbor FE80::C002:6FF:FE2C:0 (FastEthernet0/0) is up: new adjacency

It's quite weird having to putting up the routing process and "enabling ipv6" on an interface isnt it?

Comments

  • Options
    jason_lundejason_lunde Member Posts: 567
    you actually dont have to do "ipv6 enable" under the interface if you assign an ipv6 address to the interface. That command works to generate a link-local address on an interface if you dont have an actual ipv6 address assigned any other way. The "no shut" is a big gotcha for eigrpv6 as well. It is kind of strange having to start the routing process there...most other routing protocols will start as soon as you enable it on the interface using ipv6. All are pretty fun once you get them going though.
  • Options
    tomaifauchaitomaifauchai Member Posts: 301 ■■■□□□□□□□
    you actually dont have to do "ipv6 enable" under the interface if you assign an ipv6 address to the interface. That command works to generate a link-local address on an interface if you dont have an actual ipv6 address assigned any other way. The "no shut" is a big gotcha for eigrpv6 as well. It is kind of strange having to start the routing process there...most other routing protocols will start as soon as you enable it on the interface using ipv6. All are pretty fun once you get them going though.

    Thanks for clearing up!
    I wasnt sure about the ipv6 enable command, but on cisco website they were referring to it.

    For the No shut, i found it myself because..actually by default, when you do a
    • show ipv6 eigrp neighbors
    It is clearly indicated, EIGRP process 1 is SHUTDOWN
    So i did a ? on both interface and router to find out a Shutdown command. I was stunned !

    Tom
Sign In or Register to comment.