Options

EIGRP "Variance"

MonkerzMonkerz Member Posts: 842
I can't seem to prove EIGRP is unequal load balancing, but I may be going about this the wrong way. Below is the router config I am attempting to load balance through. Data is coming from 198.22.166.6 and going to 10.10.10.254.

Doesn't the variance command, when set to 2, unequal load balance to links with a metric twice that of the best route?

I have two 'permit any' ACLs setup, one on S0/1 and the other S0/2 so I can see the counters tick up as packets are passed. But as traffic flows through this router, it is only routed through S0/1 to 10.10.10.254 (ACL 1 counter ticks up). The only way I can get traffic to go over S0/2 is to shutdown S0/1.

Am I doing something wrong?
sh run wrote:
hostname R2
!
boot-start-marker
boot-end-marker
!
!
memory-size iomem 5
no aaa new-model
ip subnet-zero
ip cef
!
!
no ip domain lookup
!
!
key chain EIGRP_KEYS
key 1
key-string cisco1
accept-lifetime 00:00:00 Jan 1 2010 00:00:00 Feb 1 2010
send-lifetime 00:00:00 Jan 1 2010 00:00:00 Feb 1 2010
key 2
key-string cisco2
accept-lifetime 00:00:00 Jan 28 2010 infinite
send-lifetime 00:00:00 Jan 28 2010 infinite
!
!
interface Loopback0
ip address 192.168.1.1 255.255.255.0
no keepalive
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
no ip address
encapsulation frame-relay
clockrate 2000000
!
interface Serial0/0.1 multipoint
ip address 172.16.222.2 255.255.255.0
ip authentication mode eigrp 666 md5
ip authentication key-chain eigrp 666 EIGRP_KEYS
frame-relay map ip 172.16.222.1 300 broadcast
frame-relay map ip 172.16.222.3 300 broadcast
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
bandwidth 256
ip address 10.23.127.5 255.255.255.252
ip access-group 1 out
ip authentication mode eigrp 666 md5
ip authentication key-chain eigrp 666 EIGRP_KEYS
encapsulation ppp
clockrate 256000
!
interface Serial0/2
bandwidth 128
ip address 10.23.127.1 255.255.255.252
ip access-group 2 out
ip authentication mode eigrp 666 md5
ip authentication key-chain eigrp 666 EIGRP_KEYS
encapsulation ppp
clockrate 128000
!
router eigrp 666
variance 2
passive-interface Loopback0
network 10.23.127.0 0.0.0.255
network 172.16.222.2 0.0.0.0
network 192.168.1.0
no auto-summary
!
ip classless
ip default-network 192.168.1.0
!
!
no ip http server
no ip http secure-server
!
access-list 1 permit any
access-list 2 permit any
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
IP-EIGRP Topology Table for AS(666)/ID(192.168.1.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status

P 10.10.10.0/24, 1 successors, FD is 10537472
via 10.23.127.6 (10537472/281600), Serial0/1
via 10.23.127.2 (20537600/281600), Serial0/2
P 10.40.0.0/22, 1 successors, FD is 2297856
via 172.16.222.1 (2297856/128256), Serial0/0.1
P 10.23.127.2/32, 1 successors, FD is 2169856
via Rconnected (2169856/0)
P 172.16.222.0/24, 1 successors, FD is 2169856
via Connected, Serial0/0.1
P 10.23.127.0/30, 1 successors, FD is 20512000
via Connected, Serial0/2
P 10.23.127.1/32, 0 successors, FD is Inaccessible
via 10.23.127.6 (11049472/2195456), Serial0/1
via 10.23.127.2 (21024000/2169856), Serial0/2
P 10.23.127.6/32, 1 successors, FD is 2169856
via Rconnected (2169856/0)
P 10.23.127.4/30, 1 successors, FD is 10511872
via Connected, Serial0/1
P 10.23.127.5/32, 0 successors, FD is Inaccessible
via 10.23.127.6 (11023872/2169856), Serial0/1
via 10.23.127.2 (21049600/2195456), Serial0/2
P 192.168.1.0/24, 1 successors, FD is 128256
via Connected, Loopback0
P 198.22.166.6/32, 1 successors, FD is 3193856
via 172.16.222.1 (3193856/2681856), Serial0/0.1
P 198.22.166.0/24, 1 successors, FD is 3193856
via 172.16.222.1 (3193856/2681856), Serial0/0.1
P 172.30.0.0/16, 1 successors, FD is 3321856
via 172.16.222.1 (3321856/2809856), Serial0/0.1
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

198.22.166.0/24 is variably subnetted, 2 subnets, 2 masks
D EX 198.22.166.6/32 [170/3193856] via 172.16.222.1, 00:32:20, Serial0/0.1
D 198.22.166.0/24 [90/3193856] via 172.16.222.1, 00:32:20, Serial0/0.1
172.16.0.0/24 is subnetted, 1 subnets
C 172.16.222.0 is directly connected, Serial0/0.1
D 172.30.0.0/16 [90/3321856] via 172.16.222.1, 00:32:20, Serial0/0.1
10.0.0.0/8 is variably subnetted, 6 subnets, 4 masks
D 10.10.10.0/24 [90/10537472] via 10.23.127.6, 00:33:28, Serial0/1
[90/20537600] via 10.23.127.2, 00:33:28, Serial0/2
D 10.40.0.0/22 [90/2297856] via 172.16.222.1, 00:32:20, Serial0/0.1
C 10.23.127.2/32 is directly connected, Serial0/2
C 10.23.127.0/30 is directly connected, Serial0/2
C 10.23.127.6/32 is directly connected, Serial0/1
C 10.23.127.4/30 is directly connected, Serial0/1
C* 192.168.1.0/24 is directly connected, Loopback0

Comments

  • Options
    networker050184networker050184 Mod Posts: 11,962 Mod
    The default load balancing for CEF is per-destination (actually a per destination/source flow I believe) so if you only have one destination its only going to use one path. You can change it to per-packer depending on the platform if you want to see it work with just one pair of devices.
    An expert is a man who has made all the mistakes which can be made.
  • Options
    MonkerzMonkerz Member Posts: 842
    You are the man!! Adding 'ip load-sharing per-packet' to both outgoing interfaces did the trick. Thanks Networker!
  • Options
    deth1kdeth1k Member Posts: 312
    You have to disable cef on those interfaces since you are doing unequal load balancing, which is process switched rather than done using cef.
  • Options
    networker050184networker050184 Mod Posts: 11,962 Mod
    deth1k wrote: »
    You have to disable cef on those interfaces since you are doing unequal load balancing, which is process switched rather than done using cef.

    You can do unequal cost load balancing with CEF. It just provides an unequal amount of buckets to the links.
    An expert is a man who has made all the mistakes which can be made.
Sign In or Register to comment.