USB Ethernet Adapter with 802.1Q VLAN Tagging Support

LukeQuakeLukeQuake Member Posts: 579
Long story as to why I need this but… I could really use some help.

I’m looking to get hold of a USB Ethernet Adapter that will support 802.1Q VLAN Tagging. I’ve spent over an hour searching and am beginning to think such as thing doesn’t exist!


The DS-N26A from Netronix Inc (http://www.netronixinc.com/datasheet/Ethernet/Adapter/DS-N26A.pdf ) mentions VLAN support, but I can’t find stock of them.


Any ideas?


Regards,
Luke
Microsoft Certifications: MCITP:EA, MCSE:S, MCSA:M, MCDST, MCTS: Vista Config, MCITP: Ent Support
Citrix Certifications: CCA XenApp 4.5/5.0 and XenServer 5.0
Other: Marathon Certified Consultant (HA, FT and VM), ISEB InfoSec Management Principles and Security+
Working on: CISSP and Check Team Member

Comments

  • gamutgamut Registered Users Posts: 2 ■□□□□□□□□□
    Meanwhile hello to all members,
    I have the same problem: I want to ask if you've solved with the DS-N26A or have bought something else?
  • keenonkeenon Member Posts: 1,922 ■■■■□□□□□□
    Become the stainless steel sharp knife in a drawer full of rusty spoons
  • gamutgamut Registered Users Posts: 2 ■□□□□□□□□□
    Thank you very much, now give a look to the model, it seems that finally the right one.
    See you soon
    Angelo
  • mahirmahir Registered Users Posts: 4 ■□□□□□□□□□
    Hi Guys,

    Does RocketFish one works under windows 7 64 bit?

    Regards
    Mahir
  • SlowhandSlowhand MCSE: Cloud Platform and Infrastructure, MCSA: Windows Server 2003/2012/2016, CCNA Routing & Switchi Bay Area, CaliforniaMod Posts: 5,161 Mod
    Supposedly, the RocketFish USB-to-LAN adapter runs the Asix AX88772 chipset, which is recognized by Windows 7, but the drivers are easy enough to find if you're run into issues. Whether or not they support 802.1Q, I don't know. The chipset manufacturer makes no mention of it, and I can't find any info on the product pages of the Wii-branded adapter.

    Free Microsoft Training: Microsoft Learn
    Free PowerShell Resources: Top PowerShell Blogs
    Free DevOps/Azure Resources: Visual Studio Dev Essentials

    Let it never be said that I didn't do the very least I could do.
  • elderkaielderkai Member Posts: 279
    I have four of the Rocketfish adapters connected to two 3560s and two 2950s. I haven't tested whether vlan tagging works yet because I haven't been doing any switching labs but as far as whether their functional or not, they definitely are. They work great and look nice. ^.^
  • mahirmahir Registered Users Posts: 4 ■□□□□□□□□□
    Hi elderkai

    Would you please verify the vlan tagging info. I have monoprice usb to ethernet and they are also ASIX AX88772A chipset and they do not support tagging.

    Regards
    Mahir
  • elderkaielderkai Member Posts: 279
    It's a little late right now(brain isn't fueled very well and I'm lazy :p), but I can tomorrow. All I should have to do is set up two switches over a trunk and have one switch trunking to a GNS3 router with a router-on-a-stick topology and have a laptop of mine connected to a non-native vlan, right? Then verify that the laptop can ping the sub-int of the GNS3 router. It's late, but I think I can still workout what generates a vlan-id or not. ;)

    EDIT: Okay, from testing and research it seems that while 802.1q definitely works with the ASIX AX88772 chipset, Windows will strip the vlan tag regardless. People report it working fine with linux, though. I needed a reason to reinstall Debian anyway. ^.^ There are ways around Windows stripping the tag, but those way are only for Marvell and Broadcom NICs iirc. I didn't see anything for ASIX chipsets. A shame it is, but GNS3 does run better in linux. icon_thumright.gif
  • elderkaielderkai Member Posts: 279
    I decided to dive deeper and added the Priority and Vlan line to the registry entry for the adapter and read then added an extra block and some lines to the driver itself and got the options for Enabling and Disabling Priority & VLAN settings to show up in the advanced NIC settings. All this just further proved that Windows 7 is going to strip the VLANID from the adapters no matter the variation as it stands. They do support VLAN tagging, though, just not under Windows. The VLANID is mentioned in the driver, you'll just have to use linux if you want to take advantage of it. *shakes fist at Microsoft* :p
  • mahirmahir Registered Users Posts: 4 ■□□□□□□□□□
    I also tried with linux no success, can you try?
  • elderkaielderkai Member Posts: 279
    I would have to reinstall linux, which I will eventually if I myself ever want to take advantage of VLAN tagging, and that isn't a problem but I'm kind of sleep deprived right now with a little bit of lazy to boot. I found quite a few threads via google of people talking about getting it to work, though, so just do some research and I know you'll find your answer. :) Sorry I can't be of anymore help.
  • mahirmahir Registered Users Posts: 4 ■□□□□□□□□□
    No Problem,I did it myself again and found out that it work with older versionb of ubuntu, as soon as you update it stop working, and it always show in ubuntu as disconnected even though routers are able to send packet to switch.

    Thanks for your help.
  • elderkaielderkai Member Posts: 279
    No problem. Glad you got it solved. :)
Sign In or Register to comment.