Options

RIP Configuration

veritas_libertasveritas_libertas Member Posts: 5,746 ■■■■■■■■■■
Okay, so I'm probably missing something rather obvious, but why am isn't RIP gathering up the routes in my network? I'm using GNS3. Here is the sho run from all three routers:

R1:

Router#sho ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C 192.168.10.0/24 is directly connected, FastEthernet0/0
C 192.168.11.0/24 is directly connected, FastEthernet0/1
Router#sho run
Building configuration...

Current configuration : 760 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 15
ip subnet-zero
!
!
no ip dhcp use vrf connected
!
!
ip cef
no ip ips deny-action ips-interface
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.11.1 255.255.255.0
duplex auto
speed auto
!
router rip
network 192.168.10.0
network 192.168.11.0
!
ip classless
!
!
ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end


R2:
Router#sho run
Building configuration...

Current configuration : 751 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 15
ip subnet-zero
!
!
no ip dhcp use vrf connected
!
!
ip cef
no ip ips deny-action ips-interface
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 172.0.10.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.0.11.1 255.255.255.0
duplex auto
speed auto
!
router rip
network 172.0.0.0
network 172.10.0.0
!
ip classless
!
!
ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

R3:

Router#sho run
Building configuration...

Current configuration : 728 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 15
ip subnet-zero
!
!
no ip dhcp use vrf connected
!
!
ip cef
no ip ips deny-action ips-interface
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.0.10.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.0.11.1 255.255.255.0
duplex auto
speed auto
!
router rip
network 10.0.0.0
!
ip classless
!
!
ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end


I didn't setup any static routes. Am I right in assuming that shouldn't matter?

Comments

  • Options
    networker050184networker050184 Mod Posts: 11,962 Mod
    How are your routers connected? I'm not seeing any common subnets here.
    An expert is a man who has made all the mistakes which can be made.
  • Options
    shecoolshecool Member Posts: 33 ■■□□□□□□□□
    Do you have a picture of your topology? Or are these routers connected in some form? The link between two routers would need to be on the same network, and I see all routers are configured with different network addresses.
    Up Next: CCDA, CCDP
  • Options
    veritas_libertasveritas_libertas Member Posts: 5,746 ■■■■■■■■■■
    How are your routers connected? I'm not seeing any common subnets here.

    Hmm, back to the subnetting I guess. That is weakness... icon_lol.gif I didn't think about that when I set them up.

    duh...
  • Options
    veritas_libertasveritas_libertas Member Posts: 5,746 ■■■■■■■■■■
    shecool wrote: »
    Do you have a picture of your topology? Or are these routers connected in some form? The link between two routers would need to be on the same network, and I see all routers are configured with different network addresses.

    So each router does need to be on the same subnet?

    attachment.php?attachmentid=875&stc=1&d=1297114316
  • Options
    networker050184networker050184 Mod Posts: 11,962 Mod
    You need a common subnet between each pair of the routers. For example R1-R2 10.0.0.0/30, R1-R3 10.0.0.4/30, etc.
    An expert is a man who has made all the mistakes which can be made.
  • Options
    veritas_libertasveritas_libertas Member Posts: 5,746 ■■■■■■■■■■
    You need a common subnet between each pair of the routers. For example R1-R2 10.0.0.0/30, R1-R3 10.0.0.4/30, etc.

    Thanks! I was just reading on this web site Configuring Routing Information Protocol (RIP) | Free CCNA Workbook that RIP is classful:
    When working with RIP version 1 keep in mind that it is a classful routing protocol; meaning that the same subnet must be used for the entire network. So if you use a /24 on a switch where all the PC’s are aggregated at then you must use a /24 network on the WAN link between branches otherwise the /24 networks will not get propagated over the WAN link. RIPv1 does not include the subnet in the updates sent to neighboring routers; only the network address. So in laymen terms, a /24 can only be advertised to another router through through a link that uses a /24 network due to the neighboring router assuming the subnet mask is tied to the interface in which the update was received.

    I guess I should have realized that when the network command doesn't require a subnet mask icon_rolleyes.gif LOL
  • Options
    networker050184networker050184 Mod Posts: 11,962 Mod
    Thanks! I was just reading on this web site Configuring Routing Information Protocol (RIP) | Free CCNA Workbook that RIP is classful:



    I guess I should have realized that when the network command doesn't require a subnet mask icon_rolleyes.gif LOL


    Well, thats not really your issue here. No matter the routing protocol(IGP), classful or not, the routers must be on a common subnet to exchange routing information. There are some scenarios where you can get around this, but not really on the CCNA level of fundamentals.
    An expert is a man who has made all the mistakes which can be made.
  • Options
    veritas_libertasveritas_libertas Member Posts: 5,746 ■■■■■■■■■■
    Well, thats not really your issue here. No matter the routing protocol(IGP), classful or not, the routers must be on a common subnet to exchange routing information. There are some scenarios where you can get around this, but not really on the CCNA level of fundamentals.

    Okay, thanks. Back to the books... icon_study.gif

    I'm reminded daily that I have a lot to learn about Cisco CLI and Internetworking in general.
  • Options
    millworxmillworx Member Posts: 290
    Agreed with what the above posters said. Your routers must share a common subnet for their connections between each other.

    Also too one thing to note here. You are using RIPv1, which is classful. So depending on how you reconfigure your routers, lets say router 1 has 10.10.10.1 connected on one interface and router 2 has 10.100.10.1 on another interface. Unless you configure RIP for v2 and turn off auto-summary you might have some routing issue's. But that's just an FYI.
    Currently Reading:
    CCIE: Network Security Principals and Practices
    CCIE: Routing and Switching Exam Certification Guide
Sign In or Register to comment.