IPv6 over L3 etherchannel
I am trying to build the TSHOOT topology at home and hit a snag. I cannot get ipv6 connectivity to work over an L3 etherchannel at all and I cant figure out why. IPv4 connectivity works just fine. EIGRP is passing updates without issue. However, I cannot even get an IPv6 ping across that etherchannel. I am using 2 3550's for this connection. Below are the configs:
MLS1#
interface Port-channel12
no switchport
ip address 10.2.4.13 255.255.255.252
ipv6 address 2026::3:1/122
ipv6 enable
ipv6 rip RIP_ZONE enable
interface FastEthernet0/23
no switchport
no ip address
ipv6 enable
channel-group 12 mode desirable
interface FastEthernet0/24
no switchport
no ip address
ipv6 enable
channel-group 12 mode desirable
end
====================================
MLS2#
interface Port-channel12
no switchport
ip address 10.2.4.14 255.255.255.252
ipv6 address 2026::3:2/122
ipv6 enable
ipv6 rip RIP_ZONE enable
interface FastEthernet0/23
no switchport
no ip address
ipv6 enable
channel-group 12 mode desirable
interface FastEthernet0/24
no switchport
no ip address
ipv6 enable
channel-group 12 mode desirable
end
Any help is very much appreciated!
MLS1#
interface Port-channel12
no switchport
ip address 10.2.4.13 255.255.255.252
ipv6 address 2026::3:1/122
ipv6 enable
ipv6 rip RIP_ZONE enable
interface FastEthernet0/23
no switchport
no ip address
ipv6 enable
channel-group 12 mode desirable
interface FastEthernet0/24
no switchport
no ip address
ipv6 enable
channel-group 12 mode desirable
end
====================================
MLS2#
interface Port-channel12
no switchport
ip address 10.2.4.14 255.255.255.252
ipv6 address 2026::3:2/122
ipv6 enable
ipv6 rip RIP_ZONE enable
interface FastEthernet0/23
no switchport
no ip address
ipv6 enable
channel-group 12 mode desirable
interface FastEthernet0/24
no switchport
no ip address
ipv6 enable
channel-group 12 mode desirable
end
Any help is very much appreciated!
I program my heart to beat breakbeats and hum basslines in exhalation.... matter, verse, spirit
Comments
-
stuh84 Member Posts: 503I was under the impression IPv6 didn't work on 3550s. Even if you can put the commands in, I don't think it works.Work In Progress: CCIE R&S Written
CCIE Progress - Hours reading - 15, hours labbing - 1 -
jason_lunde Member Posts: 567I was under the impression IPv6 didn't work on 3550s. Even if you can put the commands in, I don't think it works.
This is correct, it does not work. -
fonque Member Posts: 92 ■■□□□□□□□□I was able to get IPv6 to work over my 3550's the above config will not work, as I found out, because 3550s apparently do not support IPv6 in hardware, only in software. I was only able to get IPv6 working by sending IPv6 traffic over GRE tunnels using IPv4 end points. After that RIPng and OSPFv3 will work.
the following is the config I used to get IPv6 working on a 3550:
MLS1:
interface Port-channel12
no switchport
ip address 10.2.4.13 255.255.255.252
interface Tunnel12
no ip address
ipv6 address 2026::3:1/122
ipv6 enable
ipv6 rip RIP_ZONE enable
tunnel source 10.2.4.13
tunnel destination 10.2.4.14
end
MLS2:
interface Port-channel12
no switchport
ip address 10.2.4.14 255.255.255.252
interface Tunnel12
no ip address
ipv6 address 2026::3:2/122
ipv6 enable
ipv6 rip RIP_ZONE enable
tunnel source 10.2.4.14
tunnel destination 10.2.4.13
end
With the above config, RIPng works fine, IPv6 pings work fine and the IPv6 routing table is not showing any anomalies
MLS2#sh ipv6 route
IPv6 Routing Table - Default - 5 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
R - RIP, D - EIGRP, EX - EIGRP external
R ::/0 [120/3]
via FE80::213:1AFF:FE48:E100, Tunnel12
R 2026::2:0/122 [120/2]
via FE80::213:1AFF:FE48:E100, Tunnel12
C 2026::3:0/122 [0/0]
via Tunnel12, directly connected
L 2026::3:2/128 [0/0]
via Tunnel12, receive
L FF00::/8 [0/0]
via Null0, receiveI program my heart to beat breakbeats and hum basslines in exhalation.... matter, verse, spirit -
networker050184 Mod Posts: 11,962 ModI don't think GRE tunnels are a supported feature on the 3550 either even though it might work on a small scale.An expert is a man who has made all the mistakes which can be made.
-
fonque Member Posts: 92 ■■□□□□□□□□Nope not supported, but lets me get little more use out of my 3550s for studying.I program my heart to beat breakbeats and hum basslines in exhalation.... matter, verse, spirit