IPv6 works on 3550s
I was able to get IPv6 to work on my 3550's. I got the info from this link:
Mailing List Archive: Re: strange ipv6 problems on 3550 SVI
3550s apparently do not support IPv6 in hardware, only in software. I was only able to get IPv6 working by sending IPv6 traffic over GRE tunnels using IPv4 end points. After that RIPng and OSPFv3 will work.
the following is the config I used to get IPv6 working on a 3550:
MLS1:
interface Port-channel12
no switchport
ip address 10.2.4.13 255.255.255.252
interface Tunnel12
no ip address
ipv6 address 2026::3:1/122
ipv6 enable
ipv6 rip RIP_ZONE enable
tunnel source 10.2.4.13
tunnel destination 10.2.4.14
end
MLS2:
interface Port-channel12
no switchport
ip address 10.2.4.14 255.255.255.252
interface Tunnel12
no ip address
ipv6 address 2026::3:2/122
ipv6 enable
ipv6 rip RIP_ZONE enable
tunnel source 10.2.4.14
tunnel destination 10.2.4.13
end
With the above config, RIPng works fine, IPv6 pings work fine and the IPv6 routing table is not showing any anomalies
MLS2#sh ipv6 route
IPv6 Routing Table - Default - 5 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
R - RIP, D - EIGRP, EX - EIGRP external
R ::/0 [120/3]
via FE80::213:1AFF:FE48:E100, Tunnel12
R 2026::2:0/122 [120/2]
via FE80::213:1AFF:FE48:E100, Tunnel12
C 2026::3:0/122 [0/0]
via Tunnel12, directly connected
L 2026::3:2/128 [0/0]
via Tunnel12, receive
L FF00::/8 [0/0]
via Null0, receive
Successful ping using the RIP default route:
MLS2#ping 2026::12:1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2026::12:1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 184/190/208 ms
Mailing List Archive: Re: strange ipv6 problems on 3550 SVI
3550s apparently do not support IPv6 in hardware, only in software. I was only able to get IPv6 working by sending IPv6 traffic over GRE tunnels using IPv4 end points. After that RIPng and OSPFv3 will work.
the following is the config I used to get IPv6 working on a 3550:
MLS1:
interface Port-channel12
no switchport
ip address 10.2.4.13 255.255.255.252
interface Tunnel12
no ip address
ipv6 address 2026::3:1/122
ipv6 enable
ipv6 rip RIP_ZONE enable
tunnel source 10.2.4.13
tunnel destination 10.2.4.14
end
MLS2:
interface Port-channel12
no switchport
ip address 10.2.4.14 255.255.255.252
interface Tunnel12
no ip address
ipv6 address 2026::3:2/122
ipv6 enable
ipv6 rip RIP_ZONE enable
tunnel source 10.2.4.14
tunnel destination 10.2.4.13
end
With the above config, RIPng works fine, IPv6 pings work fine and the IPv6 routing table is not showing any anomalies
MLS2#sh ipv6 route
IPv6 Routing Table - Default - 5 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
R - RIP, D - EIGRP, EX - EIGRP external
R ::/0 [120/3]
via FE80::213:1AFF:FE48:E100, Tunnel12
R 2026::2:0/122 [120/2]
via FE80::213:1AFF:FE48:E100, Tunnel12
C 2026::3:0/122 [0/0]
via Tunnel12, directly connected
L 2026::3:2/128 [0/0]
via Tunnel12, receive
L FF00::/8 [0/0]
via Null0, receive
Successful ping using the RIP default route:
MLS2#ping 2026::12:1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2026::12:1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 184/190/208 ms
I program my heart to beat breakbeats and hum basslines in exhalation.... matter, verse, spirit
Comments
-
jason_lunde Member Posts: 567That is interesting...I will have to try that out. Kudos if it does work man, good find.