frame relay EIGRP
using GNS3 i made the scenario and am able to see all loopback
inetrfaces on every router ruote table how ever i cant ping from EAST
to West on any interface also not from West to East even
they both show all interfaces on there routing tables
am wondring if somthing wrong or GNS3 fault
Frame replay configuration
HQ(config)#interface serial 0/0
HQ(config-if)#encapsulation frame-relay
HQ(config-if)# interface serial 0/0.1 multipoint
HQ(config-subif)#ip address 172.16.124.1 255.255.255.248
HQ(config-subif)#frame-relay map ip 172.16.124.2 102 broadcast
HQ(config-subif)#frame-relay map ip 172.16.124.3 103 broadcast
EAST(Conf)# interface serial 0/0
EAST(config-if)#encapsulation frame-relay
EAST(config-if)#ip address 172.16.124.2 255.255.255.248
EAST(config-)#frame-relay map ip 172.16.124.1 201 broadcast
WEST(Conf)# interface serial 0/0
WEST (config-if)#encapsulation frame-relay
WEST (config-if)#ip address 172.16.124.3 255.255.255.248
WEST (config-subif)#frame-relay map ip 172.16.124.1 301 broadcast
EIGRP configuration
HQ(config)#router eigrp 25
Network 10.1.0.0 0.0.255.255
Network 172.16.0.0
No auto-summery
EAST(config)#router eigrp 25
Network 10.2.0.0 0.0.255.255
Network 172.16.0.0
No auto-summery
WEST(config)#router eigrp 25
Network 10.3.0.0 0.0.255.255
Network 172.16.0.0
No auto-summery
HQ(config)#interface serial 0/0.1
HQ(config-subif)#no ip split-horizon eigrp 25
inetrfaces on every router ruote table how ever i cant ping from EAST
to West on any interface also not from West to East even
they both show all interfaces on there routing tables
am wondring if somthing wrong or GNS3 fault
Frame replay configuration
HQ(config)#interface serial 0/0
HQ(config-if)#encapsulation frame-relay
HQ(config-if)# interface serial 0/0.1 multipoint
HQ(config-subif)#ip address 172.16.124.1 255.255.255.248
HQ(config-subif)#frame-relay map ip 172.16.124.2 102 broadcast
HQ(config-subif)#frame-relay map ip 172.16.124.3 103 broadcast
EAST(Conf)# interface serial 0/0
EAST(config-if)#encapsulation frame-relay
EAST(config-if)#ip address 172.16.124.2 255.255.255.248
EAST(config-)#frame-relay map ip 172.16.124.1 201 broadcast
WEST(Conf)# interface serial 0/0
WEST (config-if)#encapsulation frame-relay
WEST (config-if)#ip address 172.16.124.3 255.255.255.248
WEST (config-subif)#frame-relay map ip 172.16.124.1 301 broadcast
EIGRP configuration
HQ(config)#router eigrp 25
Network 10.1.0.0 0.0.255.255
Network 172.16.0.0
No auto-summery
EAST(config)#router eigrp 25
Network 10.2.0.0 0.0.255.255
Network 172.16.0.0
No auto-summery
WEST(config)#router eigrp 25
Network 10.3.0.0 0.0.255.255
Network 172.16.0.0
No auto-summery
HQ(config)#interface serial 0/0.1
HQ(config-subif)#no ip split-horizon eigrp 25
Comments
-
tomaifauchai Member Posts: 301 ■■■□□□□□□□Perhaps you configured the wrong interface?
HQ(config)#interface serial 0/0
On the picture, it show s0/1 though. -
Monkerz Member Posts: 842This is a CBT Nuggets lab...
You sure you made this? Or did you mean you set this up?
Recheck your frame map statements. East needs to know what DLCI to use to get to West and vice-versa. -
Chris_ Member Posts: 326On east you need 2 frame maps, one to get to HQ and one to get to west - same on east.
EAST(config-)#frame-relay map ip 172.16.124.1 201 broadcast
EAST(config-)#frame-relay map ip 172.16.124.3 201 broadcast
WEST(config-)#frame-relay map ip 172.16.124.1 301broadcast
WEST(config-)#frame-relay map ip 172.16.124.2 301 broadcastGoing all out for Voice. Don't worry Data; I'll never forget you
:study: CVoice [X] CIPT 1 [ ] CIPT 2 [ ] CAPPS [ ] TVOICE [ ] -
Chris_ Member Posts: 326Recheck your frame map statements. East needs to know what DLCI to use to get to West and vice-versa.
Sorry Monkerz, just realised this is exactly what you were saying!Going all out for Voice. Don't worry Data; I'll never forget you
:study: CVoice [X] CIPT 1 [ ] CIPT 2 [ ] CAPPS [ ] TVOICE [ ] -
killo33 Banned Posts: 3 ■□□□□□□□□□This is a CBT Nuggets lab...
You sure you made this? Or did you mean you set this up?
Recheck your frame map statements. East needs to know what DLCI to use to get to West and vice-versa.
yeah its CBT lab, didnt know for sure if i should map the routers east and west
scince its multipoint design not point-to-point frame relay
thanks -
ghost.rush Registered Users Posts: 1 ■□□□□□□□□□check eigrp neighbors, if there is no relationships between the routers you missed the neighbor command
HQ(config-router)#neighbor 172.16.124.2 serial 0/0.1
HQ(config-router)#neighbor 172.16.124.3 serial 0/0.1
EAST(config-router)#neighbor 172.16.124.1 serial 0/0.1
WEST(config-router)#neighbor 172.16.124.1 serial 0/0.1
hope it heps.. -
NetworkVeteran Member Posts: 2,338 ■■■■■■■■□□am wondring if somthing wrong or GNS3 fault
-
NetworkVeteran Member Posts: 2,338 ■■■■■■■■□□On east you need 2 frame maps, one to get to HQ and one to get to west - same on east.
EAST(config-)#frame-relay map ip 172.16.124.1 201 broadcast
EAST(config-)#frame-relay map ip 172.16.124.3 201 broadcast
WEST(config-)#frame-relay map ip 172.16.124.1 301broadcast
WEST(config-)#frame-relay map ip 172.16.124.2 301 broadcast
This is a correct solution.
(Although, only one 'broadcast' keyword per DLCI is necessary and recommended.)
Perhaps it's best to elaborate on the problem for clarity's sake.
East attempts to ping 172.16.124.3
This fails immediately. East sees that 172.16.124.3 should be directly connected because they are both on the same 172.16.124.0/29 subnet. However, it doesn't know what DLCI 172.16.124.3 is on because: (a) Inverse ARP fails and (b) You haven't mapped it. Clearly, a frame-relay map statement is needed that points to 172.16.124.3 to properly map L3 to L2.
East attempts to ping 10.3.3.3
This is more interesting. East knows via EIGRP that to get to 10.3.3.3 it needs to forward its packets to 10.3.3.3, and it knows via the frame-relay map statement that 172.16.124.1 is on DLCI 201. So why is a map statement needed for a ping to get to its destination?
Answer: It's not!
The problem actually occurs in the reverse direction. By default, East sends a packet with source 172.16.124.2 and destination 10.3.3.3. When the packet arrives at the destination, the destination has no way to send a reply to 172.16.124.2 per the previous case.
An alternative solution to adding a frame-relay map would be to use an extended ping, where the source is set to 10.2.2.2 and the destination is set to 10.3.3.3. -
waragi Member Posts: 72 ■■□□□□□□□□Help , Don't see how a extended ping could replace a frame relay map?, either the router knows which dlci to use or not?.