Can someone help me with scanstate and loadstate

unnamedplayerunnamedplayer Member Posts: 74 ■■□□□□□□□□
Hi all,

I've started reading Amazon.com: Windows 7 Desktop Support and Administration: Real World Skills for MCITP Certification and Beyond (Exams 70-685 and 70-686) (9780470597095): Darril Gibson: Books and got a hold of CBT Nuggets for the 680. I wasn't really planning on pursing the 680 exam, but I may have a project coming up involving upgrading machines to Windows 7, so I figured I might as well start reading :)

Now, just to try out the USMT, I made a Windows Vista VM and did an in-place migration to Windows 7 so all my old stuff is in Windows.old. I also had a copy of Office installed, which I reinstalled after upgrading to Windows 7 just to see how my application settings are maintained.

From in Windows 7 I run the following:

ScanState.exe c:\store /v:13 /hardlink /nocompress /efs:hardlink/i:MigApp.xml /i:MigDocs.xml /offlineWinDir:c:\windows.old\windows

Things look good and everything completes. Now I run the following to load those old settings:

LoadState.exe c:\store /v:13 /c /lac:[email protected] /lae /i:MigApp.xml/i:MigDocs.xml /sf /hardlink /nocompress

Again, everything goes well, I see my old user accounts and profiles are recreated. Yippe right? Ok, so I log on with a newly migrated account. First thing, I notice my background is all black even though I had selected one of the pretty Windows landscape pictures that came with Windows Vista :)

Any ideas why that is?

Second and more pressing issue, I see all the test documents I created on my desktop just fine and can open them OK. However, I was testing out the EFS capabilities of the USMT, and I see my encrypted files, they show up as being encrypted and checking the properties, I see the certificate listed is indeed my certificate that was created on Vista when I first encrypted the file. I have also checked my user store and see my EFS certificate is there.

But, I can't open the file! Example, one is a Word doc. When I try to open it I get the following error from Word: "Word cannot open the document: user does not have access privileges"

Any ideas. This is really frustrating. I've read the USMT documentation on Technet especially concerning EFS files and it sounds like this should work OK.

Oh, I wanted to throw something out as well, according to Technet (Migrate EFS Files and Certificates) if a file is in an EFS protected folder, but the file does not have the EFS attribute applied, when you run LoadState, the file will be encrypted anyway, but this time with the certificate for the account that is running LoadState. Well, I tried this out as well when I did this little experiment. I had a file in an EFS folder, removed the encryption attribute from the file, and then after installing Windows 7, ran scanstate and loadstate and my folder and document show up as they were. In other words, the folder is still EFS protected, but the file was not encrypted like Technet says it would have been. Arrrrggghhhh.

Thanks for any help!

Comments

  • unnamedplayerunnamedplayer Member Posts: 74 ■■□□□□□□□□
    Ah, so I've figured out why some things like desktop wallpaper is not migrated. Apparently, offline migration (using scanstate on a Windows.old directory) does not copy some settings that are captured with an online migration. Desktop wallpaper is one of these settings.

    What Does USMT Migrate? has some good information.

    Still trying to figure out my EFS problem now...
  • ehndeehnde Member Posts: 1,103
    Still trying to figure out my EFS problem now...

    Just to be clear - are you sure you've migrated your encryption certificate to the new machine?
    Climb a mountain, tell no one.
  • unnamedplayerunnamedplayer Member Posts: 74 ■■□□□□□□□□
    ehnde wrote: »
    Just to be clear - are you sure you've migrated your encryption certificate to the new machine?

    Yup, I have checked the certificates store using the MMC and I see the certificate there and it reads that I have the private key associated with the certificate as well. I've confirmed the thumbprint is the same as the thumbprint listed on the properties of the file (by going to Properties of file > Advanced > Details).
Sign In or Register to comment.