Options

server can't ping passed router?

needforspeedneedforspeed Member Posts: 21 ■□□□□□□□□□
Hi, the server can't ping pc's but the router can? I have set the DNS IP on the router.

Maybe its something to do with the switches?

This is what it looks like.

2li7nm9.jpg

Students are vlan 10
Staff are vlan 20
Wireless is vlan 77

Comments

  • Options
    hiddenknight821hiddenknight821 Member Posts: 1,209 ■■■■■■□□□□
    Hi, the server can't ping pc's but the router can? I have set the DNS IP on the router.

    Maybe its something to do with the switches?

    I may not be helpful, but I think you might want to check the access list on the router to see if the router is permitting anything. Honestly, I don't think you provide enough information for us to help you troubleshoot, but I could be wrong. I am not even halfway through with my ICND2 study.
  • Options
    needforspeedneedforspeed Member Posts: 21 ■□□□□□□□□□
    I have tried permitting the 192.168.10.0/24 , 192.168.20.0/24 and server

    !
    version 12.2
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    service password-encryption
    !
    hostname ABC-Birmingham
    !
    !
    !
    enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
    !
    !
    ip dhcp excluded-address 192.168.10.1
    ip dhcp excluded-address 192.168.20.1
    ip dhcp excluded-address 192.168.77.1
    ip dhcp excluded-address 192.168.88.1
    !
    ip dhcp pool staff
    network 192.168.20.0 255.255.255.0
    default-router 192.168.20.1
    ip dhcp pool wireless
    network 192.168.77.0 255.255.255.0
    default-router 192.168.77.1
    ip dhcp pool voice
    network 192.168.88.0 255.255.255.0
    default-router 192.168.88.1
    ip dhcp pool students
    network 192.168.10.0 255.255.255.0
    default-router 192.168.10.1
    !
    !
    !
    !
    !
    !
    !
    no ip domain-lookup
    ip domain-name h**p://www.abc.com
    ip name-server 192.168.0.2
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    ip address 192.168.0.2 255.255.255.0
    ip nat inside
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet0/1.1
    encapsulation dot1Q 1 native
    ip address 192.168.1.254 255.255.255.0
    !
    interface FastEthernet0/1.10
    encapsulation dot1Q 10
    ip address 192.168.10.254 255.255.255.0
    !
    interface FastEthernet0/1.20
    encapsulation dot1Q 20
    ip address 192.168.20.254 255.255.255.0
    !
    interface FastEthernet0/1.77
    encapsulation dot1Q 77
    ip address 192.168.77.254 255.255.255.0
    !
    interface FastEthernet0/1.88
    encapsulation dot1Q 88
    ip address 192.168.88.254 255.255.255.0
    !
    interface FastEthernet0/1.99
    encapsulation dot1Q 99
    ip address 192.168.99.1 255.255.255.0
    !
    interface Serial0/0
    no ip address
    encapsulation frame-relay ietf
    !
    interface Serial0/0.101 multipoint
    ip address 172.16.0.1 255.255.255.0
    frame-relay map ip 172.16.0.2 101 broadcast
    ip nat outside
    !
    interface Serial0/1
    no ip address
    shutdown
    !
    router rip
    !
    ip nat inside source static 192.168.0.2 172.16.0.4
    ip classless
    ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
    !
    !
    access-list 10 permit 192.168.10.0 0.0.0.255
    access-list 10 permit 192.168.20.0 0.0.0.255
    access-list 10 permit 192.168.77.0 0.0.0.255
    access-list 10 permit host 192.168.0.2
    !
    no cdp run
    !
    !
    !
    !
    !
    line con 0
    password 7 0822455D0A16
    login
    line vty 0 4
    password 7 0822455D0A16
    login
    line vty 5 15
    password 7 0822455D0A16
    login
    !
    !
    !
    end
  • Options
    EildorEildor Member Posts: 444
    I haven't got to studying NAT just yet... so I can't help you there.

    I do think if you provided your configuration it would make it easier for others to help you.

    Looks like you have ROAS configured there, can the PC's ping each other?
  • Options
    EildorEildor Member Posts: 444
    What's the IP address you have assigned to the ABC Intranet Server?
  • Options
    needforspeedneedforspeed Member Posts: 21 ■□□□□□□□□□
    eildor wrote: »
    what's the ip address you have assigned to the abc intranet server?
    192.168.0.2
  • Options
    EildorEildor Member Posts: 444
    But fa0/0 has 192.168.0.2 assigned to it -- or is there something I should know about?
  • Options
    needforspeedneedforspeed Member Posts: 21 ■□□□□□□□□□
    I changed it to 172.16.0.4 now.
  • Options
    EildorEildor Member Posts: 444
    I changed it to 172.16.0.4 now.

    Did that fix the problem?
  • Options
    needforspeedneedforspeed Member Posts: 21 ■□□□□□□□□□
    Eildor wrote: »
    Did that fix the problem?
    No, nothing can ping passed the router. Only the router itself can ping the switches, server and pc's. The router can't ping the wireless as well which is ip 192.168.77.0/24
  • Options
    needforspeedneedforspeed Member Posts: 21 ■□□□□□□□□□
    This is what one of the pc's look like.

    35idpfr.jpg
  • Options
    EildorEildor Member Posts: 444
    I like a challenge, you could send me the file if you want :D Don't know if I'll be able to help, but I'm sure someone else will provide a response soon.
  • Options
    okplayaokplaya Member Posts: 199
    I changed it to 172.16.0.4 now.

    So, you have the server with a 172.16 address and it's default gateway is 192.168?

    Looks like you have the "ip nat inside" on the wrong interface as well.

    What is your original intention with the lab?
  • Options
    hiddenknight821hiddenknight821 Member Posts: 1,209 ■■■■■■□□□□
    Now I think you might have an obvious solution to your problem. If the server is facing the NAT server on the router, then it should not be able to ping anything behind the NAT except the inside global IP addresses. Try pinging from the PCs and see if it can ping the server.

    If that doesn't work then try using debugging command on the router and ping from the server to see what message appears.
  • Options
    needforspeedneedforspeed Member Posts: 21 ■□□□□□□□□□
    I have to configure Static NAT to the Intranet Server using Global Address 172.16.0.4/24 mapped to the private address 192.168.0.2/24. Use Fa0/1 as the NAT inside port and s0/0/0.101 as the NAT outside.
  • Options
    LazydogLazydog Member Posts: 19 ■□□□□□□□□□
    Can you post the output from the following commands:

    sh ip int bri
    sh ip route
    --

    Regards
    Robert

    Smile....... it increases your face value!
  • Options
    MrRyteMrRyte Member Posts: 347 ■■■■□□□□□□
    !
    no ip domain-lookup
    ip domain-name h**p://www.abc.com
    ip name-server 192.168.0.2
    !
    icon_confused.gif:

    Not sure how this relates to your issues-but I think you're supposed to have ip domain-lookup enabled in this case.....

    .....right?
    NEXT UP: CompTIA Security+ :study:

    Life is a matter of choice not chance. The path to your destiny will be paved by the decisions that you make every day.
  • Options
    needforspeedneedforspeed Member Posts: 21 ■□□□□□□□□□
    If the server ip is not 192.168.0.2 same as the router Fa0/0 it can't ping the router for some reason?


    sh ip int bri
    Interface IP-Address OK? Method Status Protocol

    FastEthernet0/0 192.168.0.2 YES manual up up

    FastEthernet0/1 unassigned YES unset up up

    FastEthernet0/1.1 192.168.1.254 YES manual up up

    FastEthernet0/1.10 192.168.10.254 YES manual up up

    FastEthernet0/1.20 192.168.20.254 YES manual up up

    FastEthernet0/1.77 192.168.77.254 YES manual up up

    FastEthernet0/1.88 192.168.88.254 YES manual up up

    FastEthernet0/1.99 192.168.99.1 YES manual up up

    Serial0/0 unassigned YES unset up up

    Serial0/0.101 172.16.0.1 YES manual up up



    show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    * - candidate default, U - per-user static route, o - ODR
    P - periodic downloaded static route

    Gateway of last resort is 0.0.0.0 to network 0.0.0.0

    172.16.0.0/24 is subnetted, 1 subnets
    C 172.16.0.0 is directly connected, Serial0/0.101
    C 192.168.0.0/24 is directly connected, FastEthernet0/0
    C 192.168.1.0/24 is directly connected, FastEthernet0/1.1
    C 192.168.10.0/24 is directly connected, FastEthernet0/1.10
    C 192.168.20.0/24 is directly connected, FastEthernet0/1.20
    C 192.168.77.0/24 is directly connected, FastEthernet0/1.77
    C 192.168.88.0/24 is directly connected, FastEthernet0/1.88
    C 192.168.99.0/24 is directly connected, FastEthernet0/1.99
    C 192.168.100.0/24 is directly connected, FastEthernet0/1
    S* 0.0.0.0/0 is directly connected, FastEthernet0/0
  • Options
    MrRyteMrRyte Member Posts: 347 ■■■■□□□□□□
    What's the status? Have it resolved yet?
    NEXT UP: CompTIA Security+ :study:

    Life is a matter of choice not chance. The path to your destiny will be paved by the decisions that you make every day.
  • Options
    PristonPriston Member Posts: 999 ■■■■□□□□□□
    On your picture you have 2 devices with the same address, the FA port connected to your server and your server. If you did change the address on your server like you posted you need to make sure the FA port connected to your server is on the same subnet, but not the same address.
    A.A.S. in Networking Technologies
    A+, Network+, CCNA
  • Options
    Forsaken_GAForsaken_GA Member Posts: 4,024
    I have to configure Static NAT to the Intranet Server using Global Address 172.16.0.4/24 mapped to the private address 192.168.0.2/24. Use Fa0/1 as the NAT inside port and s0/0/0.101 as the NAT outside.

    You should probably review your configuration and look at what interfaces you have set for nat.

    If you're setting up NAT between the intranet servers and the PC's, the intranet server is not going to be able to ping the PC's directly, btw. The PC's should be able to ping the server, because the Router will translate the pings to look like it's coming from itself, but as far as the intranet server is concerned, the router is the only node it's connected to, and the only node it sees traffic from, so it's the only thing it should be able to ping.
Sign In or Register to comment.