Help configuring RIP and OSPF

mallyg27mallyg27 Member Posts: 139
I have a simple network in which im using RIP and OSPF, for some reason my routing table is not showing neighbors. Any ideas? The information below is just from two routers running OSPF. My routing table doesn't show OSPF.

Router A
interface FastEthernet0/0
ip address 150.7.32.1 255.255.240.0
duplex auto
speed auto
!
interface Serial0/2/0
ip address 192.168.7.97 255.255.255.224
clock rate 64000
!
interface Serial0/3/0
ip address 192.168.7.66 255.255.255.224
clock rate 64000
!
router ospf 1
log-adjacency-changes
network 192.168.7.0 0.0.0.31 area 0
network 150.7.32.0 0.0.15.255 area 0

Router B

interface FastEthernet0/0
ip address 150.7.48.1 255.255.240.0
duplex auto
speed auto
!
interface Serial0/2/0
ip address 192.168.7.34 255.255.255.224
clock rate 64000
!
interface Serial0/3/0
ip address 192.168.7.65 255.255.255.224
!
router ospf 1
log-adjacency-changes
network 192.168.7.0 0.0.0.31 area 0
network 150.7.48.0 0.0.15.255 area 0

Comments

  • amb1s1amb1s1 Member Posts: 408
    mallyg27 wrote: »
    I have a simple network in which im using RIP and OSPF, for some reason my routing table is not showing neighbors. Any ideas? The information below is just from two routers running OSPF. My routing table doesn't show OSPF.

    Router A
    interface FastEthernet0/0
    ip address 150.7.32.1 255.255.240.0
    duplex auto
    speed auto
    !
    interface Serial0/2/0
    ip address 192.168.7.97 255.255.255.224
    clock rate 64000
    !
    interface Serial0/3/0
    ip address 192.168.7.66 255.255.255.224
    clock rate 64000
    !
    router ospf 1
    log-adjacency-changes
    network 192.168.7.0 0.0.0.31 area 0
    network 150.7.32.0 0.0.15.255 area 0

    Router B

    interface FastEthernet0/0
    ip address 150.7.48.1 255.255.240.0
    duplex auto
    speed auto
    !
    interface Serial0/2/0
    ip address 192.168.7.34 255.255.255.224
    clock rate 64000
    !
    interface Serial0/3/0
    ip address 192.168.7.65 255.255.255.224
    !
    router ospf 1
    log-adjacency-changes
    network 192.168.7.0 0.0.0.31 area 0
    network 150.7.48.0 0.0.15.255 area 0

    The reason that you are not getting OSPF neighbor is because all of you address are in different subnet
    You are using a subnet mast of 255.255.255.224 that it give you a range for:
    192.168.7.0 - 192.168.7.95
    192.168.7.96 - 192.168.7.127

    The same reason for the 150.7. address
    The ip range for the 150.7. are
    150.7.48.0 - 150.7.63.255
    150.7.32.0 - 150.7.47.255
    David G.
    http://gomezd.com <
    My Tshoot test Blog
    http://twitter.com/ipnet255
  • amb1s1amb1s1 Member Posts: 408
    Try the following:

    Router A
    interface FastEthernet0/0
    ip address 150.7.48.2 255.255.240.0
    duplex auto
    speed auto
    !
    interface Serial0/2/0
    ip address 192.168.7.97 255.255.255.224
    clock rate 64000
    !
    interface Serial0/3/0
    ip address 192.168.7.66 255.255.255.224
    clock rate 64000
    !
    router ospf 1
    log-adjacency-changes
    network 192.168.7.0 0.0.0.31 area 0
    network 150.7.32.0 0.0.15.255 area 0

    Router B

    interface FastEthernet0/0
    ip address 150.7.48.1 255.255.240.0
    duplex auto
    speed auto
    !
    interface Serial0/2/0
    ip address 192.168.7.98 255.255.255.224
    clock rate 64000
    !
    interface Serial0/3/0
    ip address 192.168.7.65 255.255.255.224
    !
    router ospf 1
    log-adjacency-changes
    network 192.168.7.0 0.0.0.31 area 0
    network 150.7.48.0 0.0.15.255 area 0
    network 192.168.7.96 0.0.0.31 area 0


    I'm assuming that they are connected as follow
    RA Fa0/0
    RB Fa0/0
    RA s0/2/0
    RB Fa0/2/0
    RA Fa0/3/0
    RB Fa0/3/0
    David G.
    http://gomezd.com <
    My Tshoot test Blog
    http://twitter.com/ipnet255
  • instant000instant000 Member Posts: 1,745
    mallyg27 wrote: »
    I have a simple network in which im using RIP and OSPF, for some reason my routing table is not showing neighbors. Any ideas? The information below is just from two routers running OSPF. My routing table doesn't show OSPF.

    Router A
    interface FastEthernet0/0
    ip address 150.7.32.1 255.255.240.0
    duplex auto
    speed auto
    !
    interface Serial0/2/0
    ip address 192.168.7.97 255.255.255.224
    clock rate 64000
    !
    interface Serial0/3/0
    ip address 192.168.7.66 255.255.255.224
    clock rate 64000
    !
    router ospf 1
    log-adjacency-changes
    network 192.168.7.0 0.0.0.31 area 0
    network 150.7.32.0 0.0.15.255 area 0

    Router B

    interface FastEthernet0/0
    ip address 150.7.48.1 255.255.240.0
    duplex auto
    speed auto
    !
    interface Serial0/2/0
    ip address 192.168.7.34 255.255.255.224
    clock rate 64000
    !
    interface Serial0/3/0
    ip address 192.168.7.65 255.255.255.224
    !
    router ospf 1
    log-adjacency-changes
    network 192.168.7.0 0.0.0.31 area 0
    network 150.7.48.0 0.0.15.255 area 0

    I'm curious about many things here.

    1. Which interfaces are connected together?
    2. Why is clock rate showing on both routers? (I see it on both serials on one router, then on one serial of the other router ... something is up) I'm only to Chapter 6 of Todd Lammle, but I'm sure one of the earlier chapters mentioned that you set the clocking on only one side of the connection, not both.
    3. What is your interface status?
    4. Can you confirm the address scheme that you are using for your networks?

    We had a conversation about OSPF the other day, quite good, I think. Anyway, you can't get neighbors without the interfaces being in the same subnet.

    If you could draw a picture, it might help us and you to understand what is going on here. But, right now, I'm suspecting addressing.
    Currently Working: CCIE R&S
    LinkedIn: http://www.linkedin.com/in/lewislampkin (Please connect: Just say you're from TechExams.Net!)
  • ehndeehnde Member Posts: 1,103
    Yes, very good conversation about OSPF the other day indeed!

    instant000 pegged the issue. All of this stuff needs to match if you want neighbor adjacency:
    · subnet mask used on the subnet
    · subnet number
    · hello interval
    · dead interval
    · OSPF area ID
    · value of the stub area flag
    Climb a mountain, tell no one.
  • amb1s1amb1s1 Member Posts: 408
    instant000 wrote: »
    2. Why is clock rate showing on both routers? (I see it on both serials on one router, then on one serial of the other router ... something is up) I'm only to Chapter 6 of Todd Lammle, but I'm sure one of the earlier chapters mentioned that you set the clocking on only one side of the connection, not both.

    You can set the clock rate to both side without causing any problem. In CCIE the encourage you to set it on both side and you don't loose any point. Only the DCE is going to actually take the command the other just disregard. I always set up the clock rate on both side and I never encounter any problem. In this case out of hand the IP address are indifferent subnet, but like you mention they can be connected to different interfaces. Without any draw topology is going to be hard to tell you what exactly what it is wrong. Now we are just give you a good guess
    David G.
    http://gomezd.com <
    My Tshoot test Blog
    http://twitter.com/ipnet255
  • mallyg27mallyg27 Member Posts: 139
    amb1s1 wrote: »
    The reason that you are not getting OSPF neighbor is because all of you address are in different subnet
    You are using a subnet mast of 255.255.255.224 that it give you a range for:
    192.168.7.0 - 192.168.7.95
    192.168.7.96 - 192.168.7.127

    The same reason for the 150.7. address
    The ip range for the 150.7. are
    150.7.48.0 - 150.7.63.255
    150.7.32.0 - 150.7.47.255

    Yes, I'm using a different subnet between routers. The scheme I'm using between routers 192.168.7.0.... 255.255.255.224. Isn't my range
    192.168.7.0-192.168.7.32
    192.168.7.33-192.168.7.64....increment by 32 right?

    I'm using the 150.7.0.0...255.255.240.0 for the ethernet side.
  • ehndeehnde Member Posts: 1,103
    You did your subnetting correctly, but my understanding is that your two routers need to be in the same subnet to form an adjacency.
    Climb a mountain, tell no one.
  • mallyg27mallyg27 Member Posts: 139
    instant000 wrote: »
    I'm curious about many things here.

    1. Which interfaces are connected together?
    2. Why is clock rate showing on both routers? (I see it on both serials on one router, then on one serial of the other router ... something is up) I'm only to Chapter 6 of Todd Lammle, but I'm sure one of the earlier chapters mentioned that you set the clocking on only one side of the connection, not both.
    3. What is your interface status?
    4. Can you confirm the address scheme that you are using for your networks?

    We had a conversation about OSPF the other day, quite good, I think. Anyway, you can't get neighbors without the interfaces being in the same subnet.

    If you could draw a picture, it might help us and you to understand what is going on here. But, right now, I'm suspecting addressing.

    I have a total of six routers thats why you see clock rate on the routers on showing. I figured if I can get OSPF to work between these two routers I can get the rest to work also. All interfaces show UP.
  • amb1s1amb1s1 Member Posts: 408
    mallyg27 wrote: »
    Yes, I'm using a different subnet between routers. The scheme I'm using between routers 192.168.7.0.... 255.255.255.224. Isn't my range
    192.168.7.0-192.168.7.32
    192.168.7.33-192.168.7.64....increment by 32 right?

    I'm using the 150.7.0.0...255.255.240.0 for the ethernet side.

    Yes you are right the increment is 32, but you are still using the wrong IP address.

    Are you connecting the routers like the following?
    RA Fa0/0
    RB Fa0/0
    RA s0/2/0
    RB Fa0/2/0
    RA Fa0/3/0
    RB Fa0/3/0

    so you have the following ip range
    192.168.7.0
    192.168.7.31 None of your device are in this range
    192.168.7.32 ---- 192.168.7.63 RB S0/2/0 is in this range
    192.168.7.64 ---- 192.168.7.95 RA s0/2/0 and RB S0/3/0 are in this range
    192.168.7.96 --- 192.168.7.127 RA s0/2/0 is in this range

    You have ip address all over the place, but because we don't know how you devices are connect is going hard to tell how to fix it.

    But the first thing is that you are advertise the following range 192.168.7.0 --- 192.168.7.31 with the ospf network statement "network 192.168.7.0 0.0.0.31 area 0" none of the device are in that network, so it basically advertising nothing.
    David G.
    http://gomezd.com <
    My Tshoot test Blog
    http://twitter.com/ipnet255
  • amb1s1amb1s1 Member Posts: 408
    When you have two Routers connect to each other, each interfaces has to be in the same subnet "Aka range"
    example:

    Router A Fa0/0 connect to Router Fa0/0

    Router A
    Interface Fa0/0
    192.168.7.1 255.255.255.224

    Router B
    Interface Fa0/0
    192.168.7.30 255.255.255.224

    Both of the interfaces are in the same subnet Aka the same range
    192.168.7.0 225.255.255.224 range is 192.168.7.1
    192.168.7.31 leaving the last ip for the broadcast address.
    David G.
    http://gomezd.com <
    My Tshoot test Blog
    http://twitter.com/ipnet255
  • mallyg27mallyg27 Member Posts: 139
    In my example: RA serial 3
    RB serial 3....Both of them are in the same range.
  • mallyg27mallyg27 Member Posts: 139
    I'm going to draw this thing up in vizio
  • DPGDPG Member Posts: 780 ■■■■■□□□□□
    mallyg27 wrote: »
    In my example: RA serial 3
    RB serial 3....Both of them are in the same range.

    They are indeed in the same range. The issue is with your network statement.

    network 192.168.7.0 0.0.0.31 area 0

    This runs OSPF on the IP range 192.168.7.1 - 192.168.7.30.
    Neither router is in this range.
  • amb1s1amb1s1 Member Posts: 408
    mallyg27 wrote: »
    In my example: RA serial 3
    RB serial 3....Both of them are in the same range.
    OK There are in the same network, so the network statement under OSPF should be as follow

    network 192.168.7.64 0.0.0.31 area 0



    and take the network statement that you had
    no network 192.168.7.0 0.0.0.31 area 0
    David G.
    http://gomezd.com <
    My Tshoot test Blog
    http://twitter.com/ipnet255
  • mallyg27mallyg27 Member Posts: 139
    amb1s1 wrote: »
    OK There are in the same network, so the network statement under OSPF should be as follow

    network 192.168.7.64 0.0.0.31 area 0



    and take the network statement that you had
    no network 192.168.7.0 0.0.0.31 area 0

    That solved it. Thanks a lot.
  • mallyg27mallyg27 Member Posts: 139
    Another question. On the router that's using RIP and OSPF, do I specify a network on all the interfaces for each protocol or do I just specify one protocol per interface. Also, what protocol goes on the ethernet side?
  • jwashington1981jwashington1981 Member Posts: 137
    mallyg27 wrote: »
    Another question. On the router that's using RIP and OSPF, do I specify a network on all the interfaces for each protocol or do I just specify one protocol per interface. Also, what protocol goes on the ethernet side?

    Do you want to keep one routing protocol on one side of the network and the other routing protocol on the other side of the network? If that is the case, then you have the option of performing redistribution on your router for both protocols. What that does is if you have a RIP update coming from one side of that router that you want to go to the other side, it will convert it to an OSPF route, and vice versa.
  • mallyg27mallyg27 Member Posts: 139
    Do you want to keep one routing protocol on one side of the network and the other routing protocol on the other side of the network? If that is the case, then you have the option of performing redistribution on your router for both protocols. What that does is if you have a RIP update coming from one side of that router that you want to go to the other side, it will convert it to an OSPF route, and vice versa.


    I have RA-Serial1
    RB-Seraial3
    RA-FA0
    Computer1
    RB-FA0
    computer2

    RA is only using RIP, and RB is using RIP and OSPF. From computer2, Ican't seem to ping computer1. Below is my configuration.

    RA

    interface FastEthernet0/0
    ip address 150.7.0.1 255.255.240.0
    duplex auto
    speed auto
    !
    interface Serial0/1/0
    ip address 192.168.7.130 255.255.255.224
    !
    interface Vlan1
    no ip address
    !
    !
    router rip
    version 2
    network 150.7.0.0
    network 192.168.7.0

    RB

    interface FastEthernet0/0
    ip address 150.7.16.2 255.255.240.0
    duplex auto
    speed auto
    interface Serial0/2/0
    ip address 192.168.7.98 255.255.255.224
    !
    interface Serial0/3/0
    ip address 192.168.7.129 255.255.255.224
    clock rate 64000
    !
    router ospf 1
    log-adjacency-changes
    redistribute rip metric 50000 subnets
    network 150.7.16.0 0.0.15.255 area 0
    network 192.168.7.96 0.0.0.31 area 0
    !
    router rip
    version 2
    redistribute ospf 1 metric 3
    network 192.168.7.0

    Computer1

    IP-150.7.0.2
    gateway-150.7.0.1

    Computer2
    IP-150.7.16.1
    gateway-150.7.16.2
Sign In or Register to comment.