password recovery/factory default

chusomechusome Posts: 5Member ■□□□□□□□□□
I recently bought a cisco 2501 router from ebay for educational purposes. It
came with preconfigured passwords which I didn't have so I used the
instructions at the following link:
http://www.cisco.com/warp/public/474/pswdrec_2500.htm

However when I get to the point where you should type in startup-config
running-config I get the response unknown command or computer name....

As well the prompt I have is different from the example. It shows:
router(boot)>
instead of
router>

the same applies for enable mode:
router(boot)#
instead of
router#

and now every time I power the router it gives me the setup program (twice
through)

Very confused here, all help is appreciated.

Comments

  • wildfirewildfire Posts: 654Member
    The link you provided aboved does not work, but just curious what value did you change the config register to? I think instead of putting it into ignore startup config 0x2142 (defult config is 0x2102)

    here is the method I use

    1.
    use hyperterminal --- while router boots --- do Ctrl + Break ( to get into rom monitor)

    2.
    to change configuration register to ignore nvram.....

    for 2500, >o/r 0x2142

    3.
    to reboot the router.....

    2500, >I

    4.
    after this, router boots without looking nvram.....
    #copy start run
    #config t
    (config)#enable secret
    (config)#config-register 0x2102
    #copy run start
    #reload
    Looking for CCIE lab study partnerts, in the UK or Online.
  • kplabkplab Posts: 101Member
    The "router(boot)>" prompt shows that you are in the rxboot mode, i.e. the router is running the limited function IOS stored in ROM. You have probably changed the configuration register to 0x2141. Change it back to 0x2142 and continue with the remaining steps in the procedure.

    http://www.cisco.com/warp/public/474/pswdrec_2500.html
    KPLAB
    www.kp-lab.com - Free CCNA, CCNP, and Network+ Study Guides
  • chusomechusome Posts: 5Member ■□□□□□□□□□
    ok I understand a little more here now, so the config register is your boot mode. (I work with MS products too often)

    So here's what I've found.
    In 0x2142 mode I get prompted to setup twice and prompt is router(boot)>
    In 0x2141 mode I only get prompted once and prompt is router(boot)>
    In 0x2102 mode I get the following:
    --- System Configuration Dia
    Copyright (c) 1986-1994 by cisco Systems

    Refer to the 'Getting Starte
    2500 processor with 1024 Kbytes of main memory
    Defaul

    Restricted Rights Legend

    Use, duplication, or disclosure by the Government isting:
    subject to restrictions as set forth in subparagraph
    Is this interface in use? [yes]:
    (c) of the Commercial Computer Software - Restricted interface Serial0:

    Rights clause at FAR sec. 52.227-19 and subparagraph

    Configuring interface Serial1:
    (c) (1) (ii) of the Rights in Technical Data and Computer[yes]: no
    No usable
    Software clause at DFARS sec. 252.227-7013.rap, Version 4.14(9.1),



    cisco 2500 (68030) processor (revision A) with 1020K/1024K bytes of memory.
    Processor board serial number 01523424
    DDN X.25 software, Version 2.0, NET2 and BFE compliant.
    1 Ethernet/IEEE 802.3 interface.
    2 Serial network interfaces.
    32K bytes of non-volatile configuration memory.

    Unknown or ambiguous service arg - udp-small-servers
    Illegal IP keyword - mroute-cache
    Invalid IP MTU specified
    Illegal IP keyword - mroute-cache
    Bad interface specification
    No interface specified - IP address
    Bad interface specification
    No interface specified - IP address


    Press RETURN to get started!


    GP(boot)>

    and as you can see I still get the (boot) prompt. This is the way it was oringally setup. Also when ever I run config t I don't get a prompt, instead I get the following output:

    Enter configuration commands, one per line.
    Edit with DELETE, CTRL/W, and CTRL/U; end with CTRL/Z

    thanks for the info but I'm still a little lost here....

  • chusomechusome Posts: 5Member ■□□□□□□□□□
    so yes, the real problem seems that i might have gotten screwed here.

    There is no ios on the flash memory, and according to my sources you can only buy the images.

    Does anyone know if there is a place where one can get ios images from?
  • YankeeYankee Posts: 157Member
    Doesn't look like he has any RAM either...open the chasis and I suspect you will see empty slots.

    Yankee
  • chusomechusome Posts: 5Member ■□□□□□□□□□
    there is a 1 MB of internal ram
    I also have some simms to upgrade it as well so thats not an issue, just need ios file.
  • tunerXtunerX Posts: 447Member ■■■□□□□□□□
    You can use IOSHunter to get some older images. It is up to you to register the image for use after you have already downloaded it.
  • chusomechusome Posts: 5Member ■□□□□□□□□□
    Ok, now I'm seeing a little further into it. (again)

    There is internal working ram, but no flash ram. So now I do have an ios image, but need a pair of 8MB flash simms and a single 16MB dram, which I do have some spares about from old pc's. Will this work or potentially cause damage?
Sign In or Register to comment.