OSPF and EIGRP

in CCNA & CCENT
I can't ping from pc2 to pc0. Its says "Reply from 150.7.32.1: Destination host unreachable." I checked the routing table and there is no route to PC0. How could that be? All we PCs are configured correctly. Any ideas?
Router0
interface FastEthernet0/0
ip address 150.7.0.1 255.255.240.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/1/0
ip address 192.168.7.130 255.255.255.224
!
interface Vlan1
no ip address
shutdown
!
router eigrp 100
network 150.7.0.0
network 192.168.7.0
no auto-summary
!
ip classless
!
!
!
no cdp run
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end
Router1
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
!
!
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
!
!
!
!
interface FastEthernet0/0
ip address 150.7.16.2 255.255.240.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/2/0
ip address 192.168.7.98 255.255.255.224
ip ospf authentication-key ccna3
!
interface Serial0/3/0
ip address 192.168.7.129 255.255.255.224
clock rate 64000
!
interface Vlan1
no ip address
shutdown
!
router eigrp 100
redistribute ospf 100 metric 10000 10 40 10 1500
network 192.168.7.0
network 150.7.0.0
no auto-summary
!
router ospf 1
log-adjacency-changes
area 0 authentication
redistribute eigrp 100 subnets
network 192.168.7.96 0.0.0.31 area 0
network 150.7.16.0 0.0.15.255 area 0
network 192.168.7.128 0.0.0.31 area 0
default-information originate
!
ip classless
!
!
!
no cdp run
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end
Router2
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R3
!
!
!
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
!
!
!
!
interface FastEthernet0/0
ip address 150.7.32.1 255.255.240.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/2/0
ip address 192.168.7.97 255.255.255.224
ip ospf authentication-key ccna3
clock rate 64000
!
interface Serial0/3/0
ip address 192.168.7.66 255.255.255.224
clock rate 64000
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
area 0 authentication
network 150.7.32.0 0.0.15.255 area 0
network 192.168.7.64 0.0.0.31 area 0
network 192.168.7.96 0.0.0.31 area 0
!
ip classless
!
!
!
no cdp run
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end
Router0
interface FastEthernet0/0
ip address 150.7.0.1 255.255.240.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/1/0
ip address 192.168.7.130 255.255.255.224
!
interface Vlan1
no ip address
shutdown
!
router eigrp 100
network 150.7.0.0
network 192.168.7.0
no auto-summary
!
ip classless
!
!
!
no cdp run
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end
Router1
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
!
!
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
!
!
!
!
interface FastEthernet0/0
ip address 150.7.16.2 255.255.240.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/2/0
ip address 192.168.7.98 255.255.255.224
ip ospf authentication-key ccna3
!
interface Serial0/3/0
ip address 192.168.7.129 255.255.255.224
clock rate 64000
!
interface Vlan1
no ip address
shutdown
!
router eigrp 100
redistribute ospf 100 metric 10000 10 40 10 1500
network 192.168.7.0
network 150.7.0.0
no auto-summary
!
router ospf 1
log-adjacency-changes
area 0 authentication
redistribute eigrp 100 subnets
network 192.168.7.96 0.0.0.31 area 0
network 150.7.16.0 0.0.15.255 area 0
network 192.168.7.128 0.0.0.31 area 0
default-information originate
!
ip classless
!
!
!
no cdp run
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end
Router2
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R3
!
!
!
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
!
!
!
!
interface FastEthernet0/0
ip address 150.7.32.1 255.255.240.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/2/0
ip address 192.168.7.97 255.255.255.224
ip ospf authentication-key ccna3
clock rate 64000
!
interface Serial0/3/0
ip address 192.168.7.66 255.255.255.224
clock rate 64000
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
area 0 authentication
network 150.7.32.0 0.0.15.255 area 0
network 192.168.7.64 0.0.0.31 area 0
network 192.168.7.96 0.0.0.31 area 0
!
ip classless
!
!
!
no cdp run
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end
Comments
-
networker050184 Mod Posts: 11,962 Mod
Might want to do a little more reading on EIGRP redistribution.An expert is a man who has made all the mistakes which can be made. -
mallyg27 Member Posts: 139
networker050184 wrote: »Might want to do a little more reading on EIGRP redistribution.
But I am doing EIGRP redistribution. -
mallyg27 Member Posts: 139
I just now used this command....
router eigrp 100
redistribute ospf 100 metric 10000 10 40 10 1500
I now see the in the routing table of router2 a route to 150.7.0.0 but now when I ping that computer it :"times out." -
jwashington1981 Member Posts: 137
When you redistribute, you need to redistribute in both directions. Just as you redistributed OSPF routes to look like EIGRP routes, you also need to redistribute EIGRP routes to look like OSPF routes on that same router that you're doing the redistributing on.
Edit: Ignore that. I just noticed that you did indeed do that on router 1.
You said you can't ping from PC2 to PC0. Can you ping in the other direction from PC0 to PC2?
Also, can you do a sh ip route and show us the routing tables of those three routers? -
mallyg27 Member Posts: 139
jwashington1981 wrote: »When you redistribute, you need to redistribute in both directions. Just as you redistributed OSPF routes to look like EIGRP routes, you also need to redistribute EIGRP routes to look like OSPF routes on that same router that you're doing the redistributing on.
Edit: Ignore that. I just noticed that you did indeed do that on router 1.
You said you can't ping from PC2 to PC0. Can you ping in the other direction from PC0 to PC2?
Also, can you do a sh ip route and show us the routing tables of those three routers?
Going from PC0 to PC2 I get "Reply from 150.7.0.1: Destination host unreachable."
Router0
Gateway of last resort is not set
150.7.0.0/20 is subnetted, 2 subnets
C 150.7.0.0 is directly connected, FastEthernet0/0
D 150.7.16.0 [90/20514560] via 192.168.7.129, 00:36:58, Serial0/1/0
192.168.7.0/27 is subnetted, 2 subnets
D 192.168.7.96 [90/21024000] via 192.168.7.129, 00:19:06, Serial0/1/0
C 192.168.7.128 is directly connected, Serial0/1/0
Router1
Gateway of last resort is not set
150.7.0.0/20 is subnetted, 4 subnets
D 150.7.0.0 [90/20514560] via 192.168.7.130, 00:38:03, Serial0/3/0
C 150.7.16.0 is directly connected, FastEthernet0/0
O 150.7.32.0 [110/782] via 192.168.7.97, 00:19:55, Serial0/2/0
O 150.7.48.0 [110/1563] via 192.168.7.97, 00:19:55, Serial0/2/0
192.168.7.0/27 is subnetted, 4 subnets
O 192.168.7.32 [110/2343] via 192.168.7.97, 00:19:55, Serial0/2/0
O 192.168.7.64 [110/1562] via 192.168.7.97, 00:19:55, Serial0/2/0
C 192.168.7.96 is directly connected, Serial0/2/0
C 192.168.7.128 is directly connected, Serial0/3/0
Router2
Gateway of last resort is not set
150.7.0.0/20 is subnetted, 4 subnets
O E2 150.7.0.0 [110/20] via 192.168.7.98, 00:15:36, Serial0/2/0
O 150.7.16.0 [110/782] via 192.168.7.98, 00:15:36, Serial0/2/0
C 150.7.32.0 is directly connected, FastEthernet0/0
O 150.7.48.0 [110/782] via 192.168.7.65, 00:16:19, Serial0/3/0
192.168.7.0/27 is subnetted, 4 subnets
O 192.168.7.32 [110/1562] via 192.168.7.65, 00:16:19, Serial0/3/0
C 192.168.7.64 is directly connected, Serial0/3/0
C 192.168.7.96 is directly connected, Serial0/2/0
O 192.168.7.128 [110/1562] via 192.168.7.98, 00:15:36, Serial0/2/0
-
mallyg27 Member Posts: 139
Can you upload the packet tracer file?
I don't know how to upload this type of file. -
jwashington1981 Member Posts: 137
I don't know how to upload this type of file.
You should be able to do it the same way you uploaded the picture of the diagram. -
danielno8 Member Posts: 34 ■■□□□□□□□□
-
mallyg27 Member Posts: 139
jwashington1981 wrote: »You should be able to do it the same way you uploaded the picture of the diagram.
It tells me invalid file. Must be a picture extension, like bmp,jpeg,etc... -
mallyg27 Member Posts: 139
It has to be something with my redistribution because Router0 hasn't learned any routes from router1. I just don't see how to fix it. -
mallyg27 Member Posts: 139
Solved.
Changed redistribute ospf 100 metric 10000 10 40 10 1500 to
redistribute ospf 1 metric 10000 10 40 10 1500 -
jwashington1981 Member Posts: 137
Ha! Adding those extra numbers will do it. Can't believe I didn't see that. -
danielno8 Member Posts: 34 ■■□□□□□□□□
It has to be something with my redistribution because Router0 hasn't learned any routes from router1. I just don't see how to fix it.
bah i don't have the latest version so can't open it. I'm sure someone will be a long to clear it up for you.
I'm not sure this exactly the cause, btu OSPF will only redistribute CLASSFUL subnets by default. -
Chris_ Member Posts: 326
I've seen a few problems like this posted in the CCNA section recently. Have they beefed up the CCNA to include thongs like redistribution and multiarea OSPF, or is it just that people are expanding their horizons and having a go? ( which is a good thing)Going all out for Voice. Don't worry Data; I'll never forget you
:study: CVoice [X] CIPT 1 [ ] CIPT 2 [ ] CAPPS [ ] TVOICE [ ] -
alan2308 Member Posts: 1,854 ■■■■■■■■□□
I've seen a few problems like this posted in the CCNA section recently. Have they beefed up the CCNA to include thongs like redistribution and multiarea OSPF, or is it just that people are expanding their horizons and having a go? ( which is a good thing)
I took the CNA courses a year ago and took the 640-802 last November. In class we covered that these things existed, but that was the extent of it. So I would say that it's the later. -
danielno8 Member Posts: 34 ■■□□□□□□□□
I've seen a few problems like this posted in the CCNA section recently. Have they beefed up the CCNA to include thongs like redistribution and multiarea OSPF, or is it just that people are expanding their horizons and having a go? ( which is a good thing)
redistribution and multi area are not covered in the CCNA exam. But many of the study materials used touch on these subjects, and i guess being the curious bunch us IT folks are, we usually dig a little deeper -
jwashington1981 Member Posts: 137
In the Routing and Switching Lab class I took as part of my degree program, we had to perform redistribution between EIGRP and RIP in one of the labs even though we hadn't done it before. So we kinda learned it on the fly.