OSPF and Static redistribution

in CCNA & CCENT
Let me first say this redistribution tough because it varies from protocol to protocol. I been searching all over the internet and can't figure out why im having this issue. Why doesn't OSPF avertise its routes to router0? I'm redistributing static into OSPF.
Router0
interface FastEthernet0/0
ip address 150.7.0.1 255.255.240.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/1/0
ip address 192.168.7.130 255.255.255.224
!
interface Vlan1
no ip address
shutdown
!
router rip
!
ip classless
ip route 192.168.7.96 255.255.255.224 Serial0/1/0
!
!
!
no cdp run
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end
Router 1
interface FastEthernet0/0
ip address 150.7.16.2 255.255.240.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/2/0
ip address 192.168.7.98 255.255.255.224
!
interface Serial0/3/0
ip address 192.168.7.129 255.255.255.224
clock rate 64000
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
area 0 authentication
redistribute static metric 1 subnets
network 192.168.7.96 0.0.0.31 area 0
network 192.168.7.128 0.0.0.31 area 0
network 150.7.16.0 0.0.15.255 area 0
default-information originate
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/3/0
!
!
!
no cdp run
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end
Router 2
interface FastEthernet0/0
ip address 150.7.32.1 255.255.240.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/2/0
ip address 192.168.7.97 255.255.255.224
clock rate 64000
!
interface Serial0/3/0
ip address 192.168.7.66 255.255.255.224
clock rate 64000
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
area 0 authentication
network 192.168.7.64 0.0.0.31 area 0
network 192.168.7.96 0.0.0.31 area 0
network 150.7.32.0 0.0.15.255 area 0
!
ip classless
!
!
!
no cdp run
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end
Router 0 Routing table
Gateway of last resort is not set
150.7.0.0/20 is subnetted, 1 subnets
C 150.7.0.0 is directly connected, FastEthernet0/0
192.168.7.0/27 is subnetted, 2 subnets
S 192.168.7.96 is directly connected, Serial0/1/0
C 192.168.7.128 is directly connected, Serial0/1/0
Router1 Routing table
ateway of last resort is 0.0.0.0 to network 0.0.0.0
150.7.0.0/20 is subnetted, 4 subnets
C 150.7.16.0 is directly connected, FastEthernet0/0
O 150.7.32.0 [110/782] via 192.168.7.97, 00:32:41, Serial0/2/0
O 150.7.48.0 [110/1563] via 192.168.7.97, 00:32:31, Serial0/2/0
O 150.7.64.0 [110/2344] via 192.168.7.97, 00:32:31, Serial0/2/0
192.168.7.0/27 is subnetted, 5 subnets
O 192.168.7.0 [110/3124] via 192.168.7.97, 00:26:33, Serial0/2/0
O 192.168.7.32 [110/2343] via 192.168.7.97, 00:32:31, Serial0/2/0
O 192.168.7.64 [110/1562] via 192.168.7.97, 00:32:41, Serial0/2/0
C 192.168.7.96 is directly connected, Serial0/2/0
C 192.168.7.128 is directly connected, Serial0/3/0
S* 0.0.0.0/0 is directly connected, Serial0/3/0
Router2 Routing table
150.7.0.0/20 is subnetted, 4 subnets
O 150.7.16.0 [110/782] via 192.168.7.98, 00:33:13, Serial0/2/0
C 150.7.32.0 is directly connected, FastEthernet0/0
O 150.7.48.0 [110/782] via 192.168.7.65, 00:33:13, Serial0/3/0
O 150.7.64.0 [110/1563] via 192.168.7.65, 00:33:13, Serial0/3/0
192.168.7.0/27 is subnetted, 5 subnets
O 192.168.7.0 [110/2343] via 192.168.7.65, 00:27:09, Serial0/3/0
O 192.168.7.32 [110/1562] via 192.168.7.65, 00:33:13, Serial0/3/0
C 192.168.7.64 is directly connected, Serial0/3/0
C 192.168.7.96 is directly connected, Serial0/2/0
O 192.168.7.128 [110/1562] via 192.168.7.98, 00:33:13, Serial0/2/0
O*E2 0.0.0.0/0 [110/1] via 192.168.7.98, 00:03:13, Serial0/2/0
Router0
interface FastEthernet0/0
ip address 150.7.0.1 255.255.240.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/1/0
ip address 192.168.7.130 255.255.255.224
!
interface Vlan1
no ip address
shutdown
!
router rip
!
ip classless
ip route 192.168.7.96 255.255.255.224 Serial0/1/0
!
!
!
no cdp run
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end
Router 1
interface FastEthernet0/0
ip address 150.7.16.2 255.255.240.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/2/0
ip address 192.168.7.98 255.255.255.224
!
interface Serial0/3/0
ip address 192.168.7.129 255.255.255.224
clock rate 64000
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
area 0 authentication
redistribute static metric 1 subnets
network 192.168.7.96 0.0.0.31 area 0
network 192.168.7.128 0.0.0.31 area 0
network 150.7.16.0 0.0.15.255 area 0
default-information originate
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/3/0
!
!
!
no cdp run
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end
Router 2
interface FastEthernet0/0
ip address 150.7.32.1 255.255.240.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/2/0
ip address 192.168.7.97 255.255.255.224
clock rate 64000
!
interface Serial0/3/0
ip address 192.168.7.66 255.255.255.224
clock rate 64000
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
area 0 authentication
network 192.168.7.64 0.0.0.31 area 0
network 192.168.7.96 0.0.0.31 area 0
network 150.7.32.0 0.0.15.255 area 0
!
ip classless
!
!
!
no cdp run
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end
Router 0 Routing table
Gateway of last resort is not set
150.7.0.0/20 is subnetted, 1 subnets
C 150.7.0.0 is directly connected, FastEthernet0/0
192.168.7.0/27 is subnetted, 2 subnets
S 192.168.7.96 is directly connected, Serial0/1/0
C 192.168.7.128 is directly connected, Serial0/1/0
Router1 Routing table
ateway of last resort is 0.0.0.0 to network 0.0.0.0
150.7.0.0/20 is subnetted, 4 subnets
C 150.7.16.0 is directly connected, FastEthernet0/0
O 150.7.32.0 [110/782] via 192.168.7.97, 00:32:41, Serial0/2/0
O 150.7.48.0 [110/1563] via 192.168.7.97, 00:32:31, Serial0/2/0
O 150.7.64.0 [110/2344] via 192.168.7.97, 00:32:31, Serial0/2/0
192.168.7.0/27 is subnetted, 5 subnets
O 192.168.7.0 [110/3124] via 192.168.7.97, 00:26:33, Serial0/2/0
O 192.168.7.32 [110/2343] via 192.168.7.97, 00:32:31, Serial0/2/0
O 192.168.7.64 [110/1562] via 192.168.7.97, 00:32:41, Serial0/2/0
C 192.168.7.96 is directly connected, Serial0/2/0
C 192.168.7.128 is directly connected, Serial0/3/0
S* 0.0.0.0/0 is directly connected, Serial0/3/0
Router2 Routing table
150.7.0.0/20 is subnetted, 4 subnets
O 150.7.16.0 [110/782] via 192.168.7.98, 00:33:13, Serial0/2/0
C 150.7.32.0 is directly connected, FastEthernet0/0
O 150.7.48.0 [110/782] via 192.168.7.65, 00:33:13, Serial0/3/0
O 150.7.64.0 [110/1563] via 192.168.7.65, 00:33:13, Serial0/3/0
192.168.7.0/27 is subnetted, 5 subnets
O 192.168.7.0 [110/2343] via 192.168.7.65, 00:27:09, Serial0/3/0
O 192.168.7.32 [110/1562] via 192.168.7.65, 00:33:13, Serial0/3/0
C 192.168.7.64 is directly connected, Serial0/3/0
C 192.168.7.96 is directly connected, Serial0/2/0
O 192.168.7.128 [110/1562] via 192.168.7.98, 00:33:13, Serial0/2/0
O*E2 0.0.0.0/0 [110/1] via 192.168.7.98, 00:03:13, Serial0/2/0
Comments
-
networker050184 Mod Posts: 11,962 Mod
You aren't running OSPF on Router0. How would it be able to get the OSPF route that way?An expert is a man who has made all the mistakes which can be made. -
mallyg27 Member Posts: 139
networker050184 wrote: »You aren't running OSPF on Router0. How would it be able to get the OSPF route that way?
I thought it was some way to redistribute. Same way i would do if I'm mixing other protocols.
R0-running static
R1-running static and ospf( shouldn't I have to redistribute both ways. Im redistributing static, but how do I redistribute OSPF)
R2-running ospf -
networker050184 Mod Posts: 11,962 Mod
No offense, but I think you are in way over your head here. You need to go back and understand the fundamentals of the protocols and routing in general before trying to move onto the more advanced topics.An expert is a man who has made all the mistakes which can be made. -
mallyg27 Member Posts: 139
networker050184 wrote: »No offense, but I think you are in way over your head here. You need to go back and understand the fundamentals of the protocols and routing in general before trying to move onto the more advanced topics.
I got it to run. Thanks for the advice and leading me in the right direction. -
networker050184 Mod Posts: 11,962 Mod
Just getting it working isn't going to do you much good. You need to get the basics down and understand how the router is treating these routes. Anyone can just put a working config on there.An expert is a man who has made all the mistakes which can be made. -
mallyg27 Member Posts: 139
networker050184 wrote: »Just getting it working isn't going to do you much good. You need to get the basics down and understand how the router is treating these routes. Anyone can just put a working config on there.
I know the basics and how the router treats the routes. I just was becoming a little confused. I've been studying and working on this for about 7 days straight. I was just overlooking somethings. -
danielno8 Member Posts: 34 ■■□□□□□□□□
I thought it was some way to redistribute. Same way i would do if I'm mixing other protocols.
R0-running static
R1-running static and ospf( shouldn't I have to redistribute both ways. Im redistributing static, but how do I redistribute OSPF)
R2-running ospf
It is this area you need to be clear in your head, which comes from getting more of an understanding about how the routing protocols operate. Obviously you managed to get it working by adding the OSPF config to the router, but for one you need to realise R0 doesn't "run static".I know the basics and how the router treats the routes. I just was becoming a little confused. I've been studying and working on this for about 7 days straight. I was just overlooking somethings.