Options

I cannot ping between pc from two routers Urghhhh

lon21lon21 Member Posts: 201
I've been banging my head against the wall for 2 hours.

I have this network setup in packet tracer.

I've added the static route and I'm able to ping between routers and to each side of the network either way. Also i'm able to ping from the router to the PC on the same network (both) but not through the other network.

I've added the static routes on both router and this is confirmed by the pings between the routers.

I noticed that from the switch I'm not able to ping the PC aswell.

Someone please help.

2wme0yr.jpg

Router 5 Running Config
p1#show running-config 
Building configuration...

Current configuration : 520 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname p1
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.2.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 192.168.3.0 255.255.255.0 192.168.2.2 
!
!
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
end


Router 6 Running Config
Router#show running-config 
Building configuration...

Current configuration : 524 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.2.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.3.1 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 192.168.1.0 255.255.255.0 192.168.2.1 
!
!
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
end

Comments

  • Options
    instant000instant000 Member Posts: 1,745
    Sorry, that image is blocked from this site. (I mean, I can't see it from work, and doing bypasses would only get me in trouble, LOL.)

    Tell me this:

    1. IP address, mask, and default gateway of PC
    2. IP address and mask of the closest router's interface
    3. Is there a physical path from the PC to the nearest router?
    4. If the nearest router does a "sh ip route" does it have a route to the distant side of the neighbor router?
    5. If the further router does a "sh ip route" does it have a route to the distant side of the neighbor router?
    6. Can the routers reach each other's distant side via ping?


    note: I am asking these questions because I cannot see the image.

    EDIT: Default gateway is important in this case, as it could possibly be missing from your PC's config, and would clear up some things, as to why you could ping within the same segment, but not have a way to get outside of that network.
    Currently Working: CCIE R&S
    LinkedIn: http://www.linkedin.com/in/lewislampkin (Please connect: Just say you're from TechExams.Net!)
  • Options
    ccnxjrccnxjr Member Posts: 304 ■■■□□□□□□□
    beat me to it!

    check the default gateway on the host pc's.
    (Config tab -> Global Settings -> Gateway/DNS : value for "Gateway")
    It should be the same as the router's interface on that network.
    ie,
    For PC4 it should be 192.168.1.1

    and for PC3 it should be 192.168.3.1

    verify the ip address and subnet mask as well.

    For this scenario your router configs work, it is certainly misconfigured host I tested them.
  • Options
    lon21lon21 Member Posts: 201
    It was the default gateway.

    You guys are amazing.

    I'm speechless.

    THANK YOU VERY MUCH!

    I guess the default gateway would be needed as it would be sending the packet out of its network, is this correct?

    Once again thank you.
  • Options
    ccnxjrccnxjr Member Posts: 304 ■■■□□□□□□□
    That is correct.
    A gateway enables devices on one broadcast domain communicate with another.
    The gateway will need to either have a a route to the destination network or an interface connected to the other broadcast domain.
  • Options
    lon21lon21 Member Posts: 201
    Thanks,

    I was just thinking, both routers have static routes to all network. E.g. router 5 has a static route to the network 192.168.3.0.

    Therefore if PC 4 send a ping to PC , should the packet not travel to router 5 and the router 5 see that the packet is intended for another network listed in its route table and pass the packet through?
  • Options
    jtdk985jtdk985 Banned Posts: 57 ■■□□□□□□□□
    send a ping to the interfaces on the way, or run a traceroute to see where it fails. also make sure you have an ip address setup on both PC's including the default gateways as said above
  • Options
    instant000instant000 Member Posts: 1,745
    lon21 wrote: »
    Thanks,

    I was just thinking, both routers have static routes to all network. E.g. router 5 has a static route to the network 192.168.3.0.

    Therefore if PC 4 send a ping to PC , should the packet not travel to router 5 and the router 5 see that the packet is intended for another network listed in its route table and pass the packet through?

    Hah.

    The problem is not with the router.

    The problem is with the PC.

    when the PC sends a packet to another network, it does the following:

    1. layer 3 packet uses destination IP address of distant network
    2. layer 2 frame addressed to MAC address of nearest router (default gateway)

    Of course, if the default gateway is configured incorrectly, the PC will not know where to send the frame.
    should the packet not travel to router 5 and the router 5 see that the packet is intended for another network listed in its route table and pass the packet through

    The PC cant' find that host on its network. It is supposed to consult a router to find out where to go next. Without the "default gateway" configured for the host, it cannot do that.

    However, the PC does not know to send the information to the router. (Misconfigured, or not configured default gateway.)

    Are you basically asking the router to pick up something off the wire and send it away, even though the information is not addressed to it? .... It doesn't work that way. I can think of using the "ip-helper" but even that is different, as the router is being specifically configured to handle the DHCP request traffic.

    Also, if there is a switch between the host and the router, the router's interface might not ever see the traffic on layer 2 (which, as said before, the router would ignore by default, as the traffic is not addressed to it).

    If you had the spare time, it would be educational to "shark" it, and see what occurs when you have the default gateway misconfigured, versus when you have the default gateway configured correctly.

    Hope this helps.
    Currently Working: CCIE R&S
    LinkedIn: http://www.linkedin.com/in/lewislampkin (Please connect: Just say you're from TechExams.Net!)
  • Options
    lon21lon21 Member Posts: 201
    Thanks... I need to read that a few times to let it sink in.

    Sorry, what does 'shark' it mean?

    I tired to remove the switch between a router and PC. I applied a straight through cable and the connection does not come live, even when default gateway is configured correctly. But when I choose a cross over cable between the router and PC the connections comes up, why would this be?

    I'm sure like for like devices are cross over and unlike devices are straight through?
  • Options
    mella060mella060 Member Posts: 198 ■■■□□□□□□□
    lon21 wrote: »
    Thanks... I need to read that a few times to let it sink in.

    Sorry, what does 'shark' it mean?

    I tired to remove the switch between a router and PC. I applied a straight through cable and the connection does not come live, even when default gateway is configured correctly. But when I choose a cross over cable between the router and PC the connections comes up, why would this be?

    I'm sure like for like devices are cross over and unlike devices are straight through?

    To 'shark' it probably means to use a packet capturing tool called wireshark to see where the packets go.

    Wireshark Go deep.

    You use a cross over cable when connecting a PC directly to a router. Normally you use a cross over cable when connecting 'like' devices such as router to router or switch to switch.

    You use straight-through cables for connecting 'unlike' devices such as router to switch, PC to switch etc
  • Options
    lon21lon21 Member Posts: 201
    mella060 wrote: »
    To 'shark' it probably means to use a packet capturing tool called wireshark to see where the packets go.

    Wireshark Go deep.

    You use a cross over cable when connecting a PC directly to a router. Normally you use a cross over cable when connecting 'like' devices such as router to router or switch to switch.

    You use straight-through cables for connecting 'unlike' devices such as router to switch, PC to switch etc

    But surely a PC and routers are not unlike device, therefore using a straight-through.

    I mean I have a Belkin wireless router at home and the cable used from the router and PC is a straight through cable.
  • Options
    andy4techandy4tech Member Posts: 138
    Yes Ion21 you are to connect a router to a host using crossover cable,crossover cable is used to connect devices that are not supposed to be directly connected together if you look at it inwardly you will see that a router is not suppose to be connected directly together though crossover is used to connect like devices
  • Options
    gramacorpgramacorp Member Posts: 39 ■■■□□□□□□□
    lon21 wrote: »
    But surely a PC and routers are not unlike device, therefore using a straight-through.

    I mean I have a Belkin wireless router at home and the cable used from the router and PC is a straight through cable.
    A PC and router is considered a like device therefore you would need a cross-over cable. Both tx on pin 1-2, rx on 3-6.

    If your Belkin router uses Gigabit or auto MDIX then the crossing is preformed internally so no need for the cross over cable. Hope this helps.
  • Options
    lon21lon21 Member Posts: 201
    Sorry to be a pain.

    But whats the logic behind it? This will help me remember.

    Also are there any other devices which are like to like and require cross over cables. I know a hub to switch would be cross over.

    Thanks
  • Options
    gramacorpgramacorp Member Posts: 39 ■■■□□□□□□□
    Just categorize the devices like this:

    Group1- Routers, PCs, WAPs

    Group2- Switches, Hubs

    connecting devices between groups use a straight-through

    connecting devices within groups use a cross-over

    hope this helps...
  • Options
    pfspfs Registered Users Posts: 2 ■□□□□□□□□□
    Hi.
    Sorry to revive and old thread but im really struggling with this issue also.

    Here is my dilemma and problem...

    Hi everyone im looking for help while using the GUI in packet tracer, here is my network.

    fresz.png



    I have 2 routers which are on subnetted networks. I just want help with these 2 routers at the moment even though i have a total of 5 subnetworks.

    3 routers and 2 serial cables between them = 5 networks.


    Router 1's network addresses is 172.30.41.0/24.

    The serial cable has an address of 172.30.42.0./24 and the 3rd router has and network address of 172.30.43.0/24.

    They all have a subnet mask of 255.255.255.0.

    My problem is when i give the router 1 an ip address of 172.30.41.3
    I give the serial cable an address of 172.30.42.253 and 254 for the other end of the serial connecting to router no 2.

    PC 0 has an ip address of 172.30.40.1.

    When i try to ping in packet tracer from pc0 to router 2 it fails.

    I have tried entering this in router 1's static configuration gui which i think is correct yet it still fails to ping.
    fdfergfergf.png

    I have the default gateway set as 172.30.40.3 which is the same as the ip address as router 1....
    Can somebody show me where im going wrong please ive been at this for 4 hrs now....
  • Options
    Ltat42aLtat42a Member Posts: 587 ■■■□□□□□□□
    Did you set a clock rate on S0/1 of Router1??
  • Options
    pfspfs Registered Users Posts: 2 ■□□□□□□□□□
    The clock rate is set at its default of 2000000 or whatever it is.
    I wouldnt have thought that would have made any difference.


    To elaborate once again...

    IP configuration of PC0

    IP address 172.30.41.1 mask 255.255.255.0 gateway 172.30.41.3

    IP configuration of Router0 - Fa0/0 172.30.41.3 Se0/0 172.30.42.253




    IP configuration of PC1

    IP address 172.30.43.1 mask 255.255.255.0 gateway 172.30.43.3
    IP configuration of Router1 - Fa0/0 172.30.43.3 Se0/0 172.30.42.254







    I have not used the commandline within cisco yet, I know you can static route these by using copy and paste into router config/static/ static routes (Network-mask-next hop).



    Im trying to do it this way before i use the cmdline. Im also doing it this way so when i do come to useing protocols like Rip-Ripv2-Eigrp etc i can appreciate the protocols more in what they are actually doing instead of entering static routes manually like im trying to do here.
  • Options
    chXchX Member Posts: 100 ■■■□□□□□□□
    Do you have static routes on both routers or just one? I would suggest using the CLI anyway, as that's what you'll be doing in Cisco exams and likely in the real world too.
    2019 Goals:
    [ ] Recertify CCNA
Sign In or Register to comment.