OSPF help

itdaddyitdaddy Senior MemberMember Posts: 2,089 ■■■■□□□□□□
okay here is is R2 and R1 connected by ethernet.
you can ping to both sides but there is no neighbor relationship? why?
like they don't even see each other but you have ip layer access?
I have no clue why I cannot get ospf to work on these routers to
create routing tables?

R2(config-if)#
*Mar 1 22:02:30.240: OSPF: Interface FastEthernet0/0 going Up
*Mar 1 22:02:30.741: OSPF: Build router LSA for area 0, router ID 2.2.2.2, seq 0x8000000C, process 1
R2(config-if)#
*Mar 1 22:03:10.241: OSPF: end of Wait on interface FastEthernet0/0
*Mar 1 22:03:10.241: OSPF: DR/BDR election on FastEthernet0/0
*Mar 1 22:03:10.241: OSPF: Elect BDR 2.2.2.2
*Mar 1 22:03:10.241: OSPF: Elect DR 2.2.2.2
*Mar 1 22:03:10.241: OSPF: Elect BDR 0.0.0.0
*Mar 1 22:03:10.241: OSPF: Elect DR 2.2.2.2
*Mar 1 22:03:10.241: DR: 2.2.2.2 (Id) BDR: none
*Mar 1 22:03:10.742: OSPF: No full nbrs to build Net Lsa for interface FastEthernet0/0
R2(config-if)#

*Sep 6 13:05:47.194: OSPF: Interface FastEthernet0/0 going Up
*Sep 6 13:05:47.695: OSPF: Build router LSA for area 0, router ID 1.1.1.1, seq 0x8000000E, process 1
R1(config-if)#do sho ip
*Sep 6 13:06:27.196: OSPF: end of Wait on interface FastEthernet0/0
*Sep 6 13:06:27.196: OSPF: DR/BDR election on FastEthernet0/0
*Sep 6 13:06:27.196: OSPF: Elect BDR 1.1.1.1
*Sep 6 13:06:27.196: OSPF: Elect DR 1.1.1.1
*Sep 6 13:06:27.196: OSPF: Elect BDR 0.0.0.0
*Sep 6 13:06:27.196: OSPF: Elect DR 1.1.1.1
*Sep 6 13:06:27.196: DR: 1.1.1.1 (Id) BDR: none
*Sep 6 13:06:27.697: OSPF: No full nbrs to build Net Lsa for interface FastEthernet0/0
R1(config-if)#
*Sep 6 13:09:12.579: OSPF: Build router LSA for area 0, router ID 1.1.1.1, seq 0x8000000F, process 1
R1(config-if)#

Comments

  • APAAPA Member Posts: 959
    Can you post your configs?

    Looking at the debug... off the top of my head... I'd say that your network statements are incorrect...

    It looks as if they can't see each others OSPF messages......as no OSPF states have changed, although I don't know how much debugging you've enabled...

    - Make sure network statements are correct (IP subnet and area)
    - Make sure network types are the same on interfaces (ptp or network)

    CCNA | CCNA:Security | CCNP | CCIP
    JNCIA:JUNOS | JNCIA:EX | JNCIS:ENT | JNCIS:SEC
    JNCIS:SP | JNCIP:SP
  • ConstantlyLearningConstantlyLearning Member Posts: 445
    And the pings were between the F0/0 interfaces of R1 and R2 yes?
    "There are 3 types of people in this world, those who can count and those who can't"
  • keenonkeenon Member Posts: 1,922 ■■■■□□□□□□
    you need to post 3 things.

    1. show cdp n from each router
    2. router interface configs from each router
    3. routing process config from each router
    Become the stainless steel sharp knife in a drawer full of rusty spoons
  • MonkerzMonkerz Member Posts: 842
    You can ping between R1 and R2 because they both have a "connected" route in the routing table to the network they are attached to (Fa0/0 to Fa0/0).

    From the debuging data, it appears that your routers are attempting to elect themselves as both the DR and BDR. As stated earlier, the routers are not seeing one another so it is probably a fat fingered network statement. (I do this alot, :) )
  • Forsaken_GAForsaken_GA Member Posts: 4,024
    assuming they're both connected to each other via fa0/0, the network statement is probably not the issue. They're both running OSPF on that interface, and the network statement doesn't set the actual subnets to form an adjacency over, just which interfaces OSPF will participate on.

    That looks like either MTU problems, or something munging multicast, but I agree, full configs on both routers would be nice, along with a mockup of the topology (ie, are they directly connected to each others fa0/0, or is there a switch in the mix?)
  • amb1s1amb1s1 Member Posts: 408
    Yes, we need to configs to help you out.
    David G.
    http://gomezd.com <
    My Tshoot test Blog
    http://twitter.com/ipnet255
  • amb1s1amb1s1 Member Posts: 408
    Monkerz wrote: »
    You can ping between R1 and R2 because they both have a "connected" route in the routing table to the network they are attached to (Fa0/0 to Fa0/0).

    From the debuging data, it appears that your routers are attempting to elect themselves as both the DR and BDR. As stated earlier, the routers are not seeing one another so it is probably a fat fingered network statement. (I do this alot, :) )

    Mee too I think it is fat fingered network statement.

    Is not an MTU Problem because you would see an message on the debug ip ospf adj about having the wrong MTU. You will get something like this:

    OSPF: Nbr 1.1.1.1 has smaller interface MTU
    or
    OSPF: Nbr 2.2.2.2 as larger interface MTU

    But again, we need the config to see the entire picture.
    David G.
    http://gomezd.com <
    My Tshoot test Blog
    http://twitter.com/ipnet255
  • itdaddyitdaddy Senior Member Member Posts: 2,089 ■■■■□□□□□□
    r8 ethernet to r2 ethernet to r1 frc to r3 bb1
    r1 frc to r4 bb2

    issue lies where r1 and r3 and r4 have ospf routing tables that can talk
    to each other fine. but from r1 fastethernet on subnet 192.168.1.x /30.
    nothing. it is like r2 and r8 are in their own world and there is no merging
    of ospf lsa?
    hostname R8
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    !
    resource policy
    !
    no network-clock-participate slot 1
    no network-clock-participate wic 0
    ip cef
    !
    !
    !
    !
    no ip domain lookup
    !
    !
    !
    username R1 password 0 cisco
    !
    !
    !
    !
    interface Loopback0
    ip address 8.8.8.8 255.255.255.255
    !
    interface FastEthernet0/0
    ip address 10.1.2.2 255.255.255.0
    speed 10
    full-duplex
    !
    interface Serial0/0
    no ip address
    !
    interface Serial0/1
    description T1 to R1
    ip address 20.1.1.1 255.255.255.0
    encapsulation ppp
    fair-queue
    service-module t1 clock source internal
    service-module t1 timeslots 1-24
    ppp authentication chap
    !
    router ospf 1
    log-adjacency-changes
    network 8.8.8.8 0.0.0.0 area 0
    network 10.1.2.0 0.0.0.255 area 0
    !
    !
    no ip http server
    no ip http secure-server
    !
    !
    control-plane
    !
    alias exec b show ip int brief
    !
    line con 0
    exec-timeout 0 0
    privilege level 15
    logging synchronous
    line aux 0
    line vty 0 4
    exec-timeout 0 0
    privilege level 15
    logging synchronous
    login
    !
    !
    end
    R8#

    hostname R2
    !
    boot-start-marker
    boot system flash c1700-adventerprisek9-mz.124-15.T10.bin
    boot-end-marker
    !
    !
    no aaa new-model
    ip cef
    !
    !
    !
    !
    no ip domain lookup
    ip multicast-routing
    ipv6 unicast-routing
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    archive
    log config
    hidekeys
    !
    !
    !
    !
    !
    !
    !
    !
    interface Loopback0
    ip address 2.2.2.2 255.255.255.255
    !
    interface Loopback1
    no ip address
    shutdown
    !
    interface FastEthernet0/0
    ip address 192.168.1.2 255.255.255.252
    speed auto
    full-duplex
    !
    interface Serial0/0
    no ip address
    !
    interface Ethernet1/0
    ip address 10.1.2.1 255.255.255.0
    full-duplex
    !
    router ospf 1
    log-adjacency-changes
    network 2.2.2.2 0.0.0.0 area 0
    network 10.1.2.0 0.0.0.255 area 0
    network 192.168.1.0 0.0.0.3 area 0
    !
    no ip forward-protocol nd
    !
    !
    no ip http server
    no ip http secure-server
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    alias exec b show ip int brief
    !
    line con 0
    exec-timeout 0 0
    privilege level 15
    logging synchronous
    line aux 0
    line vty 0 4
    exec-timeout 0 0
    privilege level 15
    password ccie
    logging synchronous
    login
    !
    end
    R2#


    hostname R1
    !
    boot-start-marker
    boot-end-marker
    !
    enable password 7 13061E01080355
    !
    no aaa new-model
    voice-card 2
    !
    ip cef
    !
    !
    !
    !
    no ip domain lookup
    ip multicast-routing
    !
    multilink bundle-name authenticated
    !
    !
    key chain KEYCHAIN1
    key 1
    key-string 7 1531223F2705
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    username R8 password 7 104D000A0618
    archive
    log config
    hidekeys
    !
    !
    !
    !
    !
    !
    !
    !
    interface Loopback0
    ip address 1.1.1.1 255.255.255.255
    !
    interface Loopback1
    no ip address
    shutdown
    !
    interface Loopback2
    no ip address
    shutdown
    !
    interface Loopback3
    no ip address
    shutdown
    !
    interface Loopback4
    no ip address
    shutdown
    !
    interface Loopback5
    no ip address
    shutdown
    !
    interface Loopback6
    no ip address
    shutdown
    !
    interface Loopback7
    no ip address
    shutdown
    !
    interface Loopback8
    no ip address
    shutdown
    !
    interface FastEthernet0/0
    ip address 192.168.1.1 255.255.255.0
    speed auto
    full-duplex
    !
    interface Serial0/0
    no ip address
    encapsulation frame-relay IETF
    !
    interface Serial0/0.1 point-to-point
    description direction to R3-BB1
    bandwidth 1544
    ip address 172.16.1.1 255.255.255.252
    snmp trap link-status
    frame-relay interface-dlci 181
    !
    interface Serial0/0.2 point-to-point
    description direction to R4-BB2
    bandwidth 1000
    ip address 172.16.2.1 255.255.255.252
    snmp trap link-status
    frame-relay interface-dlci 182
    !
    interface Serial1/0
    description T1 to R8
    no ip address
    encapsulation ppp
    shutdown
    fair-queue
    service-module t1 clock source internal
    service-module t1 timeslots 1-24
    ppp authentication chap
    !
    router ospf 1
    log-adjacency-changes
    network 1.1.1.1 0.0.0.0 area 0
    network 172.16.1.0 0.0.0.255 area 0
    network 172.16.2.0 0.0.0.255 area 0
    network 192.168.1.0 0.0.0.255 area 0
    !
    no ip forward-protocol nd
    !
    !
    no ip http server
    no ip http secure-server
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    voice-port 2/0
    !
    voice-port 2/1
    !
    !
    !
    !
    !
    !
    alias exec b show ip int brief
    !
    line con 0
    exec-timeout 0 0
    privilege level 15
    logging synchronous
    line aux 0
    line vty 0 4
    exec-timeout 0 0
    privilege level 15
    password 7 104D0A1000
    logging synchronous
    login
    !
    end
    R1#

    hostname R3_BB1
    !
    boot-start-marker
    boot system flash c1700-adventerprisek9-mz.124-15.T10.bin
    boot-end-marker
    !
    !
    no aaa new-model
    ip cef
    !
    !
    !
    !
    no ip domain lookup
    ip multicast-routing
    !
    multilink bundle-name authenticated
    !
    !
    key chain KEYCHAIN1
    key 1
    key-string CISCO
    key chain KEYCHAIN2
    key 1
    key-string CISCO
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    archive
    log config
    hidekeys
    !
    !
    !
    !
    !
    !
    !
    !
    interface Loopback0
    ip address 3.3.3.3 255.255.255.255
    !
    interface Loopback1
    no ip address
    !
    interface FastEthernet0/0
    ip address 172.16.3.2 255.255.255.0
    shutdown
    speed auto
    !
    interface Serial0/0
    no ip address
    encapsulation frame-relay IETF
    !
    interface Serial0/0.1 point-to-point
    description direction to R4-BB2
    ip address 10.1.1.1 255.255.255.252
    snmp trap link-status
    frame-relay interface-dlci 881
    !
    interface Serial0/0.2 point-to-point
    description direction to R1
    ip address 172.16.1.2 255.255.255.252
    snmp trap link-status
    frame-relay interface-dlci 811
    !
    interface Serial1/0
    no ip address
    !
    router ospf 1
    log-adjacency-changes
    network 3.3.3.3 0.0.0.0 area 0
    network 10.1.1.0 0.0.0.255 area 0
    network 172.16.1.0 0.0.0.255 area 0
    !
    ip forward-protocol nd
    !
    !
    no ip http server
    no ip http secure-server
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    alias exec fr frame-relay map ip 10.2.2.1 203 broadcaste (static mapping)
    alias exec b sh ip int brief
    !
    line con 0
    exec-timeout 0 0
    privilege level 15
    logging synchronous
    line aux 0
    line vty 0 4
    exec-timeout 0 0
    privilege level 15
    password ccie
    logging synchronous
    login
    !
    end
    R3_BB1#

    hostname R4_BB2
    !
    boot-start-marker
    boot system flash
    boot system flash c1700-adventerprisek9-mz.124-15.T10.bin
    boot-end-marker
    !
    !
    no aaa new-model
    ip cef
    !
    !
    !
    !
    no ip domain lookup
    ip multicast-routing
    ipv6 unicast-routing
    !
    multilink bundle-name authenticated
    !
    !
    key chain KEYCHAIN1
    key 1
    key-string CISCO
    key chain KEYCHAIN2
    key 1
    key-string CISCO
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    archive
    log config
    hidekeys
    !
    !
    !
    !
    !
    !
    !
    !
    interface Loopback0
    ip address 4.4.4.4 255.255.255.255
    !
    interface Loopback1
    no ip address
    !
    interface FastEthernet0/0
    ip address 172.16.3.3 255.255.255.0
    shutdown
    speed auto
    !
    interface Serial0/0
    no ip address
    encapsulation frame-relay IETF
    !
    interface Serial0/0.1 point-to-point
    description direction to R3-BB1
    ip address 10.1.1.2 255.255.255.252
    ip pim sparse-dense-mode
    snmp trap link-status
    frame-relay interface-dlci 882
    !
    interface Serial0/0.2 point-to-point
    description direction to R1
    ip address 172.16.2.2 255.255.255.252
    snmp trap link-status
    frame-relay interface-dlci 821
    !
    interface Serial1/0
    no ip address
    shutdown
    !
    router ospf 1
    log-adjacency-changes
    network 4.4.4.4 0.0.0.0 area 0
    network 10.1.1.0 0.0.0.255 area 0
    network 172.16.2.0 0.0.0.255 area 0
    !
    ip default-gateway 192.168.15.1
    ip forward-protocol nd
    !
    !
    no ip http server
    no ip http secure-server
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    alias exec b sh ip int brief
    !
    line con 0
    exec-timeout 0 0
    privilege level 15
    logging synchronous
    line aux 0
    line vty 0 4
    exec-timeout 0 0
    privilege level 15
    password ccie
    logging synchronous
    login
    !
    end
    R4_BB2#



    __________________
    itdaddy
    CCNA, A+, MCP
    BS in Computer Science
    (WIP:CCNP, CCSP, CCVP)

    user_online.gifforward.gif reply_small.gif
    itdaddyView Public ProfileSend a private message to itdaddyFind More Posts by itdaddyAdd itdaddy to Your Contacts


    collapse_tcat.gif Quick Reply
    Message:


    removeformat.gif
    separator.gifbold.gif
    italic.gif
    underline.gif
    separator.gifcolor.gif
    clear.gifmenupop.gif
    separator.gifcreatelink.gif
    insertimage.gif
    separator.gifquote.gif






    hostname R8
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    !
    resource policy
    !
    no network-clock-participate slot 1
    no network-clock-participate wic 0
    ip cef
    !
    !
    !
    !
    no ip domain lookup
    !
    !
    !
    username R1 password 0 cisco
    !
    !
    !
    !
    interface Loopback0
    ip address 8.8.8.8 255.255.255.255
    !
    interface FastEthernet0/0
    ip address 10.1.2.2 255.255.255.0
    speed 10
    full-duplex
    !
    interface Serial0/0
    no ip address
    !
    interface Serial0/1
    description T1 to R1
    ip address 20.1.1.1 255.255.255.0
    encapsulation ppp
    fair-queue
    service-module t1 clock source internal
    service-module t1 timeslots 1-24
    ppp authentication chap
    !
    router ospf 1
    log-adjacency-changes
    network 8.8.8.8 0.0.0.0 area 0
    network 10.1.2.0 0.0.0.255 area 0
    !
    !
    no ip http server
    no ip http secure-server
    !
    !
    control-plane
    !
    alias exec b show ip int brief
    !
    line con 0
    exec-timeout 0 0
    privilege level 15
    logging synchronous
    line aux 0
    line vty 0 4
    exec-timeout 0 0
    privilege level 15
    logging synchronous
    login
    !
    !
    end
    R8#

    hostname R2
    !
    boot-start-marker
    boot system flash c1700-adventerprisek9-mz.124-15.T10.bin
    boot-end-marker
    !
    !
    no aaa new-model
    ip cef
    !
    !
    !
    !
    no ip domain lookup
    ip multicast-routing
    ipv6 unicast-routing
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    archive
    log config
    hidekeys
    !
    !
    !
    !
    !
    !
    !
    !
    interface Loopback0
    ip address 2.2.2.2 255.255.255.255
    !
    interface Loopback1
    no ip address
    shutdown
    !
    interface FastEthernet0/0
    ip address 192.168.1.2 255.255.255.252
    speed auto
    full-duplex
    !
    interface Serial0/0
    no ip address
    !
    interface Ethernet1/0
    ip address 10.1.2.1 255.255.255.0
    full-duplex
    !
    router ospf 1
    log-adjacency-changes
    network 2.2.2.2 0.0.0.0 area 0
    network 10.1.2.0 0.0.0.255 area 0
    network 192.168.1.0 0.0.0.3 area 0
    !
    no ip forward-protocol nd
    !
    !
    no ip http server
    no ip http secure-server
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    alias exec b show ip int brief
    !
    line con 0
    exec-timeout 0 0
    privilege level 15
    logging synchronous
    line aux 0
    line vty 0 4
    exec-timeout 0 0
    privilege level 15
    password ccie
    logging synchronous
    login
    !
    end
    R2#


    hostname R1
    !
    boot-start-marker
    boot-end-marker
    !
    enable password 7 13061E01080355
    !
    no aaa new-model
    voice-card 2
    !
    ip cef
    !
    !
    !
    !
    no ip domain lookup
    ip multicast-routing
    !
    multilink bundle-name authenticated
    !
    !
    key chain KEYCHAIN1
    key 1
    key-string 7 1531223F2705
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    username R8 password 7 104D000A0618
    archive
    log config
    hidekeys
    !
    !
    !
    !
    !
    !
    !
    !
    interface Loopback0
    ip address 1.1.1.1 255.255.255.255
    !
    interface Loopback1
    no ip address
    shutdown
    !
    interface Loopback2
    no ip address
    shutdown
    !
    interface Loopback3
    no ip address
    shutdown
    !
    interface Loopback4
    no ip address
    shutdown
    !
    interface Loopback5
    no ip address
    shutdown
    !
    interface Loopback6
    no ip address
    shutdown
    !
    interface Loopback7
    no ip address
    shutdown
    !
    interface Loopback8
    no ip address
    shutdown
    !
    interface FastEthernet0/0
    ip address 192.168.1.1 255.255.255.0
    speed auto
    full-duplex
    !
    interface Serial0/0
    no ip address
    encapsulation frame-relay IETF
    !
    interface Serial0/0.1 point-to-point
    description direction to R3-BB1
    bandwidth 1544
    ip address 172.16.1.1 255.255.255.252
    snmp trap link-status
    frame-relay interface-dlci 181
    !
    interface Serial0/0.2 point-to-point
    description direction to R4-BB2
    bandwidth 1000
    ip address 172.16.2.1 255.255.255.252
    snmp trap link-status
    frame-relay interface-dlci 182
    !
    interface Serial1/0
    description T1 to R8
    no ip address
    encapsulation ppp
    shutdown
    fair-queue
    service-module t1 clock source internal
    service-module t1 timeslots 1-24
    ppp authentication chap
    !
    router ospf 1
    log-adjacency-changes
    network 1.1.1.1 0.0.0.0 area 0
    network 172.16.1.0 0.0.0.255 area 0
    network 172.16.2.0 0.0.0.255 area 0
    network 192.168.1.0 0.0.0.255 area 0
    !
    no ip forward-protocol nd
    !
    !
    no ip http server
    no ip http secure-server
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    voice-port 2/0
    !
    voice-port 2/1
    !
    !
    !
    !
    !
    !
    alias exec b show ip int brief
    !
    line con 0
    exec-timeout 0 0
    privilege level 15
    logging synchronous
    line aux 0
    line vty 0 4
    exec-timeout 0 0
    privilege level 15
    password 7 104D0A1000
    logging synchronous
    login
    !
    end
    R1#

    hostname R3_BB1
    !
    boot-start-marker
    boot system flash c1700-adventerprisek9-mz.124-15.T10.bin
    boot-end-marker
    !
    !
    no aaa new-model
    ip cef
    !
    !
    !
    !
    no ip domain lookup
    ip multicast-routing
    !
    multilink bundle-name authenticated
    !
    !
    key chain KEYCHAIN1
    key 1
    key-string CISCO
    key chain KEYCHAIN2
    key 1
    key-string CISCO
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    archive
    log config
    hidekeys
    !
    !
    !
    !
    !
    !
    !
    !
    interface Loopback0
    ip address 3.3.3.3 255.255.255.255
    !
    interface Loopback1
    no ip address
    !
    interface FastEthernet0/0
    ip address 172.16.3.2 255.255.255.0
    shutdown
    speed auto
    !
    interface Serial0/0
    no ip address
    encapsulation frame-relay IETF
    !
    interface Serial0/0.1 point-to-point
    description direction to R4-BB2
    ip address 10.1.1.1 255.255.255.252
    snmp trap link-status
    frame-relay interface-dlci 881
    !
    interface Serial0/0.2 point-to-point
    description direction to R1
    ip address 172.16.1.2 255.255.255.252
    snmp trap link-status
    frame-relay interface-dlci 811
    !
    interface Serial1/0
    no ip address
    !
    router ospf 1
    log-adjacency-changes
    network 3.3.3.3 0.0.0.0 area 0
    network 10.1.1.0 0.0.0.255 area 0
    network 172.16.1.0 0.0.0.255 area 0
    !
    ip forward-protocol nd
    !
    !
    no ip http server
    no ip http secure-server
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    alias exec fr frame-relay map ip 10.2.2.1 203 broadcaste (static mapping)
    alias exec b sh ip int brief
    !
    line con 0
    exec-timeout 0 0
    privilege level 15
    logging synchronous
    line aux 0
    line vty 0 4
    exec-timeout 0 0
    privilege level 15
    password ccie
    logging synchronous
    login
    !
    end
    R3_BB1#

    hostname R4_BB2
    !
    boot-start-marker
    boot system flash
    boot system flash c1700-adventerprisek9-mz.124-15.T10.bin
    boot-end-marker
    !
    !
    no aaa new-model
    ip cef
    !
    !
    !
    !
    no ip domain lookup
    ip multicast-routing
    ipv6 unicast-routing
    !
    multilink bundle-name authenticated
    !
    !
    key chain KEYCHAIN1
    key 1
    key-string CISCO
    key chain KEYCHAIN2
    key 1
    key-string CISCO
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    archive
    log config
    hidekeys
    !
    !
    !
    !
    !
    !
    !
    !
    interface Loopback0
    ip address 4.4.4.4 255.255.255.255
    !
    interface Loopback1
    no ip address
    !
    interface FastEthernet0/0
    ip address 172.16.3.3 255.255.255.0
    shutdown
    speed auto
    !
    interface Serial0/0
    no ip address
    encapsulation frame-relay IETF
    !
    interface Serial0/0.1 point-to-point
    description direction to R3-BB1
    ip address 10.1.1.2 255.255.255.252
    ip pim sparse-dense-mode
    snmp trap link-status
    frame-relay interface-dlci 882
    !
    interface Serial0/0.2 point-to-point
    description direction to R1
    ip address 172.16.2.2 255.255.255.252
    snmp trap link-status
    frame-relay interface-dlci 821
    !
    interface Serial1/0
    no ip address
    shutdown
    !
    router ospf 1
    log-adjacency-changes
    network 4.4.4.4 0.0.0.0 area 0
    network 10.1.1.0 0.0.0.255 area 0
    network 172.16.2.0 0.0.0.255 area 0
    !
    ip default-gateway 192.168.15.1
    ip forward-protocol nd
    !
    !
    no ip http server
    no ip http secure-server
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    alias exec b sh ip int brief
    !
    line con 0
    exec-timeout 0 0
    privilege level 15
    logging synchronous
    line aux 0
    line vty 0 4
    exec-timeout 0 0
    privilege level 15
    password ccie
    logging synchronous
    login
    !
    end
    R4_BB2#



    __________________
    itdaddy
    CCNA, A+, MCP
    BS in Computer Science
    (WIP:CCNP, CCSP, CCVP)
  • amb1s1amb1s1 Member Posts: 408
    Are you doing this lab on GNS3? You config look good. Can you do debug ip ospf event
    David G.
    http://gomezd.com <
    My Tshoot test Blog
    http://twitter.com/ipnet255
  • amb1s1amb1s1 Member Posts: 408
    Found it, the problem is that to be able to established a neighbor with a neighbors the interfaces got to be in the same subnet. YOu have router2 interface Fa0/0 on /30 subnet
    R2
    ---
    interface FastEthernet0/0
    ip address 192.168.1.2 255.255.255.252
    speed auto
    full-duplex
    

    and router 1 on a /24 subnet
    interface FastEthernet0/0
    ip address 192.168.1.1 255.255.255.0
    speed auto
    full-duplex
    
    

    To solve this problem you either move R1 to a /30 subnet or r2 to /24 subnet.
    David G.
    http://gomezd.com <
    My Tshoot test Blog
    http://twitter.com/ipnet255
  • Forsaken_GAForsaken_GA Member Posts: 4,024
    your netmasks are mismatched between r1 and r2 on the fa0/0 interfaces. r2 has it configured as a /30, r1 has it configured as a /24

    edit: damn, little too slow ;)
  • DPGDPG Member Posts: 780 ■■■■■□□□□□
    Your IP subnets and network statements are mismatched.
    [B]R1[/B]
    interface FastEthernet0/0
    ip address 192.168.1.1 255.255.255.[B]0[/B]
    
    network 192.168.1.0 0.0.0.[B]255[/B] area 0
    
    
    [B]R2[/B]
    interface FastEthernet0/0
    ip address 192.168.1.2 255.255.255.[B]252[/B]
    
    network 192.168.1.0 0.0.0.[B]3[/B] area 0
    
    
    They interfaces need to have the subnet mask and the network statements need to have the same wildcard mask in order for the adjacency to form.
  • Forsaken_GAForsaken_GA Member Posts: 4,024
    You're also going to want to adjust the wildcard masks for the network statements to be consistent, particularly if your goal is for these links to be a /30. ie, you may not necessarily want the router currently configured as a /24 to match on a 24 bit mask if your goal is to only advertise that /30, if you leave it that way, and you configured anything else in the 192.168.1.0/24 range, say for another point to point link, then that subnet would automatically get injected into ospf.

    Personally, I prefer to explicitly match the interface in the network statement if I'm using it to configure OSPF (I usually enable ospf at the interface level).

    of course, I also define passive-interface by default as well. Then I explicitly no passive-interface the interfaces I do want running OSPF, so I make it really hard to screw up and accidentally add an interface to the routing protocol.
  • itdaddyitdaddy Senior Member Member Posts: 2,089 ■■■■□□□□□□
    OMG..you are right I just didnt see that aahahha wow I should have gone thru the basics step by step I just kep relying on the ping since it did work
    but I completely see what you see fixing this tomorrow will let you know. I was look at timers and they looked good and I was like what the heck is it hahah thanks guys I willl look and fix it tomorrow morning and report back my success. thanks so much for your keen site. yeah I can sleep now.
    what a cool exercise in troubleshooting wow! I should have looked at each factor. great exercise....see you tomorrow...icon_cheers.gif
  • Forsaken_GAForsaken_GA Member Posts: 4,024
    itdaddy wrote: »
    OMG..you are right I just didnt see that aahahha wow I should have gone thru the basics step by step I just kep relying on the ping since it did work
    but I completely see what you see fixing this tomorrow will let you know. I was look at timers and they looked good and I was like what the heck is it hahah thanks guys I willl look and fix it tomorrow morning and report back my success. thanks so much for your keen site. yeah I can sleep now.
    what a cool exercise in troubleshooting wow! I should have looked at each factor. great exercise....see you tomorrow...icon_cheers.gif

    devil's in the details. I cannot explain how many times I've run into problems that at first blush, everything seemed correct, and was going off on all kinds of tangents trying to figure it out, and it turned out to be something stupid like a typo.

    When in doubt, always bet on stupid.
  • APAAPA Member Posts: 959
    See what happens when you post configs up.... :)

    Definitely explains why they weren't seeing each other.... perfect example of always thoroughly checking your config before applying it.

    CCNA | CCNA:Security | CCNP | CCIP
    JNCIA:JUNOS | JNCIA:EX | JNCIS:ENT | JNCIS:SEC
    JNCIS:SP | JNCIP:SP
  • itdaddyitdaddy Senior Member Member Posts: 2,089 ■■■■□□□□□□
    oh yeah you guys are awesome. man I feel so dumb hahaha
    yeah works great!!thank you for being my eyeballs! icon_cheers.gif
    R1#sh ip ospf neigh
    Neighbor ID Pri State Dead Time Address Interface
    2.2.2.2 1 FULL/DR 00:00:38 192.168.1.2 FastEthernet0/0
    4.4.4.4 0 FULL/ - 00:00:36 172.16.2.2 Serial0/0.2
    3.3.3.3 0 FULL/ - 00:00:35 172.16.1.2 Serial0/0.1
    R1#
Sign In or Register to comment.