Need Help with Lab 4.4.1 Routing Loops

dan87951dan87951 Member Posts: 107
Below is the lab that I had to do. I was able to finish the lab and have everything ping however when I click check results in Cisco Packet Tracer it says not correct. I’m totally confused…I have racked my brain over this and cannot figure out why! It's pretty obvious where the routing loops are by the "ip route 0.0.0.0 0.0.0.0 " command in the running config. I deleted those routs out from both routers and created static routes to the respective networks. Below you can find the running config of all three routers. Is the program wrong or is there another routing loop I’m missing?

****LAB 4.4.1: Routing Loops*******

Addressing Scheme

Device Interface IP Address Subnet Mask Default Gateway
ISP Fa0/0 10.10.0.1 255.255.0.0 N/A
S0/0 192.168.1.5 255.255.255.252 N/A
S0/1 192.168.3.10 255.255.255.252 N/A

BRANCH1 Fa0/0 172.16.4.1 255.255.255.0 N/A
S0/0 192.168.1.6 255.255.255.252 N/A
S0/1 192.168.2.1 255.255.255.252 N/A

BRANCH2 Fa0/0 172.16.15.1 255.255.255.0 N/A
S0/0 192.168.2.2 255.255.255.252 N/A
S0/1 192.168.3.9 255.255.255.252 N/A

PC0 N/A 10.10.0.2 255.255.255.0 10.10.0.1
PC1 N/A 172.16.4.2 255.255.255.0 172.16.4.1
PC2 N/A 172.16.15.2 255.255.255.0 172.16.15.2
Learning Objectives:

All routers have been configured.
Identify the conditions leading to a routing loop and the implications on router performance.
Task 1: Show contents of routing tables.

Step 1: Examine BRANCH1’s configuration.

To display the configuration of the BRANCH1 router complete the following steps:

Select router BRANCH1.
Click the CLI tab.
Change to the privileged EXEC mode by typing: enable
BRANCH1>enable
Type the following command: show run
BRANCH1#show run
Press the spacebar until the router prompt returns.
Locate the static route command. It will appear as
ip route 0.0.0.0 0.0.0.0 serial 0/1
Step 2: Examine BRANCH2’s configuration.

To display the configuration of the BRANCH2 router complete the following steps:

Select router BRANCH2.
Click the CLI tab.
Change to the privileged EXEC mode by typing: enable
BRANCH2>enable
Type the following command: show run
BRANCH2#show run
Press the spacebar until the router prompt returns.
Locate the static route command. It will appear as
ip route 0.0.0.0 0.0.0.0 serial 0/0
Task 2: Verify connectivity.

Step 1: Ping from PC2 to PC0.

Use the ping command at the command prompt of PC2 to ping PC0. The ping command will be unsuccessful due to incorrect configuration of static routes.

Step 2: How should the routes be configured?

The two static routes are incorrectly configured and will cause routing loops. What are the correct commands including the commands to remove the incorrect static routes? Correct the router configurations by replacing the incorrect static routes with the correct routes.

Step 3: Ping from PC2 to PC0.

Use the ping command at the command prompt of PC2 to ping PC0 again. The ping command should now be successful due to correct configuration of static routes


At the end of this activity your completion rate should be 100%. If the completion rate is not 100%, use the Check Results button and troubleshoot as necessary.


BRANCH1 Running Config:

Building configuration...

Current configuration : 574 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname BRANCH1
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 172.16.4.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 192.168.1.6 255.255.255.252
!
interface Serial0/1
ip address 192.168.2.1 255.255.255.252
clock rate 56000
!
ip classless
ip route 172.16.15.0 255.255.255.0 Serial0/1
ip route 10.10.0.0 255.255.255.0 Serial0/0
!
!
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end

********Branch 2 Running Config:****************

Current configuration : 561 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname BRANCH2
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 172.16.15.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 192.168.2.2 255.255.255.252
!
interface Serial0/1
ip address 192.168.3.9 255.255.255.252
!
ip classless
ip route 172.16.4.0 255.255.255.0 192.168.2.1
ip route 10.10.0.0 255.255.255.0 192.168.3.10
!
!
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end

****************ISP Running Config:**************

Building configuration...

Current configuration : 683 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname ISP
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.10.0.1 255.255.0.0
duplex auto
speed auto
!
interface Serial0/0
ip address 192.168.1.5 255.255.255.252
clock rate 56000
!
interface Serial0/1
ip address 192.168.3.10 255.255.255.252
clock rate 56000
!
ip classless
ip route 172.16.4.0 255.255.255.0 Serial0/0
ip route 172.16.15.0 255.255.255.0 Serial0/1
ip route 192.168.2.0 255.255.255.252 Serial0/0
ip route 192.168.2.0 255.255.255.252 Serial0/1
!
!
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end

Comments

  • CodeBloxCodeBlox Member Posts: 1,363 ■■■■□□□□□□
    What exactly is said to not be correct in the assessment?
    Currently reading: Network Warrior, Unix Network Programming by Richard Stevens
  • dan87951dan87951 Member Posts: 107
    It doesn't tell me it says "This activity is incomplete, please try again." and when I click on the assessment tab it tell me my "routes are incomplete". So everything looks good?
  • CodeBloxCodeBlox Member Posts: 1,363 ■■■■□□□□□□
    Packet tracer is very picky. if they expect you to use default routes with the correct interface, you may want to stick to that. I see that you didn't use default routes but specific static routes.
    Currently reading: Network Warrior, Unix Network Programming by Richard Stevens
  • jtdk985jtdk985 Banned Posts: 57 ■■□□□□□□□□
    mind uploading the lab, or posting a link to where you got it? :)

    and yes codeblox is right, packet tracer likes exit interface most of the time, instead of the next hop ip
  • onesaintonesaint Member Posts: 801
    jtdk985 wrote: »
    mind uploading the lab, or posting a link to where you got it? :)

    and yes codeblox is right, packet tracer likes exit interface most of the time, instead of the next hop ip

    Is it like this one the exams as well?
    Work in progress: picking up Postgres, elastisearch, redis, Cloudera, & AWS.
    Next up: eventually the RHCE and to start blogging again.

    Control Protocol; my blog of exam notes and IT randomness
  • jtdk985jtdk985 Banned Posts: 57 ■■□□□□□□□□
    no idea! testing 640-802 tuesday, so ill let you know :p

    assuming the test simulates the full IOS, i couldnt see it being like this. if the command does the same thing, just uses a different format, it should except it either way.
  • CodeBloxCodeBlox Member Posts: 1,363 ■■■■□□□□□□
    Yeah but they tend to disable stuff... Making you do something in a specific way. Best to know more than one way to do things.
    Currently reading: Network Warrior, Unix Network Programming by Richard Stevens
  • dan87951dan87951 Member Posts: 107
    I tried it both ways using the next hop router and using the exit interface and it made no difference. The lab didn't specify what kind of route to use. I'm only on the second semester and into chapter 4 so I don't remember covering default routes yet. Looks like default routes are covered in the next chapter (5). Hopefully the CCNA will not be this picky?

    It won’t allow me to upload the lab using the manage attachments. When I get off from work I will host it on a web server.

    Thanks
  • CodeBloxCodeBlox Member Posts: 1,363 ■■■■□□□□□□
    In the text in your first post, they mentioned that you should see a few routes "ip route 0.0.0.0 0.0.0.0 s0/1" and "ip route 0.0.0.0 0.0.0.0 s0/0" Those are default routes. perhaps the only change needed was to swap the serial interface. I'd imagine those default routes should point to the ISP router...
    Currently reading: Network Warrior, Unix Network Programming by Richard Stevens
  • dan87951dan87951 Member Posts: 107
    CodeBlox wrote: »
    In the text in your first post, they mentioned that you should see a few routes "ip route 0.0.0.0 0.0.0.0 s0/1" and "ip route 0.0.0.0 0.0.0.0 s0/0" Those are default routes. perhaps the only change needed was to swap the serial interface. I'd imagine those default routes should point to the ISP router...

    That's the only case we have covered is the "ip route 0.0.0.0 0.0.0.0". Aren't there more cases than that?

    Each router has 3 interfaces. If I just swap the serial interface how will it know to reach the other network on the other interface. By putting in the "ip route 0.0.0.0 0.0.0.0 s0/0" its pretty much saying all trafic will go out that interface I specify, correct?
  • CodeBloxCodeBlox Member Posts: 1,363 ■■■■□□□□□□
    That is correct. But listen, your images serial interfaces aren't labeled and i'm not sure if these are the original running-configs. Could you post those as well as a labeled image?
    Currently reading: Network Warrior, Unix Network Programming by Richard Stevens
  • dan87951dan87951 Member Posts: 107
    The configs I posted are my corrected ones to get everything to ping.

    Below are the original configs. Thanks for the help.

    *******Branch 1 Running Config************
    Building configuration...

    Current configuration : 520 bytes
    !
    version 12.2
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname BRANCH1
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    ip address 172.16.4.1 255.255.255.0
    duplex auto
    speed auto
    !
    interface Serial0/0
    ip address 192.168.1.6 255.255.255.252
    !
    interface Serial0/1
    ip address 192.168.2.1 255.255.255.252
    clock rate 56000
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 Serial0/1
    !
    !
    !
    !
    !
    !
    !
    line con 0
    line vty 0 4
    login
    !
    !
    !
    end

    **************Branch 2****************

    Building configuration...

    Current configuration : 503 bytes
    !
    version 12.2
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname BRANCH2
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    ip address 172.16.15.1 255.255.255.0
    duplex auto
    speed auto
    !
    interface Serial0/0
    ip address 192.168.2.2 255.255.255.252
    !
    interface Serial0/1
    ip address 192.168.3.9 255.255.255.252
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 Serial0/0
    !
    !
    !
    !
    !
    !
    !
    line con 0
    line vty 0 4
    login
    !
    !
    !
    end

    ***************ISP********************

    Building configuration...

    Current configuration : 683 bytes
    !
    version 12.2
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname ISP
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    ip address 10.10.0.1 255.255.0.0
    duplex auto
    speed auto
    !
    interface Serial0/0
    ip address 192.168.1.5 255.255.255.252
    clock rate 56000
    !
    interface Serial0/1
    ip address 192.168.3.10 255.255.255.252
    clock rate 56000
    !
    ip classless
    ip route 172.16.4.0 255.255.255.0 Serial0/0
    ip route 172.16.15.0 255.255.255.0 Serial0/1
    ip route 192.168.2.0 255.255.255.252 Serial0/0
    ip route 192.168.2.0 255.255.255.252 Serial0/1
    !
    !
    !
    !
    !
    !
    !
    line con 0
    line vty 0 4
    login
    !
    !
    !
    end
  • onesaintonesaint Member Posts: 801
    I went and grabbed the PT assignment you were doing (Routing Protocols and Concepts - 4.4.1.2). You need to start with the lowest common denominator. Thats ping and trace route. If you ping PC0 to PC2 or PC3 the packets get dropped at the ISP router. So there is an issue with the ISP router connecting.

    Then if you trace route from PC2 to PC3 it works fine. This says that the connection if fine between Branch 1 and 2. Next trace route from PC2 and 3 to PC0. the hops fail after you exit the Branch routers, telling us that there is a connection issue between Branch 1/2 and the ISP.

    The PT instructions tell you that the static routes are set incorrectly. If you run a "sh ip int brief" and compare that to the trace routes you can see that the branch routers static routes are set to the int. connecting to the opposite branch router (branch 1 set route to Branch 2 and vise versa). So remove the static route from the incorrect interface and add a new static route to the correct interface to set the route to the ISP router.
    Work in progress: picking up Postgres, elastisearch, redis, Cloudera, & AWS.
    Next up: eventually the RHCE and to start blogging again.

    Control Protocol; my blog of exam notes and IT randomness
  • dan87951dan87951 Member Posts: 107
    onesaint wrote: »
    I went and grabbed the PT assignment you were doing (Routing Protocols and Concepts - 4.4.1.2). You need to start with the lowest common denominator. Thats ping and trace route. If you ping PC0 to PC2 or PC3 the packets get dropped at the ISP router. So there is an issue with the ISP router connecting.

    Then if you trace route from PC2 to PC3 it works fine. This says that the connection if fine between Branch 1 and 2. Next trace route from PC2 and 3 to PC0. the hops fail after you exit the Branch routers, telling us that there is a connection issue between Branch 1/2 and the ISP.

    The PT instructions tell you that the static routes are set incorrectly. If you run a "sh ip int brief" and compare that to the trace routes you can see that the branch routers static routes are set to the int. connecting to the opposite branch router (branch 1 set route to Branch 2 and vise versa). So remove the static route from the incorrect interface and add a new static route to the correct interface to set the route to the ISP router.

    Ok thanks I might have rushed that one a little bit. I will go over it again tommorrow.
  • onesaintonesaint Member Posts: 801
    dan87951 wrote: »
    Ok thanks I might have rushed that one a little bit. I will go over it again tommorrow.

    No worries. That stuff can all be a pain with the specifics to get it right. Just wait till you have to do ACLs. =^)

    Interesting that your on the Exploration as opposed to Discovery path. Ive been told that Exploration is more in depth. None the less, I didnt find the writing in either to be all that great. Its abstract, yet they have detailed expectations.
    Work in progress: picking up Postgres, elastisearch, redis, Cloudera, & AWS.
    Next up: eventually the RHCE and to start blogging again.

    Control Protocol; my blog of exam notes and IT randomness
  • dan87951dan87951 Member Posts: 107
    Thanks, got it! I went over the lab again and my problem was I was not treating the ISP router as the ISP router. I wanted to route all other traffic other than the specified traffic to the ISP router which I had not done hence the not complete. Plus I was thinking to much into it. I didn't want all the local traffic to route through the ISP router as that would make 2 hops so I put in a static route on each of the branch 1 and branch 2 routers so traffic could be directed in 1 hop. Anyways, Thanks for the quick help.

    I'm using the online Cisco Academy training which is kinda an over view.
  • onesaintonesaint Member Posts: 801
    dan87951 wrote: »
    Thanks, got it! I went over the lab again and my problem was I was not treating the ISP router as the ISP router. I wanted to route all other traffic other than the specified traffic to the ISP router which I had not done hence the not complete. Plus I was thinking to much into it. I didn't want all the local traffic to route through the ISP router as that would make 2 hops so I put in a static route on each of the branch 1 and branch 2 routers so traffic could be directed in 1 hop. Anyways, Thanks for the quick help.

    I'm using the online Cisco Academy training which is kinda an over view.

    I think in a real world scenario that makes more sense. In the PT exercises they really want things a specific way. For instance if we were doing this on real equipment (maybe in a lab), and you had two routes,

    ip route 0.0.0.0 0.0.0.0 Serial0/0
    ip route 172.16.15.0 255.255.255.0 Serial0/1

    your local traffic (destined for 172.16.15.0/24) would be routed locally and all your other traffic would be routed out to the ISP router. This works and can be done in PT as well. Although, PT shows this as incomplete where as in a lab this would be working well.

    Are all your assignments in the Discovery or Exploration books? I am just finishing up my 4th semester with the Net Acad, but all my work was required from the Discovery books. Id like to have a go over the Exploration books though as Ive heard they are more in depth.
    Work in progress: picking up Postgres, elastisearch, redis, Cloudera, & AWS.
    Next up: eventually the RHCE and to start blogging again.

    Control Protocol; my blog of exam notes and IT randomness
Sign In or Register to comment.