Routing Issue

sleemiesleemie Member Posts: 109
Okay, this is driving me crazy. I've set up a topology with two networks, well I guess technically three networks, separated by two routers and I can ping from one network over to the inside interface of the router on the other network, but when I try the revserse and try to ping from the other network I can't even ping the outside interface of the router on that network.

So,

I can ping all the way to 192.168.1.1 from inside the 10 network.
But I can't ping 192.168.1.2 on the VLAN interface of switch 3 from the 10 network.
But I can ping 192.168.1.2 from router 2.
From switch 3 I can ping 192.168.1.1 but I can't ping 10.133.100.2, which is on the same routers as the 192.168.1.1 interface.

I've tried various configurations of eigrp, including auto-summary and no auto-summary and and network 192.168.0.0 and network 192.168.1.0 and network 192.0.0.0. The current config seems to be working better than any others.

Here's all the configuration info...with the extra stuff cut out..

Thanks

!
hostname Router1

interface FastEthernet0/0.1
encapsulation dot1Q 1 native
ip address 10.133.1.1 255.255.255.0
!
interface FastEthernet0/0.2
encapsulation dot1Q 2
ip address 10.133.2.1 255.255.255.0
!
interface FastEthernet0/0.3
encapsulation dot1Q 3
ip address 10.133.3.1 255.255.255.0
!
interface FastEthernet0/1
no ip address
duplex full
speed 100
!
interface Serial0/1/0
ip address 10.133.100.1 255.255.255.252
clock rate 64000
!
interface Vlan1
no ip address
!
interface Vlan2
no ip address
!
router eigrp 10
network 10.0.0.0
network 192.168.1.0
no auto-summary
!
ip classless

Router1#sho ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.133.1.0/24 is directly connected, FastEthernet0/0.1
C 10.133.2.0/24 is directly connected, FastEthernet0/0.2
C 10.133.3.0/24 is directly connected, FastEthernet0/0.3
C 10.133.100.0/30 is directly connected, Serial0/1/0
D 192.168.1.0/24 [90/2172416] via 10.133.100.2, 00:33:46, Serial0/1/0




hostname Router2


interface FastEthernet0/0.1
encapsulation dot1Q 1 native
ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/1/0
ip address 10.133.100.2 255.255.255.252
!

interface Vlan1
no ip address
!
router eigrp 10
network 10.0.0.0
network 192.168.1.0
no auto-summary
!
ip classless

Router2#sho ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
D 10.133.1.0/24 [90/2172416] via 10.133.100.1, 00:35:40, Serial0/1/0
D 10.133.2.0/24 [90/2172416] via 10.133.100.1, 00:35:40, Serial0/1/0
D 10.133.3.0/24 [90/2172416] via 10.133.100.1, 00:35:40, Serial0/1/0
C 10.133.100.0/30 is directly connected, Serial0/1/0
C 192.168.1.0/24 is directly connected, FastEthernet0/0.1


Current configuration : 1045 bytes

hostname Switch 3

interface FastEthernet0/1
switchport mode trunk

interface Vlan1
ip address 192.168.1.2 255.255.255.0

Comments

  • ZartanasaurusZartanasaurus Member Posts: 2,008 ■■■■■■■■■□
    SW3 needs a default-gateway.
    Currently reading:
    IPSec VPN Design 44%
    Mastering VMWare vSphere 5​ 42.8%
  • sleemiesleemie Member Posts: 109
    Wow, that's weird. It worked. I had thought about that, but I hadn't been setting a gateway on my switches, only on my PCs. This is in packet tracer. And on the switches over in the 10 network I don't have gateways set, but they're able to ping over to the 192 network.
Sign In or Register to comment.