Please help a newbie with vmware lab

VinUnleadedVinUnleaded Posts: 68Member ■■□□□□□□□□
Scenario: I have a team of 4 vm's with Server 2008 R2 (my host PC is Win 7 x64)
VM01 just got promoted to Domain Controller

I am trying to verify the DC setup by having VM2 join the domain. When I do that I get this error message

"An Active Directory Domain Controller (AD DC) for the domain 'trinh0301.com' could not be contacted

Ensure that the domain name is typed correctly

If the name is correct, click Details for troubleshooting information"

What am I doing wrong?

Comments

  • EssendonEssendon Posts: 4,548Member ■■■■■■■■■■
    As you probably know, a DC needs to be contactable for a machine to join a domain. Your error means your machine, VM2, cannot contact it. Here's what I'd do, not necessarily in this order.

    1. Can the DC ping VM2, can VM2 ping the DC? Most often in a lab environment, Windows Firewall is what prevents machines from joining domains. Dont just turn the firewall off, disable the service.

    2. If the firewall is off and you still cant join the domain, check the IP addresses. Both the DC and the client (VM2) need to be on the same subnet (atleast in a lab environment). So if your DC has the IP address of 10.0.0.2, set the client to 10.0.0.3

    3. The above 2 points should resolve your issue. To avoid further issues down the road, VMware has it own NAT, DHCP, DNS services, turn them off.

    Not being a jerk or anything, what did you do yourself to fix the issue? Google's your friend. If you cannot figure something out, Google around as much as you can. Teaches you a lot!

    Hope this helps!
    NSX, NSX, more NSX..

    Blog >> http://virtual10.com
  • nhan.ngnhan.ng Posts: 184Member
    are you using the correct log in?icon_lol.gif
  • VinUnleadedVinUnleaded Posts: 68Member ■■□□□□□□□□
    No you are not being a jerk. I appreciate your help. I was able to ping from client to DC and DC to client
    I did 2 things that fixed it
    1. Implemented my own IP address scheme instead of DHCP
    2. I deleted that domain and created a new one
    3. I disabled the firewall on the host machine

    Either 2 or 3 fixed it. I am not such which :)
Sign In or Register to comment.