AD Backup

sina2011sina2011 Posts: 239Member ■□□□□□□□□□
ok well first of all im so embrassed that I'm putting this up as a post but I havent done it in a while so I think im doing something wrong.


I did a full backup of the AD then deleted a OU just to see if it works I then restarted the server went to directory services restore mode by pressing F8 did the offline useraccount .\administrator followed by the password I then did the following commands in cmd:

[FONT=&quot]ntdsutil

[/FONT]
[FONT=&quot]authoritative restore

activate instance "NTDS"

authoritative restore and press enter

restore subtree "DC=banana,DC=internal" [/FONT]


after that I logged back into the DC and the OU I deleted wasnt there after I backed up.

I know there is another way with the wbadmin process etc.

But the process I did doesnt work and I remember doing this in my AD Exam and it worked and i cant find anything on the net related to my problem.

does anybody know whats going on.


Thanks.

Comments

  • SykkSykk Posts: 29Member ■□□□□□□□□□
    Try "restore subtree ou=OUName,dc=banana=internal" - That should do it, I don't think you can restore "subtree" then use it to restore the whole database.

    One of my weaker parts of my 640. Someone correct me if I'm wrong?
    [√] 70-640 - 21/07/2011
    [ ] 70-642 - Currently reading Exam 70-642 Configuring Windows Server 2008 Network Infrastructure
  • sina2011sina2011 Posts: 239Member ■□□□□□□□□□
    hey sykk

    thanks for the reply I actually just fixed it

    What I had to do after I backed up from the ADDS I had to do a recover in ADSRM as well then do the following commands:

    ntdsutil
    authoritative restore
    activate instance NTDS
    authoritative restore
    [FONT=&quot]restore subtree "DC=banana,DC=internal" [/FONT]

    I feel so stupid because I did this when I was studying for the 70-640. icon_sad.gif


    Thanks anyway Appreciate it.
Sign In or Register to comment.