Bootstrap issue

flipmadflipmad Member Posts: 184
I have a 3825 that I upgraded the IOS, when I boot the router, it loads 2 Bootstraps.

As soon as it boots I get the following output:

System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)
Technical Support: Support and Documentation - Cisco Systems
Copyright (c) 2006 by cisco Systems, Inc.

System Bootstrap, Version 12.4(13r)T11, RELEASE SOFTWARE (fc1)
Technical Support: Support and Documentation - Cisco Systems
Copyright (c) 2008 by cisco Systems, Inc.

My sh ver indicates it is using the following
ROM: System Bootstrap, Version 12.4(13r)T11, RELEASE SOFTWARE (fc1)

It is currently running normally. However, there was a reboot and we got the below message. I am trying to figure out if it is from the multiple bootstrap images or could that image be corrupted? Currently it boots just fine, but it shows the multiple bootstrap images.

System Bootstrap, Version 12.4(13r)T11, RELEASE SOFTWARE (fc1) Technical Support: Support and Documentation - Cisco Systems Copyright (c) 2008 by cisco Systems, Inc.

ERROR: Failed to determine platform type Defaulting to C3845NOVPN, System may misbehave


  • CCNP11CCNP11 Member Posts: 11 ■□□□□□□□□□
    Do you have multiple IOS images in your flash memory? Have you set the system boot parameter to look for one specifically?
  • flipmadflipmad Member Posts: 184
    There is only 1 image in my flash

    Router#sh flash:
    -#- --length--
    1 40608624 Jun 23 2011 11:42:52 +00:00 c3825-adventerprisek9-mz.124-19.bin

    I tried to force the 1 boot strap image with the boot bootstrap command and when it reloads it still comes up with the boot bootstrap images
  • CCNP11CCNP11 Member Posts: 11 ■□□□□□□□□□
    the bootstrap command is for a secondary image. remove that command from your config and run this-

    (config)#boot system flash:c3825-adventerprisek9-mz.124-19.bin

    this will force the system to go to that image first. I haven't run into your problem before but it seems that perhaps the system is looking for an image that isn't there and then defaults to finding the first available .bin in flash:
  • flipmadflipmad Member Posts: 184
    Removed the previous command, added the new one, saved it. Reboot and still the same. I am going to reload the image
  • flipmadflipmad Member Posts: 184
    Hmm..I loaded another image and still seeing multiple bootstraps. Is it possible to remove one of them?
  • flipmadflipmad Member Posts: 184
    This is a 3825. But I find it weird when I am changing the baud rate, I am getting this message

    boot: image specified by the boot system commands
    or default to: cisco2-c3845NOVPN
  • CCNP11CCNP11 Member Posts: 11 ■□□□□□□□□□
    Are you using IOS resilient configuration? I've never used it but it seems like it might cause an issue like your seeing if the IOS files are hidden.
  • tierstentiersten Member Posts: 4,505
    Its normal that you see multiple bootstrap lines. It shows that if you've upgraded the bootstrap. The router will initially load the bootstrap which is in protected flash. If there is an upgraded bootflash then the first bootstrap will load the second bootstrap. Each bootstrap will print out a banner line like what you saw. If you look at the version numbers, the first one is older than the second one. Both are kept in flash on the router motherboard itself and aren't on the CF. If nobody has upgraded the bootstrap then it will only show one banner.

    As for the cookie issue, that isn't good if you repeatedly see that. If it is repeatedly complaining about that before loading IOS then something has corrupted the cookie in flash. The "cookie" is an area of flash which stores important information about that router and is generally never altered once it leaves the factory. It will have things in there like the MAC address of any internal interfaces, type of CPU, what model router it is etc... As you can see by the error, it defaulted to assuming that it was 3845 instead of the 3825 it really was. You're not actually gaining any of the 3845 features before anybody asks :P

    It is possible to recreate the cookie by manually entering data into ROMMON but you shouldn't do it unless you're 110% certain as to what you're doing. If the router is under SMARTnet then get them to fix it.

    If it was just a one time only error then just keep an eye on the router and verify that everything looks correct as regarding what IOS thinks the router is, the MAC addresses etc...

    If it is complaining after loading IOS then check that IOS hasn't been corrupted. A corrupt IOS image can cause weird errors like that.
  • flipmadflipmad Member Posts: 184
    I appreciate the help. It definitely was not a resilient configuration. I just wasn't too sure about the multiple bootstraps loading and thought there was a way to access it and delete one of them.

    Regarding the cookie corrupt, the values appear normal, but you never know. Since loading a new IOS I have not had any further errors on the router and I didn't even want to try messing with the cookie values.

    Thanks for all of your help.
Sign In or Register to comment.