routing summarization

solnsusiesolnsusie Member Posts: 128
hi

What is the difference between ip summary-address command and the auto summary command? I’m using EIGRP routing protocol, and to summarize my network it says in the ODOM ICND2 book page # 213 to use the “ip summary-address” interface subcommand, but when I use the “auto summary” router subcommand, my routing table looks exact the same, so what is the difference how we summarize a network???

thanks

Comments

  • CheesyBreadCheesyBread Member Posts: 99 ■■□□□□□□□□
    Auto summary is a router command, ip summary address eigrp is on a specific interface.

    anyone correct me if I'm wrong, I'm still learning too.
  • solnsusiesolnsusie Member Posts: 128
    you are right! but what is the difference in the outcome regarding the routing table, why would some one use one command over the other???
  • billyrbillyr Member Posts: 186
    They both perform a similar function one being a bit more granular than the other.

    If you were to leave the auto-summary command turned on, any subnets you had would be summarized back to their nearest classful address.
    The ip summary address command applied on an interface allows you to summarize more accurately on a per interface basis.

    Lets say for example you had a router with the following 4 subnets directly attached:

    172.16.0.0 /24
    172.16.1.0 /24
    172.16.2.0 /24
    172.16.3.0 /24

    If you were to leave auto-summary applied, these 4 subnets would be summarized back to the nearest classful network, or if you like the parent network that they all came from = the 172.16.0.0 /16 network. This advertisement would be sent through all your interfaces taking part in EIGRP by default.

    Workable but a very lazy way of subnetting as you are now unable to use any other subnet from the 172.16.0.0 network anywhere else in your organization apart from behind that particular router.

    What you could do instead is to use the no auto-summary command as recommended and to summarize your subnets manually grouping together only the 4 that you actually own.

    A manually summary for the 4 subnets above would work out as 172.16.0.0 /22.

    The IP Summary-Address command will allow you to apply the above manual summarization and to advertise this summary out on a per interface basis.

    e.g.

    int f0/0
    ip summary-address eigrp 50 172.16.0.0 255.255.252.0
  • pham0329pham0329 Member Posts: 556
    In addition to what billyr said, autosummary can also cause problems. Suppose you have the following topology

    r1
    > r2 <
    r3

    r1 has the following subnets
    • 172.16.1.0
    • 172.16.2.0
    r3 have the following subnets
    • 172.16.10.0
    • 172.16.11.0
    If you use autosummary, both R1 and R3 will autosummarize the route as 172.16.0.0 when advertising to R2. This is a problem because R2 receives the same route from 2 different interface, and it may start load balancing between the 2 depending on the metric.

    Also, the router will only auto-summarize if the interface the advertisements goes out on belongs to a different major network than the routes being advertised.

    For example, if R1 is connected to R2 via the 172.16.5.0/30 network, and R1 have subnets 172.16.1.0/24 and 172.16.2.0/24, those will not get summarize because they belong to the same major network as 172.16.5.0 (172.16.0.0)
  • solnsusiesolnsusie Member Posts: 128
    billyr wrote: »
    They both perform a similar function one being a bit more granular than the other.

    If you were to leave the auto-summary command turned on, any subnets you had would be summarized back to their nearest classful address.
    The ip summary address command applied on an interface allows you to summarize more accurately on a per interface basis.

    Lets say for example you had a router with the following 4 subnets directly attached:

    172.16.0.0 /24
    172.16.1.0 /24
    172.16.2.0 /24
    172.16.3.0 /24

    If you were to leave auto-summary applied, these 4 subnets would be summarized back to the nearest classful network, or if you like the parent network that they all came from = the 172.16.0.0 /16 network. This advertisement would be sent through all your interfaces taking part in EIGRP by default.

    Workable but a very lazy way of subnetting as you are now unable to use any other subnet from the 172.16.0.0 network anywhere else in your organization apart from behind that particular router.

    What you could do instead is to use the no auto-summary command as recommended and to summarize your subnets manually grouping together only the 4 that you actually own.

    A manually summary for the 4 subnets above would work out as 172.16.0.0 /22.

    The IP Summary-Address command will allow you to apply the above manual summarization and to advertise this summary out on a per interface basis.

    e.g.

    int f0/0
    ip summary-address eigrp 50 172.16.0.0 255.255.252.0

    thanks a lot, i will go ahead and configure first with the auto summary, and check the routing table, and then change to no auto summary and with the interface sub command and ill see the outcome
    thanks again
  • HeeroHeero Member Posts: 486
    In real life, no auto-summary is what will be used every time. Creates more issues than it solves since the introduction of VLSM.
  • solnsusiesolnsusie Member Posts: 128
    billyr wrote: »
    They both perform a similar function one being a bit more granular than the other.

    If you were to leave the auto-summary command turned on, any subnets you had would be summarized back to their nearest classful address.
    The ip summary address command applied on an interface allows you to summarize more accurately on a per interface basis.

    Lets say for example you had a router with the following 4 subnets directly attached:

    172.16.0.0 /24
    172.16.1.0 /24
    172.16.2.0 /24
    172.16.3.0 /24

    If you were to leave auto-summary applied, these 4 subnets would be summarized back to the nearest classful network, or if you like the parent network that they all came from = the 172.16.0.0 /16 network. This advertisement would be sent through all your interfaces taking part in EIGRP by default.

    Workable but a very lazy way of subnetting as you are now unable to use any other subnet from the 172.16.0.0 network anywhere else in your organization apart from behind that particular router.

    What you could do instead is to use the no auto-summary command as recommended and to summarize your subnets manually grouping together only the 4 that you actually own.

    A manually summary for the 4 subnets above would work out as 172.16.0.0 /22.

    The IP Summary-Address command will allow you to apply the above manual summarization and to advertise this summary out on a per interface basis.

    e.g.

    int f0/0
    ip summary-address eigrp 50 172.16.0.0 255.255.252.0
    As I see is, that if I use the ip summary address interface subcommand with no auto summary the routing table will be exact the same like when I use the no auto summary without the ip summary address interface subcommand, and the same is when I use the auto summary together with the ip summary address interface subcommand it will be exact the same results like without the ip summary address interface subcommand, in other words that it wont make a difference when I use the ip summary address interface subcommand or not, it will be the same results,
    Except, if I have it wrong, what I mean is that, im looking on the router which is advertizing this routes, maybe I have to check the rotuers which is learning this routes maybe over there I will see a difference? Who knows???

    please help me out with this
    thanks
  • pham0329pham0329 Member Posts: 556
    depends on what summary address you're putting in. Post your config
  • solnsusiesolnsusie Member Posts: 128
    please check out my config's, look on the underlined and bold and see that with both setting the routing table is the same.



    Router#show ru
    Building configuration...

    interface FastEthernet0/0.2
    encapsulation dot1Q 2
    ip address 192.168.2.1 255.255.255.248
    !
    interface FastEthernet0/0.3
    encapsulation dot1Q 3
    ip address 192.168.2.9 255.255.255.248
    !
    interface Serial1/0
    ip address 11.1.1.1 255.255.255.252
    ip summary-address eigrp 1 192.168.2.0 255.255.255.252 90
    ip summary-address eigrp 1 11.1.1.0 255.255.255.254 90
    clock rate 800000

    router eigrp 1
    network 11.0.0.0
    network 192.168.2.0
    no auto-summary

    show ip rout

    Gateway of last resort is not set

    D EX 10.0.0.0/8 [170/20512000] via 11.1.1.2, 00:02:01, Serial1/0
    11.0.0.0/30 is subnetted, 1 subnets
    C 11.1.1.0 is directly connected, Serial1/0
    D EX 12.0.0.0/8 [170/20512000] via 11.1.1.2, 00:02:01, Serial1/0
    D EX 16.0.0.0/8 [170/20512000] via 11.1.1.2, 00:02:01, Serial1/0
    D EX 172.1.0.0/16 [170/20512000] via 11.1.1.2, 00:02:00, Serial1/0
    D EX 172.2.0.0/16 [170/20512000] via 11.1.1.2, 00:02:01, Serial1/0
    D 172.3.0.0/16 [90/21024000] via 11.1.1.2, 00:02:00, Serial1/0
    D EX 172.4.0.0/16 [170/20512000] via 11.1.1.2, 00:02:01, Serial1/0
    D EX 192.168.1.0/24 [170/20512000] via 11.1.1.2, 00:02:01, Serial1/0
    192.168.2.0/29 is subnetted, 3 subnets
    C 192.168.2.0 is directly connected, FastEthernet0/0.2
    C 192.168.2.8 is directly connected, FastEthernet0/0.3
    D 192.168.2.16 [90/20514560] via 11.1.1.2, 00:02:00, Serial1/0
    D EX 192.168.3.0/24 [170/20512000] via 11.1.1.2, 00:02:00, Serial1/0
    D EX 192.168.4.0/24 [170/20512000] via 11.1.1.2, 00:02:00, Serial1/0


    Router#show ru
    Building configuration...
    interface Serial1/0
    ip address 11.1.1.1 255.255.255.252
    clock rate 800000


    router eigrp 1
    network 11.0.0.0
    network 192.168.2.0
    no auto-summary

    Gateway of last resort is not set

    D EX 10.0.0.0/8 [170/20512000] via 11.1.1.2, 00:01:08, Serial1/0
    11.0.0.0/30 is subnetted, 1 subnets
    C 11.1.1.0 is directly connected, Serial1/0
    D EX 12.0.0.0/8 [170/20512000] via 11.1.1.2, 00:01:08, Serial1/0
    D EX 15.0.0.0/8 [170/20512000] via 11.1.1.2, 00:01:08, Serial1/0
    D EX 16.0.0.0/8 [170/20512000] via 11.1.1.2, 00:01:08, Serial1/0
    D EX 17.0.0.0/8 [170/20512000] via 11.1.1.2, 00:01:08, Serial1/0
    D EX 172.1.0.0/16 [170/20512000] via 11.1.1.2, 00:01:08, Serial1/0
    D EX 172.2.0.0/16 [170/20512000] via 11.1.1.2, 00:01:08, Serial1/0
    D 172.3.0.0/16 [90/21024000] via 11.1.1.2, 00:01:08, Serial1/0
    D EX 172.4.0.0/16 [170/20512000] via 11.1.1.2, 00:01:08, Serial1/0
    D EX 192.168.1.0/24 [170/20512000] via 11.1.1.2, 00:01:08, Serial1/0
    192.168.2.0/29 is subnetted, 3 subnets
    C 192.168.2.0 is directly connected, FastEthernet0/0.2
    C 192.168.2.8 is directly connected, FastEthernet0/0.3
    D 192.168.2.16 [90/20514560] via 11.1.1.2, 00:01:08, Serial1/0
    D EX 192.168.3.0/24 [170/20512000] via 11.1.1.2, 00:01:08, Serial1/0
    D EX 192.168.4.0/24 [170/20512000] via 11.1.1.2, 00:01:08, Serial1/0
    D EX 192.168.6.0/24 [170/20512000] via 11.1.1.2, 00:01:08, Serial1/0
  • pham0329pham0329 Member Posts: 556
    I'm confused...you're trying to summarize a /29 into a /30? Do you have anything connected to this router? If not, that's why the summary route isn't showing up.
  • solnsusiesolnsusie Member Posts: 128
    pham0329 wrote: »
    I'm confused...you're trying to summarize a /29 into a /30? Do you have anything connected to this router? If not, that's why the summary route isn't showing up.
    mmmmmmmmmmmm!!!! its my mistake, sorry i gave the wrong config setting, here you have to correct one!

    Router#show ru
    Building configuration...

    interface FastEthernet0/0.2
    encapsulation dot1Q 2
    ip address 192.168.2.1 255.255.255.248
    !
    interface FastEthernet0/0.3
    encapsulation dot1Q 3
    ip address 192.168.2.9 255.255.255.248
    !
    interface Serial1/0
    ip address 11.1.1.1 255.255.255.252
    clock rate 800000
    !
    router eigrp 1
    network 11.0.0.0
    network 192.168.2.0
    no auto-summary

    Gateway of last resort is not set

    D EX 10.0.0.0/8 [170/20512000] via 11.1.1.2, 00:01:28, Serial1/0
    11.0.0.0/30 is subnetted, 1 subnets
    C 11.1.1.0 is directly connected, Serial1/0
    D EX 13.0.0.0/8 [170/20512000] via 11.1.1.2, 00:01:28, Serial1/0
    D EX 14.0.0.0/8 [170/20512000] via 11.1.1.2, 00:01:28, Serial1/0
    D EX 16.0.0.0/8 [170/20512000] via 11.1.1.2, 00:01:28, Serial1/0
    D EX 172.1.0.0/16 [170/20512000] via 11.1.1.2, 00:01:28, Serial1/0
    D EX 172.2.0.0/16 [170/20512000] via 11.1.1.2, 00:01:28, Serial1/0
    D 172.3.0.0/16 [90/21024000] via 11.1.1.2, 00:01:27, Serial1/0
    D EX 172.4.0.0/16 [170/20512000] via 11.1.1.2, 00:01:28, Serial1/0
    D EX 192.168.1.0/24 [170/20512000] via 11.1.1.2, 00:01:27, Serial1/0
    192.168.2.0/29 is subnetted, 3 subnets
    C 192.168.2.0 is directly connected, FastEthernet0/0.2
    C 192.168.2.8 is directly connected, FastEthernet0/0.3
    D 192.168.2.48 [90/20514560] via 11.1.1.2, 00:01:27, Serial1/0
    D EX 192.168.4.0/24 [170/20512000] via 11.1.1.2, 00:01:27, Serial1/0


    Router#show ru
    Building configuration...

    interface FastEthernet0/0.2
    encapsulation dot1Q 2
    ip address 192.168.2.1 255.255.255.248
    !
    interface FastEthernet0/0.3
    encapsulation dot1Q 3
    ip address 192.168.2.9 255.255.255.248
    !
    interface Serial1/0
    ip address 11.1.1.1 255.255.255.252
    ip summary-address eigrp 1 11.1.1.0 255.255.255.254 90
    ip summary-address eigrp 1 192.168.2.0 255.255.255.248 90
    clock rate 800000
    router eigrp 1
    network 11.0.0.0
    network 192.168.2.0
    no auto-summary



    Gateway of last resort is not set

    D EX 10.0.0.0/8 [170/20512000] via 11.1.1.2, 00:00:24, Serial1/0
    11.0.0.0/30 is subnetted, 1 subnets
    C 11.1.1.0 is directly connected, Serial1/0
    D EX 12.0.0.0/8 [170/20512000] via 11.1.1.2, 00:00:24, Serial1/0
    D EX 16.0.0.0/8 [170/20512000] via 11.1.1.2, 00:00:24, Serial1/0
    D EX 172.1.0.0/16 [170/20512000] via 11.1.1.2, 00:00:24, Serial1/0
    D EX 172.2.0.0/16 [170/20512000] via 11.1.1.2, 00:00:24, Serial1/0
    D 172.3.0.0/16 [90/21024000] via 11.1.1.2, 00:00:24, Serial1/0
    D EX 172.4.0.0/16 [170/20512000] via 11.1.1.2, 00:00:24, Serial1/0
    D EX 192.168.1.0/24 [170/20512000] via 11.1.1.2, 00:00:24, Serial1/0
    192.168.2.0/29 is subnetted, 3 subnets
    C 192.168.2.0 is directly connected, FastEthernet0/0.2
    C 192.168.2.8 is directly connected, FastEthernet0/0.3
    D 192.168.2.48 [90/20514560] via 11.1.1.2, 00:00:24, Serial1/0
    D EX 192.168.3.0/24 [170/20512000] via 11.1.1.2, 00:00:24, Serial1/0
    D EX 192.168.4.0/24 [170/20512000] via 11.1.1.2, 00:00:24, Serial1/0
  • pham0329pham0329 Member Posts: 556
    I'm sorry, I have to ask. Do you know what summary routes are all about and are you familiar with subnetting?

    Also, is the router connected to another router?
  • solnsusiesolnsusie Member Posts: 128
    yes!! I do know exactly what subneting means, I know it in middle of my sleep!!! and about summary, I do know what it is and how to configure it, but as I’m trying it out with this 2 commands, I’m getting confused!!! As you see it does the same with no auto-summary without ip summary-address then with ip summary-address,

    and it is connected to another router, and the configuration from above is from the networks connected to that router,

    does it look like i don’t know what I’m talking????
  • solnsusiesolnsusie Member Posts: 128
    let me ask, do i have to see a difference on the router that the commands are configured, or on the router who gets the advertisement???
  • solnsusiesolnsusie Member Posts: 128
    as i see now, that when i configure ip summary-addres together with no auto summary, and then cange to auto summary it will change the roting table,
  • pham0329pham0329 Member Posts: 556
    solnsusie wrote: »
    yes!! I do know exactly what subneting means, I know it in middle of my sleep!!! and about summary, I do know what it is and how to configure it, but as I’m trying it out with this 2 commands, I’m getting confused!!! As you see it does the same with no auto-summary without ip summary-address then with ip summary-address,

    and it is connected to another router, and the configuration from above is from the networks connected to that router,

    does it look like i don’t know what I’m talking????

    You should see it on both. The router sending the summary route will have an entry in its routing table for the summary route, pointing to Null0. The router receiving the summary route will have the summary router installed in its routing table, pointing to the originating router as the next hop.

    Can you explain your reasoning behind the ip summary-address eigrp 1 192.168.2.0 255.255.255.252 command? Why are you taking a /29 and "summarizing" it as a /30?

    Also, I'm assuming the other router is connected on the S0/0 interface, via the 11.1.1.0/30 subnet? In that case, there's no need for the 11.1.1.0 summary route.
  • solnsusiesolnsusie Member Posts: 128
    pham0329 wrote: »
    You should see it on both. The router sending the summary route will have an entry in its routing table for the summary route, pointing to Null0. The router receiving the summary route will have the summary router installed in its routing table, pointing to the originating router as the next hop.

    Can you explain your reasoning behind the ip summary-address eigrp 1 192.168.2.0 255.255.255.252 command? Why are you taking a /29 and "summarizing" it as a /30?

    Also, I'm assuming the other router is connected on the S0/0 interface, via the 11.1.1.0/30 subnet? In that case, there's no need for the 11.1.1.0 summary route.

    as you see my last reply, that it was a mistake, and it has to be ip summary-address eigrp 1 192.168.2.0 255.255.255.248 90, and the routing table with the no auto summary command looks like this:

    192.168.2.0/29 is subnetted, 3 subnets
    C 192.168.2.0 is directly connected, FastEthernet0/0.2
    C 192.168.2.8 is directly connected, FastEthernet0/0.3
    D 192.168.2.16 [90/20514560] via 11.1.1.2, 00:19:11, Serial1/0

    is that correct how it has to be?, and i don’t see the summary route pointing to Null0, and the summary route of 11.1.1.0 was just for testing-playing purposes, my main concern is the 1192.168.2.0 network,


    please tell me what im doing wrong, im working in this allready a week, and no clue!!!!

    thanks
  • pham0329pham0329 Member Posts: 556
    Because you're summary route is the exact same route as what's already in the routing table. The summary address will only be used if you have more specific routes in the routing table. As I said, you may want to read up on route summarization because you seem a bit confused. If you want a summary route that would capture the 192.168.2.0 and 192.168.2.8, you would use ip summary-route eigrp 1 192.168.2.0 255.255.255.240 (not 248 )
  • solnsusiesolnsusie Member Posts: 128
    pham0329 wrote: »
    Because you're summary route is the exact same route as what's already in the routing table. The summary address will only be used if you have more specific routes in the routing table. As I said, you may want to read up on route summarization because you seem a bit confused. If you want a summary route that would capture the 192.168.2.0 and 192.168.2.8, you would use ip summary-route eigrp 1 192.168.2.0 255.255.255.240 (not 248 )

    that’s why I’m here, if i know exactly how it works i wouldn’t post my question here!!!
    so now i understand better the concept and i changed it to a /28, and my routing table looks like this,
    D 192.168.2.0/28 is a summary, 00:07:42, Null0
    C 192.168.2.0/29 is directly connected, FastEthernet0/0.2
    C 192.168.2.8/29 is directly connected, FastEthernet0/0.3
    is it now correct?
  • MrBrianMrBrian Member Posts: 520
    solnsusie wrote: »
    that’s why I’m here, if i know exactly how it works i wouldn’t post my question here!!!
    so now i understand better the concept and i changed it to a /28, and my routing table looks like this,
    D 192.168.2.0/28 is a summary, 00:07:42, Null0
    C 192.168.2.0/29 is directly connected, FastEthernet0/0.2
    C 192.168.2.8/29 is directly connected, FastEthernet0/0.3
    is it now correct?

    Yes, if you want to summarize both of your connected routes, you'd need a /28 (or less, at least). The /29 you first had configured only summarized 192.168.2.0 - 192.168.2.7, so the connected network ending in .8 was not included in the summary.

    Now when you switched to using the /28, it includes both of your connected networks, and as you see a summary route pointed to Null0 is now installed in your routing table, which is expected.

    The main thing to note about auto-summary and ip summary address is that auto-summary only summarized to the classful boundary. However, the ip summary address command within eigrp allows you to summarize a specific block of addresses. By configuring a network plus subnet mask you can have eigrp advertise a smaller, more precise block of addresses... where auto-summary will advertise the whole Class A/B/C address space.
    Currently reading: Internet Routing Architectures by Halabi
  • solnsusiesolnsusie Member Posts: 128
    thanks a million!!! now i have it locked down!!!! i got it!!icon_cheers.gif
Sign In or Register to comment.