What am I doing wrong!!!?

bermovickbermovick Member Posts: 1,135 ■■■■□□□□□□
I've been stuck on this for HOURS now. From my understanding this should work! (so apparently my understanding is wrong).

Trying to set up a route-map for BGP network command to include all /30 routes in a /16 network (I have 1 set up now, but this is to "plan ahead".

Here's what I have:
ip prefix-list DHCP-POOL seq 5 permit 10.10.0.0/16 ge 30 le 30
route-map SLASH_30S permit 10
 match ip address prefix-list DHCP-POOL

And under my router BGP 46000:
network 10.10.10.0 route-map SLASH_30S
*NOTE I changed this to 10.10.0.0, but I didn't expect it to make a difference (and it didn't)

Show-commands suggest my problem is in the route-map portion, but I don't see HOW:
R6#sh ip prefix-list detail 
Prefix-list with the last deletion/insertion: DHCP-POOL
ip prefix-list DHCP-POOL:
   count: 1, range entries: 1, sequences: 5 - 5, refcount: 3
   seq 5 permit 10.10.0.0/16 ge 30 le 30 (hit count: 0, refcount: 1)
R6#sh route-map 
route-map SLASH_30S, permit, sequence 10
  Match clauses:
    ip address prefix-lists: DHCP-POOL 
  Set clauses:
  Policy routing matches: 0 packets, 0 bytes
Latest Completed: CISSP

Current goal: Dunno

Comments

  • cxzar20cxzar20 Member Posts: 168
    Why don't you have it configured for the neighbor route-map? Also be sure to specify the direction.
  • bermovickbermovick Member Posts: 1,135 ■■■■□□□□□□
    This is just to specify which routes to load into the BGP table; rather than

    10.10.0.0/30
    10.10.0.4/30
    10.10.0.8/30
    ...
    ...
    ...
    10.10.0.252/30





    I thought that prefix list/route map would be "load all the routes in 10.0.10.0/16 that are /30's".

    Configuring it for the neighbor just filters routes that are already in the BGP table, doesn't it?
    Latest Completed: CISSP

    Current goal: Dunno
  • shednikshednik Member Posts: 2,005
    BGP doesn't act like an IGP as in it will advertise what you tell it to whether or not you have an active interface on the router or not. I understand what you're trying to do but I don't believe it will work for BGP.

    ie you can advertise 5.5.5.0/24 on BGP and not have it configured anywhere on your router, and it will still advertise the network to your neighbors.

    hope this helps

    joe
  • bermovickbermovick Member Posts: 1,135 ■■■■□□□□□□
    Are you sure about that? I thought BGP required an exact match (unlike IGP's which will match more specific networks)

    IE:
    network 192.168.0.0/16

    Will match 192.168.1.0/24 for an IGP but not for BGP.
    Latest Completed: CISSP

    Current goal: Dunno
  • cxzar20cxzar20 Member Posts: 168
    bermovick wrote: »
    Are you sure about that? I thought BGP required an exact match (unlike IGP's which will match more specific networks)

    IE:
    network 192.168.0.0/16

    Will match 192.168.1.0/24 for an IGP but not for BGP.

    You are correct, BGP will advertise the routes specified only if they exist in the routing table exactly unless you are using aggregate address. Unfortunately I am not sure what you are trying to do, are you trying to make sure that only /30 are imported into the local routing table or advertised to its peers?
  • bermovickbermovick Member Posts: 1,135 ■■■■□□□□□□
    I was trying to load the BGP table with all the /30 routes without having to manually enter every /30 route (or summarize)

    I'm starting to think it's not possible though, and you either end up doing it all manually:
    network 10.10.0.0 mask 255.255.255.252
    network 10.10.0.4 mask 255.255.255.252
    network 10.10.0.8 mask 255.255.255.252
    network 10.10.0.12 mask 255.255.255.252
    network 10.10.0.16 mask 255.255.255.252
    network 10.10.0.20 mask 255.255.255.252
    network 10.10.0.24 mask 255.255.255.252
    ...
    network 10.10.0.252 mask 255.255.255.252

    or do a null 0 route
    ip route 10.10.0.0 255.255.255.0 null 0
    network 10.10.0.0 mask 255.255.255.0

    or something with auto-summarization I suppose.

    I thought aggregate-address might be the answer, but that looks to aggregate routers already in the table

    I figured there would be a way for the ISPs with /8's that break out lost of /30's to not have to entire insane amounts of those manually. Perhaps there is, but I haven't been able to find it, and it seems to be sidetracking me, so I've just manually entered them all.
    Latest Completed: CISSP

    Current goal: Dunno
  • cxzar20cxzar20 Member Posts: 168
    You may also be able to redistribute connected on the routers with the /30s, but I would be careful with that.
  • shednikshednik Member Posts: 2,005
    bermovick wrote: »
    Are you sure about that? I thought BGP required an exact match (unlike IGP's which will match more specific networks)

    IE:
    network 192.168.0.0/16

    Will match 192.168.1.0/24 for an IGP but not for BGP.

    Thats what I get for responding to posts when I'm tired, you are correct there.

    redistributing the connected routes as suggested would probably be the easiest way to accomplish what you're trying.

    Is this for a lab or are you trying to do something for work?
  • DPGDPG Member Posts: 780 ■■■■■□□□□□
    Redistribute connected and then use a prefix list to filter the announced routes.


    router bgp 65001
    redistribute connected
    neighbor x.x.x.x prefix-list FILTER out

    ip prefix-list FILTER seq 5 permit x.x.x.x/x ge 30 le 30

  • bermovickbermovick Member Posts: 1,135 ■■■■□□□□□□
    This was just for a lab, so it was no big deal (I WISH work would let me do anything like this!).

    What cxzar and DPG are saying about redistributing connected makes sense now. It just seems weird loading them all up on that router then blocking them from going anywhere. Whatever works though!
    Latest Completed: CISSP

    Current goal: Dunno
  • WillTech105WillTech105 Member Posts: 216
    Labbing helps VERY much -- especially when you really dont play with routers enough at work.

    As Jeremy from CBTNuggets suggests, get GNS3 and then head over to Welcome to GNS3Vault and play with the labs. Cool thing is they have youtube solution videos so its great to get some "real world" experience. Doing you learn ALOT more than just reading.
    In Progress: CCNP ROUTE
Sign In or Register to comment.