Need help w/ 3 router lab

brad-brad- Senior MemberMember Posts: 1,218
I have 2x2610XM's w/ DCE/DTE cables going into a WIC-1T and 2x2950's. I set them up while watching the cbt nuggets, had everything working happily.

Then I bought a 3rd router, a 2610 and a Serial 4A/S to go in it. I removed all previous routing - static and RIPv2...and re addressed the interfaces so I had 3 Routers - one on each edge and one in the middle w/ 2 serial connections - one to each. The original 2610XM had the clock rate set on its S0/0...and now that i have another DTE/DCE cable in the mix, I also set the clock rate on the second edge 2610XM. Should the clock rate only be on one DCE...should i not have 2 DTE/DCE cables?

IDK what the problem is, the 2610 in the middle w/ the 4A/S cannot even ping itself. The sho ip int brief tells that the status is up w/ line protocol down. All 3 routers are in HDLC encapsulation.

With the original 2 router 2 switch setup, I had 3 networks, one between each device...and I tried adding a 4th network when introducing the new router in between. The setup is somewhat like a 'bus' with a switch on each edge router...using the 192.168.1.0,2.0,3.0,4.0 networks, all with a /24. I addressed both used interfaces on the middle router, and readdressed one of the edge routers to show its S0/0 on the new network.

Is my setup not feasible? Have i made some kind of common pitfall newbie mistake? Any help would be greatly appreciated.

Comments

  • JaCkNiFeJaCkNiFe Member Member Posts: 96 ■■□□□□□□□□
    Hello Brad,

    Regarding point-to-point serial links:

    You will need to issue the "clock rate [value]" command on all 'DCE' ends.
    Issue the "show controllers [serial interface]" or "do show controllers [serial interface]" (in global config etc.)

    You're looking for the DCE or DTE keywords towards the beginning of the output to determine exactly which side your dealing with.
    Interface Serial0/0
    R2#show controllers s0/0
    Hardware is GT96K
    [b]DCE 530, clock rate 2000000[/b]
    idb at 0x66547418, driver data structure at 0x6654EB24
    wic_info 0x6654F150
    Physical Port 1, SCC Num 1
    MPSC Registers:
    ***output omitted***
    

    A few givens: (doesn't hurt to check)

    Ensure your encapsulation is indeed the same on both ends of the segment. If you make no modifications to encapsulation configuration, as I am sure you well know, the serial links default to HDLC.

    -Easily checked with a 'show run int s0/0' to verify configs or 'show int s0/0' to verify current encapsulation.
    R2#show int s0/0
    Serial0/0 is up, line protocol is down
      Hardware is GT96K Serial
      MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      [b]Encapsulation PPP[/b], LCP Listen, loopback not set
    

    Ensure each of your point-to-point segments are in different subnets. This is not required for the interface to go "up/up" but a little connectivity never hurt anyone!

    HTH...
    Cheers!
    Lab on!
  • brad-brad- Senior Member Member Posts: 1,218
    Thx for the response jack. Yes I did confirm the clock rate was set on each DCE interface and checked the encapsulation on all 4 interfaces.

    I found a website with a similar network diagram that im trying to set up and they show the DCE ends both coming from the "middle" router...as opposed to my setup with the DCE's on the edge routers. I'll try that and post my findings.
  • alxxalxx Senior Member Member Posts: 755
    Double check your "numbering" lines up with cisco's number of ports
    (not left to right)

    Router ports are labelled right to left, switch ports are labelled left to right.

    look at the debug commands

    show controllers
    show diag
    show ip interface brief
    show interfaces
    show ip protocols
    show ip route
    show ip arp
    debug ip rip

    someone else had similar hassles with a rip2 lab
    Configuration Example: RIP-2 Routing
    http://www.techexams.net/forums/ccna-ccent/69001-ripv2-problems.html
    Goals CCNA by dec 2013, CCNP by end of 2014
  • MrBrianMrBrian Grind time, gotta eat Member Posts: 520
    Funny enough with point-to-point serial links when you ping your own interface it actually gets sent across and back. So when you send an echo-request to your own int it goes to the other side and back, then your own interface creates its echo-reply and it goes to the other side and back lol.. this isn't the case for ethernet links, however. You can verify this by looking at the round trip millisecond times in the output. It actually takes longer to ping your own int than pinging the other side!

    Anyways, what I'm getting at is that if you're up/down on an a serial int the layer 3 pings won't work because they're not handled internally, they're actually going across the link. And up/down means layer 2's not ready yet. This could be encapsulation or clocking, mainly. You said both sides are hdlc so that's good. You also mentioned messing messing with the clocks. I'd check there first. Depending on which end of the cable is plugged into what device will be the side you need to configure the clocking. Try a "show controller int s0/0" for example, on both sides, and they'll show you if they're the dte or dce side.. if it's still not working let us know.
    Currently reading: Internet Routing Architectures by Halabi
  • brad-brad- Senior Member Member Posts: 1,218
    Thx for the replies everyone.

    I got it working. I put both DCE ends into the same router so the clock was only coming from one machine (but both used interfaces). I also noticed when doing that that the 2610 did not have the same clock rate values I had set on the 2610XM's...so there's some info in case anyone else comes accress that.
Sign In or Register to comment.