Can't send or receive mail from my mail server

sina2011sina2011 Posts: 239Member ■□□□□□□□□□
hey everyone

I have abit of a problem I have setup a exchange server at home (for testing purposes only) I have done all the neccessary setup requirements I'am not going to get into that,my problem is that I cant send or receive email from my exchange server.

I later Realised my ISP Blocks port 25 so I signed up with this service called mail reflector from no-ip.com I followed the instructions on the link and even changed the port number for smtp as well but still couldn't send or receive.

This is the link to the instructions I followed:
Blocked Port 25? .. Mail on a Non-Standard Port

Just to give you guys more info I have also created send and receive connectors as well,and the type of accessing my exchange server is through OWA.

any tips or hints would be appreciated.


Thanks.

Comments

  • undomielundomiel Posts: 2,818Member
    So you've configured your receive connector for a port other than 25 and configured no-ip.com to send to that port. Skimming through that documentation it looks like there is a verification process to make sure no-ip can communicate with your server. Did you pass that test? Do you have anonymous access configured for that receive connector? If all of those tests passed did you make sure your MX records were setup correctly? mail1.no-ip.com and mail2.no-ip.com and nothing else.

    As to your being unable to send e-mail are you setup to run through a smart host? If your ISP is filtering port 25 they're probably stopping outgoing as well as incoming so you'll need to go through an alternate port and that would require a smart host. I don't see any mention in that guide of whether no-ip.com has smart hosting available or not so you'll want to research into that.
    Jumping on the IT blogging band wagon -- http://www.jefferyland.com/
  • sina2011sina2011 Posts: 239Member ■□□□□□□□□□
    hey undomiel

    thank you for your reply.

    yes I have configured my receive connector using port 2525 and its configured with the same settings as the no-ip.com,regarding the verification process yes i did it the result I got was connection timed out.

    your question regarding if im using anonymous access with my receive connector no im not,yes I did create the mail1.no-ip.com and mail2.no-ip.com records I verified it by doing the following:

    nslookup
    set q=mx
    globalmantics.net

    then for results I got:

    globalmantics.net MX Preference =5, mail exchanger = mail1.no-ip.com
    globalmantics.net MX Preference =10, mail exchanger = mail2.no-ip.com

    regarding your last question no im not using a smart host I used the option use domain name system MX records to route mail automatically.

    hope I have given you enough information.

    Thanks again.
  • undomielundomiel Posts: 2,818Member
    If you're getting a time out from the verification process then it sounds like you have a firewall issue to fix up. Make sure you're opening up 2525 on your router. You won't be able to use DNS to route mail if your ISP is filtering port 25 traffic so you'll have to find a smart host to route through. Do you know why you would need anonymous connections enabled for your receive connector?
    Jumping on the IT blogging band wagon -- http://www.jefferyland.com/
  • sina2011sina2011 Posts: 239Member ■□□□□□□□□□
    Hi undomiel thanks for your reply.

    yeah I have opened port 2525 on my router,when you say I have a firewall blocking it do you think I should create a new inbound rule in windows firewall for DNS?

    No i dont know why I need anonymous connections enabled?


    Thanks.
  • sina2011sina2011 Posts: 239Member ■□□□□□□□□□
    just an update


    I went to windows advanced firewall and opened ports 53 for incoming and outgoing and then ran the test and now it works with message:
    Success! Set mail server and port for globalmantics.net to mail.globalmantics.net:2525


    but still cant send or receive ? icon_sad.gif
  • sina2011sina2011 Posts: 239Member ■□□□□□□□□□
    ok another update:

    I can receive email from the outside but not send im guessing this is becoming a send connector problem?
  • sina2011sina2011 Posts: 239Member ■□□□□□□□□□
    Hi undomiel

    just wanted to let you know I fixed it using a smart host and placed in my ISP Smtp settings in e.g smtp.abc.net.au

    thanks for the help
Sign In or Register to comment.