Unable to ping serial interface

osJoeosJoe Member Posts: 61 ■■□□□□□□□□
Another newbie question here! For some reason I cannot ping the 172.16.10.10 (serial 0/0/0) IP Address from anywhere within this network.. I'm not sure what I'm missing here.

The network 172.16.10.0 has been subnetted with a /29 mask... So I have subnets 0,8 in the picture below with available addresses in the 0 subnet from 1 to 6 and in the 8 subnet 9 to 14.

Output from R1
!
interface FastEthernet0/0
ip address 172.16.10.1 255.255.255.248
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 172.16.10.9 255.255.255.248
clock rate 148000
!
interface Serial0/0/1
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 172.16.10.8 255.255.255.248 172.16.10.10
!

Output from R2
!
!
!
interface FastEthernet0/0
ip address 172.16.10.17 255.255.255.248
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.16.10.25 255.255.255.248
duplex auto
speed auto
!
interface Serial0/0/0
ip address 172.16.10.10 255.255.255.248
!
interface Serial0/0/1
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 172.16.10.0 255.255.255.248 172.16.10.9
!

topology



Thanks for any help on this!

Comments

  • alxxalxx Member Posts: 755
    Sure you really want to use /29 ?

    How many hosts will that give you ?

    How many hosts and ip addresses does your diagram need (don't forget network and broadcast addresses)?
    Goals CCNA by dec 2013, CCNP by end of 2014
  • poguepogue Member Posts: 213
    Not really sure of what the current status of this network is..

    Can you ping from Sales to Marketing PCs?

    But anyways.. According to your config, I am pretty sure -

    ip route 172.16.10.8 255.255.255.248 172.16.10.10

    is supposed to be

    ip route 172.16.10.16 255.255.255.248 172.16.10.10

    In effect, what you are saying with your configured static route is:

    "To get to network x.x.x.8, go to x.x.x.10." (Which, by the by, is actually ON network x.x.x.8.) The router already knows how to get to network x.x.x.8, as it is a directly connected network. I am not sure what that static route is actually doing on the layer 2 level, but I am pretty sure it is confusing the router in some way.

    Russ
    Currently working on: CCNA:Security
    Up next: CCNA:Voice
  • osJoeosJoe Member Posts: 61 ■■□□□□□□□□
    Nope I cannot ping to marketing, as soon as it hits R1 the packet drops. When I try to ping sales FROM marketing it all goes well until the PC from sales forwards the packet through to R1 to get back to marketing and then it drops at R1. I actually added that route on R1 as a last resort because I had no idea why I wasn't (and still cannot) ping 172.16.10.10... I have removed the route and I still am unable to ping the interface.. Maybe PT is being buggy...
  • alxxalxx Member Posts: 755
    sorry ignore , read your question wrong
    Goals CCNA by dec 2013, CCNP by end of 2014
  • drkatdrkat Banned Posts: 703
    you dont need the static routes they'll be known via connected.

    you need to trace it down so go into R1 and can you ping across the link? then ping from the switch... etc until it fails.

    I'd need a little bit more info like where you're pinging from? etc
  • osJoeosJoe Member Posts: 61 ■■□□□□□□□□
    Alxx, A /29 provides me with 32 subnets, correct? Each with 6 hosts possible. I see no reason why this wouldnt work for the network or why I would need more space?

    Drkat, I try a ping from R2, the same router the IP is assigned too and still no response.
  • osJoeosJoe Member Posts: 61 ■■□□□□□□□□
    I see now why the routes are not needed between those two LANs, thanks for pointing that out.

    Here is a look at the whole network...
  • poguepogue Member Posts: 213
    osJoe,

    Work with me here, man. This is a simple issue, but you need to give us the information that helps us help you. If you make a change, post configs.

    YES, you WILL need static routes in order for packets from each Fa0/0 to reach the other router. Without a route of some sort, only R1 will be able to ping R2. No other pings will work across these two routers.

    So, let's approach this methodically:

    1. Are both serial ports in an up/up state? (This is kind of important, and should have been the first bit of info communicated. icon_smile.gif)

    2. Can you ping from R1 to R2, and vice versa?
    (Remember, a "normal" ping sources from the Serial port, as that is the connected interface. No route of any sort is required, static or otherwise.)

    If so, then layer 2 connection is working fine, and this is a route issue.

    If not, are you sure that the R1 Serial interface is DCE? (Do 'show controller' on each router and verif which is connected to DCE end of cable. This may only be relevant if you are using phsical routers, and not GNS3)

    3. If you can ping from router to router, then change your ping to being sourced from the Fa0/0 interface like so:

    R2# ping ip 172.16.10.9 source 172.16.10.17 (This simply tests the routing from R2 LAN to R1 S0/0/0 and back. If this fails, check your ip route statements)

    Since you are not including your changed configs..

    Output from R1
    !
    interface FastEthernet0/0
    ip address 172.16.10.1 255.255.255.248
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    interface Serial0/0/0
    ip address 172.16.10.9 255.255.255.248
    clock rate 148000
    !
    interface Serial0/0/1
    no ip address
    shutdown
    !
    interface Vlan1
    no ip address
    shutdown
    !
    ip classless
    ip route 172.16.10.8 255.255.255.248 172.16.10.10 <<<This will NOT work. You need to understand what this command is trying to accomplish. You are trying to tell the router how to get to R2's ethernet interface network. Does 172.16.10.8 reside off of R2 Fa0/0????????
    !
    Output from R2
    !
    !
    !
    interface FastEthernet0/0
    ip address 172.16.10.17 255.255.255.248
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    ip address 172.16.10.25 255.255.255.248
    duplex auto
    speed auto
    !
    interface Serial0/0/0
    ip address 172.16.10.10 255.255.255.248
    !
    interface Serial0/0/1
    no ip address
    shutdown
    !
    interface Vlan1
    no ip address
    shutdown
    !
    ip classless
    ip route 172.16.10.0 255.255.255.248 172.16.10.9
    Currently working on: CCNA:Security
    Up next: CCNA:Voice
  • Todd BurrellTodd Burrell Member Posts: 280
    The first thing I would try to do is to PING R2 from R1. That is, ping the .10 address from R1. If that does not work, then there is some sort of connectivity issue there. Look at SH IP INT BRIEF on R1 and R2 and make sure you have UP/UP for the links between these routers.

    With this setup you will need a static route on R1 and R3, but you can also just activate some routing protocol (like OSPF or EIGRP) for that as well... R1 will not see the .32 network and R3 will not see the .0 network by default (if I'm reading the diagram correctly).
  • poguepogue Member Posts: 213
    And..mebbe not.

    Tell me.. When Marketing sends a packet to R1, then how does R1 know how to get to network 172.16.10.16 (marketing LAN)?

    Answer: It doesn't.

    Fix this.

    Russ
    Currently working on: CCNA:Security
    Up next: CCNA:Voice
  • poguepogue Member Posts: 213
    Todd,

    There is no need to activate a routing protocol at this point. Right now osJoe does not understand what he is trying to accomplish with the static routes. If you read through his initial configs, he has an error in his static route on R1. This was pointed out, and not fixed. This indicates a break in logic that must be remedied to advance anywhere in cisco, as static routing is used heavily even into the CCIE level. icon_smile.gif

    I agree with your suggestion to verify the Layer 2 (Up/Up) information before chasing wild geese.

    Russ
    Currently working on: CCNA:Security
    Up next: CCNA:Voice
  • MAC_AddyMAC_Addy Member Posts: 1,740 ■■■■□□□□□□
    On R2, what's the output if you type in sh ip route

    Also, I don't think you'll need to add any routes since they're directly connected.

    Starting with the physical layer, are you using the DCE cable on the clocking side and DTE on the non-clocking side?
    2017 Certification Goals:
    CCNP R/S
  • osJoeosJoe Member Posts: 61 ■■□□□□□□□□
    I'm sorry for the lack of information I given, however it looks like you guys spotted the issue with my screwed up static routes, i removed the incorrect ones and have added the following and everything is working perfectly. I was actually pretty confident in static routes but I was making this network at 3AM so that could be the problem...

    R1: 172.16.10.16 [1/0] via 172.16.10.10
    R2: 172.16.10.0 [1/0] via 172.16.10.9

    Thanks again guys. Glad I did this lab before going in for INCD1.
  • poguepogue Member Posts: 213
    MAC_Addy wrote: »
    Also, I don't think you'll need to add any routes since they're directly connected.

    R1's Fa0/0 is not directly connected to R2's Fa0/0.

    The problem was put forth as "an inability to ping 172.16.10.10", when the real problem was R1 had no route to 172.16.10.16 network, and further, that the route that was in place was sabotaging pings to R1.

    We must always be careful to identify the real issue before suggesting fixes. icon_smile.gif

    Russ
    Currently working on: CCNA:Security
    Up next: CCNA:Voice
  • poguepogue Member Posts: 213
    osJoe wrote: »
    I'm sorry for the lack of information I given, however it looks like you guys spotted the issue with my screwed up static routes, i removed the incorrect ones and have added the following and everything is working perfectly. I was actually pretty confident in static routes but I was making this network at 3AM so that could be the problem...

    R1: 172.16.10.16 [1/0] via 172.16.10.10
    R2: 172.16.10.0 [1/0] via 172.16.10.9

    Thanks again guys. Glad I did this lab before going in for INCD1.

    No problem, osJoe..

    Remember the lesson to be learned here... Once you configure all the network interfaces with correct IPs and subnet masks, you have to be careful to think through which routers will need to know about a path to which networks.

    In your diagram, R1 will need static routes to 172.16.10.16, 172.16.10.24, and 172.16.10.32 networks. (Or a default route.)

    R2 will need a static route to 172.16.10.0 and 172.16.10.32.

    Good luck in the way forward, man..

    Russ
    Currently working on: CCNA:Security
    Up next: CCNA:Voice
  • osJoeosJoe Member Posts: 61 ■■□□□□□□□□
    Thanks man! Will keep that in mind.
Sign In or Register to comment.