Inbound and outbound calls failing

JZegersJZegers Member Posts: 79 ■■□□□□□□□□
New to voice, working on getting my first VOIP lab setup. My issue is that inbound and outbound external calls are failing. I can make calls between my phone extensions just fine.

My config:
Building configuration...

Current configuration : 6323 bytes
!
! Last configuration change at 20:31:44 NEB Mon Jan 9 2012 by jzegers
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 2801CME
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
clock timezone NEB -6 0
dot11 syslog
ip source-route
!
!
!
!
ip dhcp pool VOIP
!
!
ip cef
ip domain name UR-MOM
ip name-server 4.2.2.2
ip name-server 8.8.8.8
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
!
!
voice service voip
 ip address trusted list
  ipv4 208.110.65.16 255.255.255.240
  ipv4 173.203.199.137 255.255.255.255
  ipv4 50.22.55.32 255.255.255.255
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 sip
  bind control source-interface FastEthernet0/1
  bind media source-interface FastEthernet0/1
  session transport tcp
  registrar server
!
voice class h323 1
  h225 timeout tcp establish 2
  h225 timeout setup 2
!
!
voice register global
 mode cme
 source-address 172.16.0.254 port 5060
 max-dn 50
 max-pool 10
 tftp-path flash:
 create profile sync 0708160413011592
!
!
!
voice translation-rule 1
 rule 1 /4175209020/ /1000/
!
!
voice translation-profile INCOMING
 translate called 1
!
!
voice-card 0
!
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-18735116
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-18735116
 revocation-check none
!
!
crypto pki certificate chain TP-self-signed-18735116
 certificate self-signed 01
  30820227 30820190 A0030201 02020101 300D0609 2A864886 F70D0101 04050030 
  2F312D30 2B060355 04031324 494F532D 53656C66 2D536967 6E65642D 43657274 
  69666963 6174652D 31383733 35313136 301E170D 31323031 31303032 31393332 
  5A170D32 30303130 31303030 3030305A 302F312D 302B0603 55040313 24494F53 
  2D53656C 662D5369 676E6564 2D436572 74696669 63617465 2D313837 33353131 
  3630819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281 8100B909 
  F615AF67 49D16255 70F92E10 CD7AF685 B7B24CD5 A0C125E0 8F65C1C9 BDF22D92 
  428380D0 28EAAD35 7C3C1DF8 FA39F141 AF6D08BC 8AFB0864 2E99AC4F B52B5893 
  1F2B247A FCC232FA B7636031 4881803C 541E6469 50173CDC CF95157C ADC56B2A 
  0C7EB16F 1CF29406 9B37C1FE 4B6BF653 506AD22D 91FE0860 DAB94232 ADC70203 
  010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603 551D2304 
  18301680 148A98A7 2C399DD7 B4D9A618 E08321A4 DC07E347 8D301D06 03551D0E 
  04160414 8A98A72C 399DD7B4 D9A618E0 8321A4DC 07E3478D 300D0609 2A864886 
  F70D0101 04050003 81810026 D37321F7 13065F92 18C00BAA F58B6929 CA8EF255 
  DE6C18AB FB80AA10 A8DFAD62 EFAC42B7 36529E8B 7FF6F431 7A9F227C E7D4B4AA 
  CBA1EAA4 E31891AB 74B2506E 52AC9983 ED289264 2AD282C9 0E41DA28 E059CBB2 
  88B95A31 2B80353D 7C163FE4 1310A658 7E12F9CA 0ACC9843 D0E2A125 ADD7D7FC 
  AD2A7FED ABA31020 FB7D4F
   quit
!
!
license udi pid CISCO2801 sn FCZ101921S8
username admin privilege 15 secret 5 xxxxxxxxxxxxxu
sername jzegers privilege 15 secret 5 xxxxxxxxxx!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 172.16.0.254 255.255.255.0
 duplex auto
 speed auto
 h323-gateway voip interface
 h323-gateway voip bind srcaddr 172.16.0.254
!
interface FastEthernet0/1
 ip address x.x.x.x 255.255.255.0
 duplex auto
 speed auto
!
ip forward-protocol nd
!
!
no ip http server
ip http authentication local
ip http secure-server
ip route 0.0.0.0 0.0.0.0 69.80.120.1
ip route 172.16.1.0 255.255.255.0 172.16.0.1
ip route 192.168.254.0 255.255.255.0 172.16.0.1
!
logging esm config
!
!
tftp-server flash:/P00308000400.bin alias P00308000400.bin
tftp-server flash:/P00308000400.loads alias P00308000400.loads
tftp-server flash:/P00308000400.sb2 alias P00308000400.sb2
tftp-server flash:/P00308000400.sbn alias P00308000400.sbn
tftp-server flash:/P00308000500.bin alias P00308000500.bin
tftp-server flash:/P00308000500.loads alias P00308000500.loads
tftp-server flash:/P00308000500.sb2 alias P00308000500.sb2
tftp-server flash:/P00308000500.sbn alias P00308000500.sbn
!
control-plane
!
!
!
!
mgcp profile default
!
!
dial-peer voice 1 voip
 description *** 10 Digit Calls ***
 destination-pattern [2-9]..[2-9]......
 session protocol sipv2
 session target sip-server
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad
!
dial-peer voice 2 voip
 description *** 11 Digit Calls ***
 destination-pattern 1[2-9]..[2-9]......
 session protocol sipv2
 session target sip-server
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad
!
dial-peer voice 3 voip
 description *** Lab Extensions ***
 destination-pattern 7......
 session protocol sipv2
 session target sip-server
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad
!
dial-peer voice 100 voip
 description *** Incoming Dial-Peer ***
 session protocol sipv2
 session target sip-server
 incoming called-number .
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad
!
dial-peer voice 4 voip
 destination-pattern .T
 session protocol sipv2
 session target sip-server
 incoming called-number .
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad
!
dial-peer voice 200 voip
 description *** Incoming Dial-Peer ***
 translation-profile incoming INCOMING
 session protocol sipv2
 session target sip-server
 incoming called-number 4175209020
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad
!
!
gateway 
 timer receive-rtp 1200
!
sip-ua 
 credentials username 154001 password 7 xxx realm sip-ua.com
 authentication username 154001 password 7 xxx
 registrar dns:proxy.sip-ua.com expires 60
 sip-server dns:proxy.sip-ua.com
!
!
telephony-service
 max-ephones 10
 max-dn 50
 ip source-address 172.16.0.254 port 2000
 system message JZEGERS.COM
 cnf-file location flash:
 load 7960-7940 P00308000500
 max-conferences 4 gain -6
 web admin system name jzegers secret 5 $xxx
 transfer-system full-consult
 create cnf-files version-stamp 7960 Jan 09 2012 20:05:05
!
!
ephone-dn  10  dual-line
 number 1000 secondary 4175209020
!
!
ephone-dn  11
 number 4175209020
!
!
ephone-dn  12
 number 1001
!
!
ephone  10
 mac-address 0015.F9A3.B2F2
 type 7960
 button  1:10 2:11
!
!
!
ephone  11
 mac-address 0015.F9A2.D607
 type 7960
 button  1:12
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login local
 transport input ssh
!
scheduler allocate 20000 1000
ntp master
ntp server 1.pool.ntp.org
end

When i do a show sip-ua register status this is what i get:
Line                             peer       expires(sec) registered P-Associ-URI
================================ ========== ============ ========== ============
1000                             20001      54           no
1001                             20004      54           no
154001                           -1         56           yes
4175209020                       20002      54           no

What happens when i try an inbound or outbound call is i just get a fast dialtone

Output of show dialplan number (number i am trying to dial)
Last Disconnect Cause is "26  ",
        Last Disconnect Text is "network out of order (3[IMG]https://us.v-cdn.net/6030959/uploads/images/smilies/icon_cool.gif[/IMG]",
        Last Setup Time = 62362.
        Last Disconnect Time = 0.
Matched: xxxxxxxxxx   Digits: 2
Target: sip-server


Just looking to get pointed in the right direction. Can provide any more output/debugging upon request. Been working on this for a while but am stumped at the moment. Sweet network topology attached

Comments

  • pitviperpitviper CCNP:Collaboration, CCNP:R&S, CCNA:S, CCNA:V, CCNA, CCENT Member Posts: 1,376 ■■■■■■■□□□
    For starters, try this:
    voice service voip 
      sip
        session transport udp
    

    If you do a “sh sip-ua register status” does your phone number say “YES” in the registered field?
    CCNP:Collaboration, CCNP:R&S, CCNA:S, CCNA:V, CCNA, CCENT
  • JZegersJZegers Member Posts: 79 ■■□□□□□□□□
    pitviper wrote: »
    For starters, try this:
    voice service voip 
      sip
        session transport udp
    

    If you do a “sh sip-ua register status” does your phone number say “YES” in the registered field?


    Winner! now working. Thanks!
Sign In or Register to comment.