BGP trouble
Can't seem to get BGP working properly, can't figure out what I've missed
R1#traceroute 10.10.10.10
Type escape sequence to abort.
Tracing the route to 10.10.10.10
1 192.168.12.2 64 msec
192.168.13.3 72 msec
192.168.12.2 68 msec
2 192.168.34.4 120 msec
192.168.24.4 64 msec
192.168.34.4 40 msec
3 * * *
R1
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.12.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.13.1 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 192.168.12.1 0.0.0.0 area 0
network 192.168.13.1 0.0.0.0 area 0
!
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback0
no auto-summary
!
no ip http server
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end
R2
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.12.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.24.2 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 192.168.12.2 0.0.0.0 area 0
network 192.168.24.2 0.0.0.0 area 0
!
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback0
no auto-summary
!
no ip http server
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end
R3
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.13.3 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.34.3 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0
network 192.168.13.3 0.0.0.0 area 0
network 192.168.34.3 0.0.0.0 area 0
!
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback0
no auto-summary
!
no ip http server
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end
R4
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.34.4 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.24.4 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet2/0
ip address 192.168.45.4 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 4.4.4.4 0.0.0.0 area 0
network 192.168.24.4 0.0.0.0 area 0
network 192.168.34.4 0.0.0.0 area 0
!
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source Loopback0
neighbor 1.1.1.1 next-hop-self
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source Loopback0
neighbor 2.2.2.2 next-hop-self
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 update-source Loopback0
neighbor 3.3.3.3 next-hop-self
neighbor 5.5.5.5 remote-as 1
neighbor 5.5.5.5 ebgp-multihop 2
neighbor 5.5.5.5 update-source Loopback0
no auto-summary
!
no ip http server
!
ip route 5.5.5.5 255.255.255.255 192.168.45.5
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end
R5
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 5.5.5.5 255.255.255.255
!
interface Loopback1
ip address 10.10.10.10 255.255.255.0
!
interface Loopback2
ip address 20.20.20.20 255.255.255.0
!
interface Loopback3
ip address 30.30.30.30 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.45.5 255.255.255.0
duplex auto
speed auto
!
router bgp 1
no synchronization
bgp log-neighbor-changes
network 10.10.10.0 mask 255.255.255.0
network 20.20.20.0 mask 255.255.255.0
network 30.30.30.0 mask 255.255.255.0
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 ebgp-multihop 2
neighbor 4.4.4.4 update-source Loopback0
no auto-summary
!
no ip http server
!
ip route 4.4.4.4 255.255.255.255 192.168.45.4
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end
R1#traceroute 10.10.10.10
Type escape sequence to abort.
Tracing the route to 10.10.10.10
1 192.168.12.2 64 msec
192.168.13.3 72 msec
192.168.12.2 68 msec
2 192.168.34.4 120 msec
192.168.24.4 64 msec
192.168.34.4 40 msec
3 * * *
R1
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.12.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.13.1 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 192.168.12.1 0.0.0.0 area 0
network 192.168.13.1 0.0.0.0 area 0
!
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback0
no auto-summary
!
no ip http server
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end
R2
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.12.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.24.2 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 192.168.12.2 0.0.0.0 area 0
network 192.168.24.2 0.0.0.0 area 0
!
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback0
no auto-summary
!
no ip http server
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end
R3
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.13.3 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.34.3 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0
network 192.168.13.3 0.0.0.0 area 0
network 192.168.34.3 0.0.0.0 area 0
!
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback0
no auto-summary
!
no ip http server
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end
R4
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.34.4 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.24.4 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet2/0
ip address 192.168.45.4 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 4.4.4.4 0.0.0.0 area 0
network 192.168.24.4 0.0.0.0 area 0
network 192.168.34.4 0.0.0.0 area 0
!
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source Loopback0
neighbor 1.1.1.1 next-hop-self
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source Loopback0
neighbor 2.2.2.2 next-hop-self
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 update-source Loopback0
neighbor 3.3.3.3 next-hop-self
neighbor 5.5.5.5 remote-as 1
neighbor 5.5.5.5 ebgp-multihop 2
neighbor 5.5.5.5 update-source Loopback0
no auto-summary
!
no ip http server
!
ip route 5.5.5.5 255.255.255.255 192.168.45.5
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end
R5
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 5.5.5.5 255.255.255.255
!
interface Loopback1
ip address 10.10.10.10 255.255.255.0
!
interface Loopback2
ip address 20.20.20.20 255.255.255.0
!
interface Loopback3
ip address 30.30.30.30 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.45.5 255.255.255.0
duplex auto
speed auto
!
router bgp 1
no synchronization
bgp log-neighbor-changes
network 10.10.10.0 mask 255.255.255.0
network 20.20.20.0 mask 255.255.255.0
network 30.30.30.0 mask 255.255.255.0
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 ebgp-multihop 2
neighbor 4.4.4.4 update-source Loopback0
no auto-summary
!
no ip http server
!
ip route 4.4.4.4 255.255.255.255 192.168.45.4
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end
Comments
-
Eildor Member Posts: 444iBGP requires a full mesh.
Really? I thought using an IGP, configuring the update-source and next-hop-self would have fixed that problem. -
mayhem87 Member Posts: 73 ■■□□□□□□□□The R5 router doesnt know how to get back to R1. Therefore when R5 gets it it has no way to send anything back cause the route to R1 is not in its routing table. you could use either a static route on r5 so it knows where to send it back. Advertise R1 in in BGP or do a NAT on R4.
-
Eildor Member Posts: 444The R5 router doesnt know how to get back to R1. Therefore when R5 gets it it has no way to send anything back cause the route to R1 is not in its routing table. you could use either a static route on r5 so it knows where to send it back. Advertise R1 in in BGP or do a NAT on R4.
Ah that makes sense... so R5 would need a route to 1.1.1.1, 2.2.2.2, 3.3.3.3 and 4.4.4.4. I don't bloody get BGP, it's complicated. I think I'll end up having to do CCIP just to understand it properly! -
mayhem87 Member Posts: 73 ■■□□□□□□□□no just needs the 1.1.1.1 well technically the interface that the traceroute is going out of unless you do the traceroute with the source of that loopback. That will enable it to speak to router 1. But yes if you want R5 to talk to all of them it has to know about the networks on the inside or just put a default route in.
-
Eildor Member Posts: 444no just needs the 1.1.1.1 well technically the interface that the traceroute is going out of unless you do the traceroute with the source of that loopback. That will enable it to speak to router 1. But yes if you want R5 to talk to all of them it has to know about the networks on the inside or just put a default route in.
Got it. I was being a bit stupid about the whole thing -- don't know what I was thinking. Cheers mate. -
bermovick Member Posts: 1,135 ■■■■□□□□□□Not sure how well the previous responses answered your question, so here goes.
There's a couple things wrong here (actually more, but only 2 that are actually game-breaking).
First off, R4 and R5 aren't able to establish a neighborship because they don't know how to reach each other's loopback interfaces:R5#show bgp summary Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd [B]4.4.4.4 4 100 0 0 0 0 0 never Active[/B] R4#show bgp summary Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd 1.1.1.1 4 100 7 7 1 0 0 00:04:38 0 2.2.2.2 4 100 7 7 1 0 0 00:04:35 0 3.3.3.3 4 100 7 7 1 0 0 00:04:35 0 [B] 5.5.5.5 4 1 0 0 0 0 0 never Active[/B]
Static routes are the easiest way to correct that from my understanding.R4(config)#ip route 5.5.5.5 255.255.255.255 192.168.45.5 R5(config)#ip route 4.4.4.4 255.255.255.255 192.168.45.4
R5# *Mar 1 00:08:39.511: %BGP-5-ADJCHANGE: neighbor 4.4.4.4 Up
Once we've verified the neighbor relationship is establishedR5#show bgp summary Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd 4.4.4.4 4 100 4 5 7 0 0 00:00:18 0
We encounter the second problem: R5 isn't getting any BGP routesR5#sh ip route Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2 ia - IS-IS inter area, * - candidate default, U - per-user static route o - ODR, P - periodic downloaded static route Gateway of last resort is not set C 192.168.45.0/24 is directly connected, FastEthernet0/0 4.0.0.0/32 is subnetted, 1 subnets S 4.4.4.4 [1/0] via 192.168.45.4 20.0.0.0/24 is subnetted, 1 subnets C 20.20.20.0 is directly connected, Loopback2 5.0.0.0/32 is subnetted, 1 subnets C 5.5.5.5 is directly connected, Loopback0 10.0.0.0/24 is subnetted, 1 subnets C 10.10.10.0 is directly connected, Loopback1 30.0.0.0/24 is subnetted, 1 subnets C 30.30.30.0 is directly connected, Loopback3
Because R4 isn't sending it anyR4#sh run | s bgp router bgp 100 no synchronization bgp log-neighbor-changes neighbor 1.1.1.1 remote-as 100 neighbor 1.1.1.1 update-source Loopback0 neighbor 1.1.1.1 next-hop-self neighbor 2.2.2.2 remote-as 100 neighbor 2.2.2.2 update-source Loopback0 neighbor 2.2.2.2 next-hop-self neighbor 3.3.3.3 remote-as 100 neighbor 3.3.3.3 update-source Loopback0 neighbor 3.3.3.3 next-hop-self neighbor 5.5.5.5 remote-as 1 neighbor 5.5.5.5 ebgp-multihop 2 neighbor 5.5.5.5 update-source Loopback0 no auto-summary
The easiest (but probably not the best) way is to redistribute on R4 from OSPF into BGP.R4(config-router)#redistribute ospf 1
BOOYAH.R5#sh ip route Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2 ia - IS-IS inter area, * - candidate default, U - per-user static route o - ODR, P - periodic downloaded static route Gateway of last resort is not set B 192.168.12.0/24 [20/11] via 4.4.4.4, 00:00:07 1.0.0.0/32 is subnetted, 1 subnets B 1.1.1.1 [20/12] via 4.4.4.4, 00:00:07 B 192.168.13.0/24 [20/12] via 4.4.4.4, 00:00:07 2.0.0.0/32 is subnetted, 1 subnets B 2.2.2.2 [20/2] via 4.4.4.4, 00:00:07 3.0.0.0/32 is subnetted, 1 subnets B 3.3.3.3 [20/11] via 4.4.4.4, 00:00:07 C 192.168.45.0/24 is directly connected, FastEthernet0/0 4.0.0.0/32 is subnetted, 1 subnets S 4.4.4.4 [1/0] via 192.168.45.4 B 192.168.24.0/24 [20/0] via 4.4.4.4, 00:00:08 20.0.0.0/24 is subnetted, 1 subnets C 20.20.20.0 is directly connected, Loopback2 5.0.0.0/32 is subnetted, 1 subnets C 5.5.5.5 is directly connected, Loopback0 10.0.0.0/24 is subnetted, 1 subnets C 10.10.10.0 is directly connected, Loopback1 B 192.168.34.0/24 [20/0] via 4.4.4.4, 00:00:09 30.0.0.0/24 is subnetted, 1 subnets C 30.30.30.0 is directly connected, Loopback3
And now on R1:R1#ping 10.10.10.10 Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 10.10.10.10, timeout is 2 seconds: !!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 40/80/112 ms
I actually enjoyed BGP. Looking forward to getting back to it in CCIP land.Latest Completed: CISSP
Current goal: Dunno -
bermovick Member Posts: 1,135 ■■■■□□□□□□Alternately, since there are only 3 "real" routes in AS100, you could just advertise them into BGP on R4:
R4(config-router)#network 192.168.12.0 mask 255.255.255.0 R4(config-router)#network 192.168.13.0 mask 255.255.255.0 R4(config-router)#network 192.168.24.0 mask 255.255.255.0
Edit:Err.... 4 real routes.R4(config-router)#network 192.168.34.0 mask 255.255.255.0
Latest Completed: CISSP
Current goal: Dunno -
mayhem87 Member Posts: 73 ■■□□□□□□□□@bermovick did you take his configs and lab this? he has static routes on R4 and R5 for their loopbacks so I don't see how he has a problem there.
I also disagree with redistributing your IGP into BGP and would stick with either a static route or do a NAT. -
Eildor Member Posts: 444Thank you all for your input.
I've added another two AS's into the picture, it seems to be working fine but I'm not sure if what I've done is valid. When I try and traceroute from R6's loopback (16.16.16.16) to a loopback interface of a AS100 router (for example 172.16.2.1) it takes quite some time to complete the traceroute.
R6#trace ip 172.16.2.1 source l1
Type escape sequence to abort.
Tracing the route to 172.16.2.1
1 192.168.56.5 20 msec 44 msec 24 msec
2 192.168.45.4 36 msec 56 msec 36 msec
3 192.168.24.2 44 msec 44 msec *
R1
interface Loopback0 ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
ip address 172.16.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.12.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.13.1 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 172.16.1.1 0.0.0.0 area 0
network 192.168.12.1 0.0.0.0 area 0
network 192.168.13.1 0.0.0.0 area 0
!
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback0
no auto-summary
R2
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Loopback1
ip address 172.16.2.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.12.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.24.2 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 172.16.2.1 0.0.0.0 area 0
network 192.168.12.2 0.0.0.0 area 0
network 192.168.24.2 0.0.0.0 area 0
!
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback0
no auto-summary
R3
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Loopback1
ip address 172.16.3.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.13.3 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.34.3 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0
network 172.16.3.1 0.0.0.0 area 0
network 192.168.13.3 0.0.0.0 area 0
network 192.168.34.3 0.0.0.0 area 0
!
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback0
no auto-summary
R4
interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface Loopback1
ip address 172.16.4.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.34.4 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.24.4 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet2/0
ip address 192.168.45.4 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 4.4.4.4 0.0.0.0 area 0
network 172.16.4.1 0.0.0.0 area 0
network 192.168.24.4 0.0.0.0 area 0
network 192.168.34.4 0.0.0.0 area 0
!
router bgp 100
no synchronization
bgp log-neighbor-changes
network 172.16.0.0
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source Loopback0
neighbor 1.1.1.1 next-hop-self
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source Loopback0
neighbor 2.2.2.2 next-hop-self
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 update-source Loopback0
neighbor 3.3.3.3 next-hop-self
neighbor 5.5.5.5 remote-as 1
neighbor 5.5.5.5 ebgp-multihop 2
neighbor 5.5.5.5 update-source Loopback0
no auto-summary
!
no ip http server
!
ip route 5.5.5.5 255.255.255.255 192.168.45.5
ip route 172.16.0.0 255.255.0.0 Null0
R5
interface Loopback0
ip address 5.5.5.5 255.255.255.255
!
interface Loopback1
ip address 10.10.10.10 255.255.255.0
!
interface Loopback2
ip address 20.20.20.20 255.255.255.0
!
interface Loopback3
ip address 30.30.30.30 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.45.5 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.56.5 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet2/0
ip address 192.168.57.5 255.255.255.0
duplex auto
speed auto
!
router bgp 1
no synchronization
bgp log-neighbor-changes
network 10.10.10.0 mask 255.255.255.0
network 20.20.20.0 mask 255.255.255.0
network 30.30.30.0 mask 255.255.255.0
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 ebgp-multihop 2
neighbor 4.4.4.4 update-source Loopback0
neighbor 6.6.6.6 remote-as 2
neighbor 6.6.6.6 ebgp-multihop 2
neighbor 7.7.7.7 remote-as 3
neighbor 7.7.7.7 ebgp-multihop 2
no auto-summary
!
no ip http server
!
ip route 4.4.4.4 255.255.255.255 192.168.45.4
ip route 6.6.6.6 255.255.255.255 192.168.56.6
ip route 7.7.7.7 255.255.255.255 192.168.57.7
R6
interface Loopback0
ip address 6.6.6.6 255.255.255.255
!
interface Loopback1
ip address 16.16.16.16 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.56.6 255.255.255.0
duplex auto
speed auto
!
router bgp 2
no synchronization
bgp log-neighbor-changes
network 16.16.16.0 mask 255.255.255.0
neighbor 192.168.56.5 remote-as 1
neighbor 192.168.56.5 update-source Loopback0
no auto-summary
R7
interface Loopback0
ip address 7.7.7.7 255.255.255.255
!
interface Loopback1
ip address 17.17.17.17 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.57.7 255.255.255.0
duplex auto
speed auto
!
router bgp 3
no synchronization
bgp log-neighbor-changes
network 17.17.17.0 mask 255.255.255.0
neighbor 192.168.57.5 remote-as 1
neighbor 192.168.57.5 update-source Loopback0
no auto-summary -
Eildor Member Posts: 444@bermovick did you take his configs and lab this? he has static routes on R4 and R5 for their loopbacks so I don't see how he has a problem there.
I also disagree with redistributing your IGP into BGP and would stick with either a static route or do a NAT.
Yes you are right, I didn't have the issues bermovick mentioned. -
bermovick Member Posts: 1,135 ■■■■□□□□□□@bermovick did you take his configs and lab this? he has static routes on R4 and R5 for their loopbacks so I don't see how he has a problem there.
I also disagree with redistributing your IGP into BGP and would stick with either a static route or do a NAT.
Yeah I did. That's odd. I'll have to re-lab and see why it didn't work until I (re)-added the route.
I agree that redistribution is not the best method of putting the OSPF routes into BGP for it to advertise. I'm not sure why you think having static routes to each site would be the best solution, since that defeats the purpose of having a routing protocol running in the first place. Besides for the EBGP router the problem wasn't it's inability to reach the loopback interfaces (next-hop-self on R4 makes in a moot point), but that it didn't have a route to the 192.16.12.x etc networks in it's routing table. My second post with the network statements would be a better way (this is also where being able to summarize would have been good)Latest Completed: CISSP
Current goal: Dunno -
Eildor Member Posts: 444Yeah I did. That's odd. I'll have to re-lab and see why it didn't work until I (re)-added the route.
Don't worry about it mate -- thank you for your help! -
mayhem87 Member Posts: 73 ■■□□□□□□□□not sure everything seems to be ok granted this is just a quick overview of the configs. as long as the path that it is choosing is correct and you aren't getting any drops i would say its good. I know sometimes when i traceroute in GNS3 and have some routers in there it seems to take a little bit. Post up the traceroute results i guess would be the next thing. are you grabbing this from the cbt nuggets lab? lol looks really familiar.
-
Eildor Member Posts: 444not sure everything seems to be ok granted this is just a quick overview of the configs. as long as the path that it is choosing is correct and you aren't getting any drops i would say its good. I know sometimes when i traceroute in GNS3 and have some routers in there it seems to take a little bit. Post up the traceroute results i guess would be the next thing. are you grabbing this from the cbt nuggets lab? lol looks really familiar.
I've edited my post and included the traceroute. Maybe it is just down to GNS3 then, because it all seems to be working fine. It's not a CBT Nuggets lab, it's just me messing around in GNS3 trying to figure out the basics. -
mayhem87 Member Posts: 73 ■■□□□□□□□□Yeah I did. That's odd. I'll have to re-lab and see why it didn't work until I (re)-added the route. I agree that redistribution is not the best method of putting the OSPF routes into BGP for it to advertise. I'm not sure why you think having static routes to each site would be the best solution, since that defeats the purpose of having a routing protocol running in the first place. Besides for the EBGP router the problem wasn't it's inability to reach the loopback interfaces (next-hop-self on R4 makes in a moot point), but that it didn't have a route to the 192.16.12.x etc networks in it's routing table. My second post with the network statements would be a better way (this is also where being able to summarize would have been good)
-
mayhem87 Member Posts: 73 ■■□□□□□□□□I've edited my post and included the traceroute. Maybe it is just down to GNS3 then, because it all seems to be working fine. It's not a CBT Nuggets lab, it's just me messing around in GNS3 trying to figure out the basics.
-
Eildor Member Posts: 444ya i would say its just GNS3. try doing a traceroute in you AS100 to another AS100 will probably give you some late times aswell. i just did one on a eigrp lab im working on and the times are about comparable.
Traceroute from AS100 to AS2 isn't slow at all -
mayhem87 Member Posts: 73 ■■□□□□□□□□Traceroute from AS100 to AS2 isn't slow at all
traceroute 5.5.5.5
Type escape sequence to abort.
Tracing the route to 5.5.5.5
1 192.168.12.2 48 msec 36 msec 28 msec
2 192.168.24.4 60 msec 68 msec 64 msec
3 192.168.54.5 92 msec 96 msec * -
Eildor Member Posts: 444not sure then man lol here is a traceroute i did so you can compare. This is a 7 router lab connecting over fast ethernet running just one protocol in GNS3.
traceroute 5.5.5.5
Type escape sequence to abort.
Tracing the route to 5.5.5.5
1 192.168.12.2 48 msec 36 msec 28 msec
2 192.168.24.4 60 msec 68 msec 64 msec
3 192.168.54.5 92 msec 96 msec *
Must just be a GNS3 thing then; not to worry! Surprised I was able to even get it to work to be honest! lol. Thank you for your help, much appreciated.