Floppy drive still showing after removal from VM under VMware Workstation 8

certhelpcerthelp Member Posts: 191
Why does the floppy drive still show up even after the virtual machine is configured w/o one. I deleted the floppy drive from the options but I still see it. This didn't happen in VMware Workstation 7.1. Or did I miss something?

Comments

  • jibbajabbajibbajabba Member Posts: 4,317 ■■■■■■■■□□
    certhelp wrote: »
    Why does the floppy drive still show up even after the virtual machine is configured w/o one. I deleted the floppy drive from the options but I still see it. This didn't happen in VMware Workstation 7.1. Or did I miss something?

    Long shot probably, but is that maybe your local drive ?
    My own knowledge base made public: http://open902.com :p
  • azjagazjag Member Posts: 579 ■■■■■■■□□□
    certhelp wrote: »
    Why does the floppy drive still show up even after the virtual machine is configured w/o one. I deleted the floppy drive from the options but I still see it. This didn't happen in VMware Workstation 7.1. Or did I miss something?

    I blame Microsoft ;).
    Remove the hardware through windows, shutdown the vm then remove the Floppy drive and power on again.
    Currently Studying:
    VMware Certified Advanced Professional 5 – Data Center Administration (VCAP5-DCA) (Passed)
    VMware Certified Advanced Professional 5 – Data Center Design (VCAP5-DCD)
  • certhelpcerthelp Member Posts: 191
    jibbajabba wrote: »
    Long shot probably, but is that maybe your local drive ?

    None of my physical computers have any floppy drives; I only have hard drives and optical drives. I can reproduce this on all computers running Worstation 8.
  • certhelpcerthelp Member Posts: 191
    azjag wrote: »
    I blame Microsoft ;).
    Remove the hardware through windows, shutdown the vm then remove the Floppy drive and power on again.

    There aren't any actual floppy drives on any of my computers. I have restarted VMs several times and several occasions. It is most likely VMware issue on only workstation 8. I have seen one or two posts on the VMware communities mention this.

    Even if my computers had a floppy drive, removing the virtual floppy from the configuration should get rid of it. So, it has to do with workstation 8 and probably not Windows 7.
  • azjagazjag Member Posts: 579 ■■■■■■■□□□
    certhelp wrote: »
    There aren't any actual floppy drives on any of my computers. I have restarted VMs several times and several occasions. It is most likely VMware issue on only workstation 8. I have seen one or two posts on the VMware communities mention this.

    Even if my computers had a floppy drive, removing the virtual floppy from the configuration should get rid of it. So, it has to do with workstation 8 and probably not Windows 7.

    I meant remove the floppy through add/remove hardware on the VM, then power down the vm and remove the floppy from the configuration. I didn't think I would have to spell it out for you.

    If the floppy drive bothers you that much, delete all your affected VM's and start from scratch, only this time do it right the first time and create them without floppies.
    Currently Studying:
    VMware Certified Advanced Professional 5 – Data Center Administration (VCAP5-DCA) (Passed)
    VMware Certified Advanced Professional 5 – Data Center Design (VCAP5-DCD)
  • certhelpcerthelp Member Posts: 191
    azjag wrote: »
    I meant remove the floppy through add/remove hardware on the VM, then power down the vm and remove the floppy from the configuration. I didn't think I would have to spell it out for you.

    If the floppy drive bothers you that much, delete all your affected VM's and start from scratch, only this time do it right the first time and create them without floppies.

    The floppy drives were removed before the O/S was installed using the customize hardware option of the new VM creation wizard -- VMs are created with floppy drive by default until you remove using the customization wizard. That's what I did for every VM I created. This happens with both typical (recommended) or custom (advanced) virtual machine option selection of the wizard.



    Because the floppy drives were created without the floppy drive, the Hardware tab of virtual machine settings doesn't list floppy drive.

    Floppy drive shows up even in VMs that were created under 7.1 when used in workstation 8 (after upgrading hardware to version icon_cool.gif.
    azjag wrote: »
    Remove the hardware through windows

    Since you said you blame Microsoft, I took that literally. icon_wink.gif
  • sting_224sting_224 Member Posts: 43 ■■□□□□□□□□
    I noticed this too. I usually remove the floppy before creating the VM but it appears after creating it. After the first boot when the 'cannot connect virtual device...' message comes up, I shutdown the VM, remove the floppy and it doesn't appear again when I power up the VM again.
  • MentholMooseMentholMoose Senior Member Member Posts: 1,525 ■■■■■■■■□□
    Besides removing the floppy from the VM configuration, you also need to disable it in the VM BIOS. It is the same as a physical PC with a floppy controller.

    BIOS configuration:


    Result:
    MentholMoose
    MCSA 2003, LFCS, LFCE (expired), VCP6-DCV
  • certhelpcerthelp Member Posts: 191
    Besides removing the floppy from the VM configuration, you also need to disable it in the VM BIOS. It is the same as a physical PC with a floppy controller.

    Thanks. That did it.
Sign In or Register to comment.