VLSM Issue
sentimetal
Member Posts: 103
in CCNA & CCENT
Hello! I am having an issue with VLSM. I'll start with a scenario:
I'm given an address block of 192.168.1.0/24. On the Fa0/0 side of Router 1 I have a LAN that needs at least enough host address for 20 hosts. On the other side of the router, Se0/0/0 needs just 2 addresses for the WAN link. I cannot use the zero subnet.
On the Fa0/0 side of R2, I'm to use the third subnet. Again, I need at least 20 host addresses. So I use a /27 mask for optimal space.
So I figure:
192.168.1.32/27 is my first subnet for R1's LAN
192.168.1.64/30 is my second subnet, used for the WAN links.
192.168.1.68/27 for R2's LAN.
When I assign the ip addresses to R2's serial interface that connects R1 and R2, I get a message saying the addresses overlap, but how am I supposed to use the 3rd subnet for a WAN link while getting the most efficient address space? If I were to start at 192.168.1.0/30 wouldn't I get:
.0, .4, .8, .12, .16, .20, .24, .28, .32, .36, .40, .44, .48, 52, .56, .60, 64, .68 so wouldn't it be a vaild subnet either way?
I'm given an address block of 192.168.1.0/24. On the Fa0/0 side of Router 1 I have a LAN that needs at least enough host address for 20 hosts. On the other side of the router, Se0/0/0 needs just 2 addresses for the WAN link. I cannot use the zero subnet.
On the Fa0/0 side of R2, I'm to use the third subnet. Again, I need at least 20 host addresses. So I use a /27 mask for optimal space.
So I figure:
192.168.1.32/27 is my first subnet for R1's LAN
192.168.1.64/30 is my second subnet, used for the WAN links.
192.168.1.68/27 for R2's LAN.
When I assign the ip addresses to R2's serial interface that connects R1 and R2, I get a message saying the addresses overlap, but how am I supposed to use the 3rd subnet for a WAN link while getting the most efficient address space? If I were to start at 192.168.1.0/30 wouldn't I get:
.0, .4, .8, .12, .16, .20, .24, .28, .32, .36, .40, .44, .48, 52, .56, .60, 64, .68 so wouldn't it be a vaild subnet either way?
Comments
-
SubnetZero Member Posts: 124Personally I take a single /24 and use it for all of my point-to-points, no need to mix and match from the same /24. Is there some reason you're doing it this way?
Either way if you want to make this work you can use the /30 after the two /27's to make it contiguous
192.168.1.32/27 for R1's LAN
192.168.1.64/27 for R2's LAN
192.168.1.96/30 for the WAN links
So on R1
interface FastEthernet0/0
ip address 192.168.1.33 255.255.255.224
no shut
!
interface Serial0/0
ip address 192.168.1.97 255.255.255.252
no shut
on R2
interface FastEthernet0/0
ip address 192.168.1.65 255.255.255.224
no shut
!
interface Serial0/0
ip address 192.168.1.98 255.255.255.252
no shut
Alternatively you could have blocked out your /30's all the way to .95
While no trees were harmed in the transmission of this message, several electrons were severely inconvenienced :cool: -
sentimetal Member Posts: 103SubnetZero wrote: »Personally I take a single /24 and use it for all of my point-to-points, no need to mix and match from the same /24. Is there some reason you're doing it this way?
Either way if you want to make this work you can use the /30 after the two /27's to make it contiguous
192.168.1.32/27 for R1's LAN
192.168.1.64/27 for R2's LAN
192.168.1.96/30 for the WAN links
So on R1
interface FastEthernet0/0
ip address 192.168.1.33 255.255.255.224
no shut
!
interface Serial0/0
ip address 192.168.1.97 255.255.255.252
no shut
on R2
interface FastEthernet0/0
ip address 192.168.1.65 255.255.255.224
no shut
!
interface Serial0/0
ip address 192.168.1.98 255.255.255.252
no shut
Alternatively you could have blocked out your /30's all the way to .95
The lab instructions said not to use the zero subnet and that subnet 1 was for R1 LAN, subnet 2 was for the WAN link, and subnet 3 was for the the R2 LAN. Would I actually have to keep a /30 mask all the way up to .96 to change to a /27 mask? I can see how .68/27 doesn't make sense, but yeah. -
SubnetZero Member Posts: 124Lab it up and see what happens! I can tell you that I just did it and it works
While no trees were harmed in the transmission of this message, several electrons were severely inconvenienced :cool: -
lanrexng2 Member Posts: 74 ■■□□□□□□□□Thanks for that breakdown Sir ZeroM Sc Computer Science == 1% completeA+, Network+, Security+, CCENT == 100% complete
ICND2, RHCSA, C/C++, Python, x86, -
SubnetZero Member Posts: 124sentimetal wrote: »The lab instructions said not to use the zero subnet and that subnet 1 was for R1 LAN, subnet 2 was for the WAN link, and subnet 3 was for the the R2 LAN. Would I actually have to keep a /30 mask all the way up to .96 to change to a /27 mask? I can see how .68/27 doesn't make sense, but yeah.
It's all binary. I'll point you to a site that explains this well when I get home tonight.
That being said there is kind of method when subneting with VLSM. Basically (like my first method) you should order your subnets by capacity in decreasing numbers.
for our example I put the two /27's first and the /30 as the last one. That’s the order in which you should assign the addresses ranges.
Doing a /27, a /30, and then a /27 is possible but kind of odd so you should always be going from bigger (at the beginging of the range) to smallest towards the end of the range whenever possible
HTH
While no trees were harmed in the transmission of this message, several electrons were severely inconvenienced :cool: -
sentimetal Member Posts: 103SubnetZero wrote: »It's all binary. I'll point you to a site that explains this well when I get home tonight.
That being said there is kind of method when subneting with VLSM. Basically (like my first method) you should order your subnets by capacity in decreasing numbers.
for our example I put the two /27's first and the /30 as the last one. That’s the order in which you should assign the addresses ranges.
Doing a /27, a /30, and then a /27 is possible but kind of odd so you should always be going from bigger (at the beginging of the range) to smallest towards the end of the range whenever possible
HTH
I hate resorting to binary for my subnetting. : ( I suppose it's good for the overall understanding. It DID work, I think for some reason I gave .64 a /27 subnetmask and didn't catch it while checking last time. -
alxx Member Posts: 755Why ?
Don't be scared of binary.
Learn it and use it.Goals CCNA by dec 2013, CCNP by end of 2014 -
SubnetZero Member Posts: 124sentimetal wrote: »I hate resorting to binary for my subnetting. : ( I suppose it's good for the overall understanding. It DID work, I think for some reason I gave .64 a /27 subnetmask and didn't catch it while checking last time.
But that's all this stuff is man, 1's and 0's!
So you said you got this to work with your OG configuration? How? That shouldn't work and doesn't work on any of my routers
R2(config)#interface FastEthernet0/0
R2(config-if)# ip address 192.168.1.69 255.255.255.224
R2(config-if)#interface Serial0/0
R2(config-if)# ip address 192.168.1.65 255.255.255.252
% 192.168.1.64 overlaps with FastEthernet0/0
However if I configure it with .97 there's no overlap
R2(config)#interface FastEthernet0/0
R2(config-if)# ip address 192.168.1.69 255.255.255.224
R2(config-if)#int s0/0
R2(config-if)#ip address 192.168.1.97 255.255.255.252
In fact every address up to 97 will fail because the router expects us to be using subnets in increments of 32 (0,32,64,96, etc) however by throwing a /30 in between the two /27's you're violating this rule.
If this is the PacketTracer lab I'm thinking of I don't think you need the /30 between your WAN interfaces (even though that's best practice)
Also, since they want the second subnet to be used for your WAN interfaces you should probably just do three /27's. In this way you are going in increments of 32 and you wont get the overlap error.
While no trees were harmed in the transmission of this message, several electrons were severely inconvenienced :cool: