Frame-Relay..Spokes not recieving routes
mallyg27
Member Posts: 139
in CCNA & CCENT
I have a hub and spoke setup for frame relay, but for some reason my spokes are not receiving the updates or forming adjacency. I ran debug ip ospf adj and nothing shows up. All the parameters seem to match. I'm using GNS3 to do this. The frame relay is setup properly because they can ping each others interface. I ran debug ip ospf hello and shows that everyone is receiving hellos from each other also. This a point-to-point setup. Any ideas?
R1
interface Serial0/0
no ip address
encapsulation frame-relay
!
interface Serial0/0.1 point-to-point
ip address 172.16.1.1 255.255.255.0
frame-relay interface-dlci 75
!
interface Serial0/0.2 point-to-point
ip address 172.16.2.1 255.255.255.0
frame-relay interface-dlci 76
!
router ospf 1
log-adjacency-changes
network 2.2.2.0 0.0.0.255 area 0
network 172.16.1.0 0.0.0.255 area 0
network 172.16.2.0 0.0.0.255 area 0
R2
interface Serial0/0
ip address 172.16.1.2 255.255.255.0
encapsulation frame-relay
ip ospf hello-interval 10
frame-relay map ip 172.16.1.1 101 broadcast
no frame-relay inverse-arp
!
router ospf 1
log-adjacency-changes
network 172.16.1.0 0.0.0.255 area 0
R3
interface Serial0/0
ip address 172.16.2.2 255.255.255.0
encapsulation frame-relay
frame-relay interface-dlci 102
!
router ospf 1
log-adjacency-changes
network 172.16.2.0 0.0.0.255 area 0
R1
interface Serial0/0
no ip address
encapsulation frame-relay
!
interface Serial0/0.1 point-to-point
ip address 172.16.1.1 255.255.255.0
frame-relay interface-dlci 75
!
interface Serial0/0.2 point-to-point
ip address 172.16.2.1 255.255.255.0
frame-relay interface-dlci 76
!
router ospf 1
log-adjacency-changes
network 2.2.2.0 0.0.0.255 area 0
network 172.16.1.0 0.0.0.255 area 0
network 172.16.2.0 0.0.0.255 area 0
R2
interface Serial0/0
ip address 172.16.1.2 255.255.255.0
encapsulation frame-relay
ip ospf hello-interval 10
frame-relay map ip 172.16.1.1 101 broadcast
no frame-relay inverse-arp
!
router ospf 1
log-adjacency-changes
network 172.16.1.0 0.0.0.255 area 0
R3
interface Serial0/0
ip address 172.16.2.2 255.255.255.0
encapsulation frame-relay
frame-relay interface-dlci 102
!
router ospf 1
log-adjacency-changes
network 172.16.2.0 0.0.0.255 area 0
Comments
-
Monkerz Member Posts: 842Paste the output from 'show ip ospf interface ***' of all your interfaces, if you would.
-
mallyg27 Member Posts: 139This output is from show ip ospf interface:
R1
Serial0/0.2 is up, line protocol is up
Internet Address 172.16.2.1/24, Area 0
Process ID 1, Router ID 172.16.2.1, Network Type POINT_TO_POINT, Cost: 64
Transmit Delay is 1 sec, State POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:04
Index 2/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 172.16.2.2
Suppress hello for 0 neighbor(s)
Serial0/0.1 is up, line protocol is up
Internet Address 172.16.1.1/24, Area 0
Process ID 1, Router ID 172.16.2.1, Network Type POINT_TO_POINT, Cost: 64
Transmit Delay is 1 sec, State POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:04
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 172.16.1.2
Suppress hello for 0 neighbor(s)
R2
Serial0/0 is up, line protocol is up
Internet Address 172.16.1.2/24, Area 0
Process ID 1, Router ID 172.16.1.2, Network Type NON_BROADCAST, Cost: 64
Transmit Delay is 1 sec, State DROTHER, Priority 1
Designated Router (ID) 172.16.2.1, Interface address 172.16.1.1
Backup Designated router (ID) 172.16.2.1, Interface address 172.16.1.1
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:06
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 172.16.2.1 (Designated Router)
Suppress hello for 0 neighbor(s)
R3
Serial0/0 is up, line protocol is up
Internet Address 172.16.2.2/24, Area 0
Process ID 1, Router ID 172.16.2.2, Network Type NON_BROADCAST, Cost: 64
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 172.16.2.2, Interface address 172.16.2.2
Backup Designated router (ID) 172.16.2.1, Interface address 172.16.2.1
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:04
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 2, maximum is 2
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 172.16.2.1 (Backup Designated Router)
Suppress hello for 0 neighbor(s) -
Monkerz Member Posts: 842On R3 under Serial0/0, use "ip ospf network broadcast"
Then after a few seconds do a "sh ip ospf nei' from R1 and paste the output in here. -
mallyg27 Member Posts: 139This the output from sh ip ospf neighbor on R1. The spokes are still not learning the other networks.
Neighbor ID Pri State Dead Time Address Interface
172.16.2.2 1 FULL/ - 00:00:38 172.16.2.2 Serial0/0.2
172.16.1.2 1 FULL/ - 00:00:30 172.16.1.2 Serial0/0.1 -
Monkerz Member Posts: 842I just wanted to make sure an adjacency was possible, guess I could have just read your output, . Under Serial0/0 on both R2 and R3 use 'ip ospf network point-to-point'. You should see the routes then.
-
SubnetZero Member Posts: 124Your configuration isn't right...
R1 is in POINT_TO_POINT mode
R2 is in NON_BROADCAST mode
R3 is in NON_BROADCAST mode
In NBMA mode you need the "neighbor" command plus you have to think about how DR's'/BDR's work over Frame Relay. By default anything in BROADCAST or NON_BROADCAST will require a DR and anything in POINT_TO_POINT or MULTIPOINT wont. Since this is hUB & SPOKE you want the HUB to be the DR and spokes to NEVER become the DR.
To make life easier do the following on R2 and R3 to match R1's network type
R2
interface Serial0/0
no ip ospf hello-interval 10
ip ospf network point-to-point
!
router ospf 1
log-adjacency-changes
network 172.16.1.0 0.0.0.255 area 0
R3
interface Serial0/0
no frame-relay interface-dlci 102
frame-relay map ip 172.16.1.1 102 broadcast
ip ospf network point-to-point
Now clear OSPF:
clear ip ospf process
This should bring up your neighbors. After you're done run the following:
show frame map
show frame lmi
show ip ospf neighbor
Cheers!
While no trees were harmed in the transmission of this message, several electrons were severely inconvenienced :cool: -
mallyg27 Member Posts: 139Yes I can see the routes now. Shouldn't it already have been a point-to-point since I was using sub-interfaces on the hub? My first time encountering that issue. All the videos and books setup was straight forward.
-
Monkerz Member Posts: 842On R1 they were set to Point-to-Point because you used subinterfaces, but a physical serial interface defaults to non-broadcast.
-
mallyg27 Member Posts: 139Thanks a lot. So if I had used sub-interfaces on the spokes I would not have had this problem?
-
SubnetZero Member Posts: 124Thanks a lot. So if I had used sub-interfaces on the spokes I would not have had this problem?
Correct
While no trees were harmed in the transmission of this message, several electrons were severely inconvenienced :cool: