IPSLA issue not routing back to primary link

chmodchmod Member Posts: 360 ■■■□□□□□□□

I have been having a hardtime with IPSLA, it seems to be pretty straightforward but i can't make it work as expected.

I have 2 links with 1 ISP one is a dedicated link over fibber the other is a cable modem. I know is not actually a failover because if the ISP is having issues we won't have internet access at all but seems that they have the enterprise devices in one location and home devices(for cable modem) in another location because when one fails the other one is still up.

Basically the topology is the following:

Cisco 1811
fibber connection to FE0/0
********************Cable Modem. TO FE0/1

Right now the cable modem is just seating there, doing nothing.

The fibber enterprise connection is the WAN providing all the services.

I added the following config

R1811(config)# ip sla 1
R1811(config)# icmp-echo "ISP fibber link GW IP" source-interface FastEthernet0/0
R1811(config)# timeout 1000
R1811(config)# threshold 2
R1811(config)# frequency 3
R1811(config)# ip sla schedule 1 life forever start-time now

R1811(config)# track 1 ip sla 1 reachability
R1811(config)# ip route IP of fibber link track 1
R1811(config)# ip route IP of Cable Modem 10

I first show track and it looks OK
If i shutdown the interface FE0/0 and i show track i can see it down

I created a NAT ACL for the FE0/1 and applied the ip nat outside

R1# show track

Track 1
IP SLA 1 reachability
Reachability is Down
1 change, last change 00:03:19
Latest operation return code: Unknown

Then i do sh ip route and i see the route change to the cable modem which is using the FE0/1

Everything works just fine so far.

When i enable the FE0/0 which is our primary link, i still see the reachability as down but i can ping the GW just fine even using the FE0/0 as the source and the data vlan as source. I had to manually change it i don´t know why is not routing back to the primary link.
sh track shows down just increasing the timer obviously.

This is the sh ver of the router:
Cisco IOS Software, C181X Software (C181X-ADVIPSERVICESK9-M), Version 12.4(24)T3, RELEASE SOFTWARE (fc2)

Any ideas, am i doing something wrong? or missing something? i did a test with the delay down 1 up 1 command, but same result


  • mattaumattau Member Posts: 218
    what happens when you remove threshold?
    CCNP ROUTE - passed 20/3/12
    CCNP SWITCH - passed 25/10/12
    CCNP TSHOOT - passed 11/12/12

  • chmodchmod Member Posts: 360 ■■■□□□□□□□
    Dude u r the men.

    It works now.
  • mattaumattau Member Posts: 218
    keep in mind that the threshold you entered was 2. I belive threshold is like timeout where it is entered in milliseconds.

    frequency is 5 seconds
    timeout 1000 milliseconds = 1 second
    threshold 2 = 2 milliseconds - change it to 2000 which implies 2 seconds. ( or just leave it out altogether )
    CCNP ROUTE - passed 20/3/12
    CCNP SWITCH - passed 25/10/12
    CCNP TSHOOT - passed 11/12/12

Sign In or Register to comment.