EHWIC-D-8ESG-P dhcp

phoeneousphoeneous Go ping yourself...Member Posts: 2,333 ■■■■■■■□□□
First time configuring a EHWIC-D-8ESG-P inside a 2901, can't get dhcp to hand out addresses to anything connected to the switchports. Data is vlan 10,voice is vlan 20. Any help is appreciated.

router#sh run
<snip>
!
!
!
ip dhcp excluded-address 10.0.200.1 10.0.200.49
ip dhcp excluded-address 10.0.200.151 10.0.200.254
ip dhcp excluded-address 10.0.202.1 10.0.202.49
ip dhcp excluded-address 10.0.202.151 10.0.202.254
!
ip dhcp pool ***LAN***
 network 10.0.200.0 255.255.255.0
 default-router 10.0.200.1
 domain-name company.com
 dns-server 10.0.0.2
 lease 7
!
ip dhcp pool ***VOICE***
 network 10.0.202.0 255.255.255.0
 domain-name company.com
 netbios-name-server 10.0.0.2
 option 150 ip 10.0.2.10
 default-router 10.0.202.1
!
!
ip domain name company.com
ip name-server 10.0.0.2
multilink bundle-name authenticated
!
!
voice-card 0
!
!
!
!
!
!
!
license udi pid CISCO2901/K9 sn FTX160686VT
hw-module pvdm 0/0
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/0.1
 encapsulation dot1Q 10
 ip address 10.0.200.1 255.255.255.0
!
interface GigabitEthernet0/0.20
 encapsulation dot1Q 20 native
 ip address 10.0.202.1 255.255.255.0
!
interface GigabitEthernet0/1
 ip address 10.1.10.2 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/3/0
 switchport access vlan 10
 switchport voice vlan 20
 no ip address
 spanning-tree portfast
!
interface GigabitEthernet0/3/1
 switchport access vlan 10
 switchport voice vlan 20
 no ip address
 spanning-tree portfast
!
interface GigabitEthernet0/3/2
 switchport access vlan 10
 switchport voice vlan 20
 no ip address
 spanning-tree portfast
!
interface GigabitEthernet0/3/3
 switchport access vlan 10
 switchport voice vlan 20
 no ip address
 spanning-tree portfast
!
interface GigabitEthernet0/3/4
 switchport access vlan 10
 switchport voice vlan 20
 no ip address
 spanning-tree portfast
!
interface GigabitEthernet0/3/5
 switchport access vlan 10
 switchport voice vlan 20
 no ip address
 spanning-tree portfast
!
interface GigabitEthernet0/3/6
 switchport access vlan 10
 switchport voice vlan 20
 no ip address
 spanning-tree portfast
!
interface GigabitEthernet0/3/7
 switchport access vlan 10
 switchport voice vlan 20
 no ip address
 spanning-tree portfast
!
interface Vlan1
 no ip address
!
interface Vlan10
 no ip address
!
interface Vlan20
 no ip address
!
!
!
!
control-plane
!
!
voice-port 0/1/0
!
voice-port 0/1/1
!
voice-port 0/1/2
!
voice-port 0/1/3
!
!
!
mgcp profile default
!
!
!
!
!
gatekeeper
 shutdown
!
router#

Comments

  • networker050184networker050184 Mod Posts: 11,962 Mod
    So, do you need help with this? Any specific questions?
    An expert is a man who has made all the mistakes which can be made.
  • phoeneousphoeneous Go ping yourself... Member Posts: 2,333 ■■■■■■■□□□
    So, do you need help with this? Any specific questions?

    oops, forgot to put that in :)

    First time configuring a EHWIC-D-8ESG-P inside a 2901, can't get dhcp to hand out addresses to anything connected to the switchports. Data is vlan 10,voice is vlan 20. Any help is appreciated.
  • pitviperpitviper CCNP:Collaboration, CCNP:R&S, CCNA:S, CCNA:V, CCNA, CCENT Member Posts: 1,376 ■■■■■■■□□□
    Try popping the IP addresses on the SVIs instead. Also make sure that the VLANs were created @ L2. Those switch modules are notorious for not auto creating VLANS when you paste in the config.

    Also it looks like you have the voice VLAN as the native VLAN.
    CCNP:Collaboration, CCNP:R&S, CCNA:S, CCNA:V, CCNA, CCENT
  • phoeneousphoeneous Go ping yourself... Member Posts: 2,333 ■■■■■■■□□□
    And that's what I originally did at first but it didnt work. What I found out is that you have to create the vlan first, creating the vlan svi doesnt create the l2 vlan.
    vlan database
    vlan 10
    name data
    vlan 20
    name voice
    exit
    int vlan 10
    ip add ...
    encap dot1q 10 nat
    exit
    int vlan 20
    ip add ...
    encap dot1q 20 nat
    exit

    Also, when assigning the switchports to their respective vlans, you cannot use the range command. You have to apply the config to each interface one at a time. This was also confirmed by cisco tac. I guess it is a bug.

    Also also, when I set the native vlan for int vlan 10 to 10, and did the same for int vlan 20m it would remove it from 10. Also a bug?
  • pitviperpitviper CCNP:Collaboration, CCNP:R&S, CCNA:S, CCNA:V, CCNA, CCENT Member Posts: 1,376 ■■■■■■■□□□
    Yeah, those modules are a bit finicky.

    You shouldn't need the encap command on the SVIs.

    Check this out to - gotta love it! :)

    BUG › angryciscoguy
    CCNP:Collaboration, CCNP:R&S, CCNA:S, CCNA:V, CCNA, CCENT
Sign In or Register to comment.