Inbound Calling Issue

JZegersJZegers Posts: 79Member ■■□□□□□□□□
OK so working in my lab trying to get CUCM fully functional. Phones are registering in CUCM no problem, can call extensions, no problem, can make OUTBOUND calls, no problem. My issue is with inbound calls.

I make an inbound call from an external number, the phone registered through CUCM RINGS, but when i answer it, the inbound calling phone continues to ring, and i eventually get a busy signal.

I am using a 2801 with a SIP trunk to my provider, and using an H323 gateway to my call manager.

Heres what my config looks like:
=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2012.03.09 08:40:45 =~=~=~=~=~=~=~=~=~=~=~=
more sys
2801CME#more system:run
2801CME#more system:running-config
!
! Last configuration change at 23:01:28 NEB Thu Mar 8 2012 by jzegers
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 2801CME
!
boot-start-marker
boot-end-marker
!
!
logging buffered 4096 warnings
!
no aaa new-model
clock timezone NEB -6 0
dot11 syslog
ip source-route
!
!
!
!
ip dhcp pool VOIP
!
!
ip cef
ip domain name UR-MOM
ip name-server 4.2.2.2
ip name-server 8.8.8.8
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
!
!
voice service voip
 ip address trusted list
  ipv4 208.110.65.16 255.255.255.240
  ipv4 173.203.199.137 255.255.255.255
  ipv4 50.22.55.32 255.255.255.255
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 sip
  bind control source-interface FastEthernet0/1
  bind media source-interface FastEthernet0/1
  registrar server
!
voice class h323 1
  h225 timeout tcp establish 2
  h225 timeout setup 2
!
!
voice register global
 mode cme
 source-address 172.16.0.254 port 5060
 max-dn 50
 max-pool 10
 tftp-path flash:
 create profile sync 0708160413011594
!
!
!
voice translation-rule 1
 rule 1 /4175209020/ /7000/
!
!
voice translation-profile INCOMING
 translate called 1
!
!
voice-card 0
!
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-18735116
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-18735116
 revocation-check none
!
!
crypto pki certificate chain TP-self-signed-18735116
 certificate self-signed 01
  30820227 30820190 A0030201 02020101 300D0609 2A864886 F70D0101 04050030 
  2F312D30 2B060355 04031324 494F532D 53656C66 2D536967 6E65642D 43657274 
  69666963 6174652D 31383733 35313136 301E170D 31323033 30393034 32373134 
  5A170D32 30303130 31303030 3030305A 302F312D 302B0603 55040313 24494F53 
  2D53656C 662D5369 676E6564 2D436572 74696669 63617465 2D313837 33353131 
  3630819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281 8100B909 
  F615AF67 49D16255 70F92E10 CD7AF685 B7B24CD5 A0C125E0 8F65C1C9 BDF22D92 
  428380D0 28EAAD35 7C3C1DF8 FA39F141 AF6D08BC 8AFB0864 2E99AC4F B52B5893 
  1F2B247A FCC232FA B7636031 4881803C 541E6469 50173CDC CF95157C ADC56B2A 
  0C7EB16F 1CF29406 9B37C1FE 4B6BF653 506AD22D 91FE0860 DAB94232 ADC70203 
  010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603 551D2304 
  18301680 148A98A7 2C399DD7 B4D9A618 E08321A4 DC07E347 8D301D06 03551D0E 
  04160414 8A98A72C 399DD7B4 D9A618E0 8321A4DC 07E3478D 300D0609 2A864886 
  F70D0101 04050003 81810079 FA9D9F17 CA2F8634 829DB5FC 2734D51B 650E931E 
  B54A3BB9 6E82D5EB D47433FE FE9090F8 DA8153C8 B231B854 B96CBC78 2C1AC8EE 
  E9477D29 AB748D3E 9E632B5E 8D1F6935 234356C3 80C1224A A1F6ECBF C5AC8D59 
  01539B86 4CBD8056 3DD80AEB A62ABE48 3B210E5C 2C452818 A83AC2E6 5355C734 
  9AF4A50B 797B26A2 13CC84
   quit
!
!
license udi pid CISCO2801 sn FCZ101921S8
username admin privilege 15 secret 5 $1$PXXF$MZrWJLgzwiRQ3XVb.W0rl/
username jzegers privilege 15 secret 5 $1$OLAC$WLlux28IUNIfx09xWHdlo.
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 172.16.0.254 255.255.255.0
 duplex auto
 speed auto
 h323-gateway voip interface
 h323-gateway voip bind srcaddr 172.16.0.254
!
interface FastEthernet0/1
 ip address x 255.255.255.0
 duplex auto
 speed auto
!
ip forward-protocol nd
!
!
no ip http server
ip http authentication local
ip http secure-server
ip route 0.0.0.0 0.0.0.0 69.80.120.1
ip route 172.16.1.0 255.255.255.0 172.16.0.1
ip route 192.168.254.0 255.255.255.0 172.16.0.1
!
logging esm config
!
snmp-server community CACTI RO
snmp-server chassis-id 2801CME
!
tftp-server flash:/P00308000400.bin alias P00308000400.bin
tftp-server flash:/P00308000400.loads alias P00308000400.loads
tftp-server flash:/P00308000400.sb2 alias P00308000400.sb2
tftp-server flash:/P00308000400.sbn alias P00308000400.sbn
tftp-server flash:/P00308000500.bin alias P00308000500.bin
tftp-server flash:/P00308000500.loads alias P00308000500.loads
tftp-server flash:/P00308000500.sb2 alias P00308000500.sb2
tftp-server flash:/P00308000500.sbn alias P00308000500.sbn
!
control-plane
!
!
!
!
mgcp profile default
!
!
dial-peer voice 1 voip
 description *** 10 Digit Calls ***
 destination-pattern [2-9]..[2-9]......
 session protocol sipv2
 session target sip-server
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad
!
dial-peer voice 2 voip
 description *** 11 Digit Calls ***
 destination-pattern 1[2-9]..[2-9]......
 session protocol sipv2
 session target sip-server
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad
!
dial-peer voice 3 voip
 description *** Lab Extensions ***
 destination-pattern 7......
 session protocol sipv2
 session target sip-server
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad
!
dial-peer voice 100 voip
 description *** Incoming Dial-Peer ***
 session protocol sipv2
 session target ipv4:172.16.0.253
 incoming called-number .
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad
!
dial-peer voice 4 voip
 destination-pattern .T
 session target ipv4:172.16.0.253
 incoming called-number .
 voice-class h323 1
 dtmf-relay rtp-nte
 no vad
!
dial-peer voice 200 voip
 description *** Incoming Dial-Peer ***
 translation-profile incoming INCOMING
 session protocol sipv2
 session target sip-server
 incoming called-number 4175209020
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad
!
!
gateway 
 timer receive-rtp 1200
!
sip-ua 
 credentials username 154001 password 7 x realm sip-ua.com
 authentication username 154001 password 7 x
 registrar dns:proxy.sip-ua.com expires 60
 sip-server dns:proxy.sip-ua.com
!
!
telephony-service
 max-ephones 10
 max-dn 50
 ip source-address 172.16.0.254 port 2000
 system message JZEGERS.COM
 cnf-file location flash:
 load 7960-7940 P00308000500
 max-conferences 4 gain -6
 web admin system name jzegers secret 5 x
 transfer-system full-consult
 create cnf-files version-stamp 7960 Jan 09 2012 20:05:05
!
!
ephone-dn  10  dual-line
 number 1000 secondary 4175209020
!
!
ephone-dn  11
 number 4175209020
!
!
ephone-dn  12
 number 1001
!
!
ephone  10
 mac-address 0015.F9A3.B2F2
 type 7960
 button  1:10 2:11
!
!
!
ephone  11
 mac-address 0015.F9A2.D607
 type 7960
 button  1:12
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login local
 transport input ssh
!
scheduler allocate 20000 1000
ntp master
end
2801CME#


The one and only route pattern i have in CUCM is [email protected], but i dont feel like that is the issue.

I feel the issue is somewhere with the H323 call setup but im stuck :S

ANY help at all? Can provide screens from call manager if needed.

Comments

  • shodownshodown Posts: 2,271Member
    You have a inbound and outbound dial-peers which is good. Are you sending the call to CUCM. Do a debug voice dial-peer to see what dial peer you are matching to send the call inbound to call manager. Then on that dial-peer check it out to make sure thats legit. You may also have to check your inbound gateway setting to make sure there is nothing funky in there. Debug voice ccapi is also a good command to find out if there are any type of rejections. You can run that one instead of the debug voice dialpeer
    Currently Reading

    CUCM SRND 9x/10, UCCX SRND 10x, QOS SRND, SIP Trunking Guide, anything contact center related
  • JZegersJZegers Posts: 79Member ■■□□□□□□□□
    I am sending it to the CUCM server, i know the peer is working because the phone actually RINGS that is registered with CUCM, its just that when i pick up, the inbound phone continues to ring then i get a busy signal after a bit. Its like when i pickup the phone from CUCM it doesnt get the off hook signal.
  • shodownshodown Posts: 2,271Member
    hmmmm... Since you are using SIP it seems like your SIP messages aren't registering.

    Do a

    Debug ccsip messages
    Debug ccsip calls
    Currently Reading

    CUCM SRND 9x/10, UCCX SRND 10x, QOS SRND, SIP Trunking Guide, anything contact center related
  • JZegersJZegers Posts: 79Member ■■□□□□□□□□
    Sip between phones or sip between the CM and my Gateway? Does a h323 gateway actually use SIP for call signaling?
  • JZegersJZegers Posts: 79Member ■■□□□□□□□□
    When i do a show h323 calls while the phone is ringing this is what i have, everything look normal? Again this is with the CUCM REGISTERED phone ringing with the inbound call from the outside:
    2801CME#show h323 calls
    H323 Info of all [1] calls in detailed format
    H323 call legs at show begin: 1
    Call Leg 1
    H323 CCAPI ID              : 4232
       Peer Leg CCAPID ID      : 4231
       Calling Number          : 402xxxxxxx
       Called Number           : 4175209020
       Remote Sig Addr:Port    : 172.16.0.253:1720
       Remote Media Addr:Port  : 0.0.0.0:0
       Codec:Bytes             : No Codec   :0
       Media Flow Mode         : FLOW_THROUGH
       Status Flags            : 0x48000008 0x0
       H245 Status Flags       : 0x4 0x0
       H225 State              : H225_REQ_FS_ALERT (4)
       IWF State               : IWF_IDLE (0)
       IWF OLC State           : IWF_OLC_IDLE (12)
       TCS IN State            : IDLE (0)
       TCS OUT State           : IDLE (0)
       MSD State               : H245_MS_NONE (0)
       OLC IN State            : H245_OLC_IN_STATE_IDLE (0)
       OLC OUT State           : H245_OLC_OUT_STATE_IDLE (0)
    
  • shameer123shameer123 Posts: 1Registered Users ■□□□□□□□□□
    Hi
    Did you manage to fix this issue,

    really appreciate your help

    shameer
Sign In or Register to comment.