Options

query - frame relay & RIP

alliasneoalliasneo Member Posts: 186
Hey guys, I've got an interesting one today. Just configured Frame Relay with static frame map statements with the broadcast statement. I've just put RIP on top but for some reason, I seem to have a bit of a loop.

This is the topology and I have enabled RIP on all three. I've put a loopback of 2.2.2.2 on R2 but R3 has this route in the routing table?

This is the debug ip rip from R3:

R3#debug ip rip
RIP protocol debugging is on
R3#
*Mar 1 01:54:48.955: RIP: sending v1 update to 255.255.255.255 via Serial0/0 (1
72.12.123.3)
*Mar 1 01:54:48.955: RIP: build update entries
*Mar 1 01:54:48.955: network 2.0.0.0 metric 3
*Mar 1 01:54:48.955: subnet 172.12.123.0 metric 1
R3#
*Mar 1 01:55:00.109: RIP: received v1 update from 172.12.123.1 on Serial0/0
*Mar 1 01:55:00.109: 2.0.0.0 in 2 hops
*Mar 1 01:55:00.109: 172.12.123.0 in 1 hops



I can post the config up as well.

R1

frameswitch#sh run
Building configuration...


Current configuration : 1945 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname frameswitch
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
no network-clock-participate slot 1
no network-clock-participate wic 0
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
no ip ips deny-action ips-interface
no ip domain lookup
!
frame-relay switching
!
!
!
!
!
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
shutdown
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.10
encapsulation isl 10
ip address 192.168.0.1 255.255.255.0
no ip redirects
no snmp trap link-status
!
interface FastEthernet0/0.20
encapsulation isl 20
ip address 10.10.10.1 255.255.255.0
no ip redirects
no snmp trap link-status
!
interface Serial0/0
ip address 172.12.123.1 255.255.255.0
encapsulation frame-relay
frame-relay map ip 172.12.123.2 112 broadcast
frame-relay map ip 172.12.123.3 113 broadcast
no frame-relay inverse-arp
!
interface Serial0/1
no ip address
shutdown
!
interface Serial1/0
no ip address
shutdown
!
interface Serial1/1
no ip address
encapsulation frame-relay
clockrate 64000
no frame-relay inverse-arp
frame-relay intf-type dce
frame-relay route 112 interface Serial1/2 221
frame-relay route 113 interface Serial1/3 321
!
interface Serial1/2
no ip address
encapsulation frame-relay
clockrate 64000
no frame-relay inverse-arp
frame-relay intf-type dce
frame-relay route 221 interface Serial1/1 112
!
interface Serial1/3
no ip address
encapsulation frame-relay
clockrate 64000
no frame-relay inverse-arp
frame-relay intf-type dce
frame-relay route 321 interface Serial1/1 113
!
router rip
network 172.12.0.0
!
ip classless
!
no ip http server
no ip http secure-server
!
!
!
control-plane
!
!
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
login
!
!

_____________________________________________________________

R2

R2#sh run
Building configuration...


Current configuration : 987 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 10
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
no ip ips deny-action ips-interface
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Ethernet0/0
ip address 172.23.23.2 255.255.255.0
half-duplex
!
interface Serial0/0
ip address 172.12.123.2 255.255.255.0
encapsulation frame-relay
frame-relay map ip 172.12.123.1 221 broadcast
frame-relay map ip 172.12.123.3 221 broadcast
no frame-relay inverse-arp
!
interface Ethernet0/1
no ip address
shutdown
half-duplex
!
interface Serial0/1
no ip address
shutdown
!
router rip
network 2.0.0.0
network 172.12.0.0
!
ip classless
!
no ip http server
no ip http secure-server
!
!
!
control-plane
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end

_________________________________________________________

R3

R3#sh run
Building configuration...


Current configuration : 1106 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
no ip ips deny-action ips-interface
no ip domain lookup
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
shutdown
!
interface Loopback1
no ip address
!
interface Loopback2
no ip address
!
interface Loopback10
no ip address
!
interface Loopback20
no ip address
!
interface Loopback50
no ip address
!
interface Ethernet0/0
ip address 192.168.0.1 255.255.255.0
half-duplex
!
interface Serial0/0
ip address 172.12.123.3 255.255.255.0
encapsulation frame-relay
frame-relay map ip 172.12.123.1 321 broadcast
frame-relay map ip 172.12.123.2 321 broadcast
!
interface Serial0/1
no ip address
!
router rip
network 172.12.0.0
!
ip classless
!
no ip http server
no ip http secure-server
!
!
!
control-plane
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end

Comments

  • Options
    controlcontrol Member Posts: 309
    Hi,

    I'm only just studying for my CCNA myself so my theory might be totally wrong.

    I believe if you are using the physical interface for frame relay (Not subinterfaces) then split horizon is actually disabled by default. You would have to enable it using no ip split-horizon.
    However, if you use subinterfaces then the problem would go away as split horizon would be on as default as you would normally expect.
    You should be able to see this if you use a show ip int command on the interface. It will show Split Horizon as disabled

    Like I say...I may be way of on a tangent here and this is my first attempt at actually answering anyones ccna query.
  • Options
    Nate--IRL--Nate--IRL-- Member Posts: 103 ■■□□□□□□□□
    Looks like it's being routed through R1 - that will give 3 hops from R2 to R3.

    Loopback to R2 is 1 hop
    R2 to R1 is 1 hop &
    R1 to R3 is the third.

    Also your frame relay maps in R2 and R3 have the same DLCI for 2 IPs. R2 and R3 cant communicate directly, hence the route being discovered through R1.

    EDIT:- Looking at it again you have no frame relay route setup between R2 and R3. They aren't connected.

    Nate
Sign In or Register to comment.