Options

Stuck on some #70-642 Work - Netdom problems

ov3rtonov3rton Registered Users Posts: 3 ■□□□□□□□□□
Hey everyone, just stumbled across this amazing resource while trying to troubleshoot my problem. Thought this seemed like the best/friendliest place to ask.

I'm working through the MCTS guide #70-642 and I'm stuck trying to join my server core08 machine to my domain (running server2k8 both enterprise 64-bit.

Logon failure: Unknown user name or bad password <=== My problem

I'm using my domain server admin account and the correct password.

I'm using VirtualBox. I'm pretty sure I have all the networking settings correct, I can Ping my domain from the core install as well as my domain server.

I've tried almost every netdom command variation that I could find. I just can't get past this Logon failure.

bentech.local is the domain
MSN-SC-001 is the server core machine

What I've tried:
netdom join \\msn-sc-001 /domain:bentech.local /UserD:bentech.local\administrator /PasswordD:MyDomainAdminPass

netdom join msn-sc-001 /domain:bentech.local /UserD:bentech.local\administrator /PasswordD:MyDomainAdminPass

netdom join msn-sc-001 /domain:bentech.local

and a few others.

Sorry for the lengthy first post, thanks in advance for any help.

Comments

  • Options
    buzzkillbuzzkill Member Posts: 95 ■■□□□□□□□□
    The syntax looks fine, I did that very middle command just the other day.

    I guess by pinging you mean pinging the fqdn of the dc rather than the just the hostname, as that would reply with the ipv6 link local address so it would look like it was fine but wouldn't work for a domain join.

    Actually thinking aloud I suppose it can't be a DNS issue since it gets beyond that point, if it was it would say unable to contact domain or whatever.

    I wonder if it works if you try with sconfig?

    I'd make another domainadmin account and trying that.

    is this a cloned VM or a fresh install?

    These things usually turn out to be something annoyingly simple. I'm sure you've ruled out typos by now but if not...
  • Options
    ov3rtonov3rton Registered Users Posts: 3 ■□□□□□□□□□
    Tried a new user, still having the same problem. The install is fresh too.

    Here's my ipconfig from the domain server
    dSS2dl.jpg

    And ipconfig from Server Core Install.
    sRRc7l.jpg
  • Options
    kriscamaro68kriscamaro68 Member Posts: 1,186 ■■■■■■■□□□
    Is your DC also DNS server? Have you tried setting the DNS settings of the server core server to be that of your DC and joining then?
  • Options
    undomielundomiel Member Posts: 2,818
    Try netdom join msc-sc-001 /domain:bentech.local /userd:administrator /passwordd:*

    That will allow you type out the password without putting it in the command and worrying that any special characters will cause trouble.
    Jumping on the IT blogging band wagon -- http://www.jefferyland.com/
  • Options
    ov3rtonov3rton Registered Users Posts: 3 ■□□□□□□□□□
    K, finally fixed it. I had to go disable the NAT connection on the server core machine. Thanks for all the help everyone. I'm really glad I found this amazing resource.
Sign In or Register to comment.