Still Stuck in SDM/GNS3 Hell? Here's a Solution

hiddenknight821hiddenknight821 The whole Shebang!Member Posts: 1,209 ■■■■■■□□□□
Before today, I thought I would no problem using SDM with GNS3 until I ran into the firewalls stuff, and I was unable to view Zones in Configure > Additional Tasks > Zones in SDM. I thought swapping the IOS with the one that actually has ZBFW (Zone-Based Policy Firewall) feature would solve my problem, but it didn't. I even checked to see if the IOS image I used actually contains the feature using this helpful link, Cisco Feature Navigator.

After losing many hours researching for a solution, I finally found the solution. It turned out that an older version of SDM, which was very similar to the figures in Paquet book, was a success. I was using SDM version 2.5, and it caused many problems. I downgraded to version 2.4.1. I also downgraded the Java Runtime Environment (JRE) back to four version earlier following someone else's advice and this was also mentioned in the SDM v.2.5 release note. I used
JRE 1.6.0_03 to get it to work.


Here are the following things I used:
- IOS image: c3725-adventerprisek9-mz.124-15.T8.bin (I was told c3725 IOSes are very reliable in GNS3).
- Windows XP SP3 (for SDM)
- GNS3 0.7.4
- Internet Explorer 6.0.2900.5512.xpsp_sp3_gdr.101209-1647


I hope you find this helpful while trying to finish the 640-553 exam before it expires at the end of September.

Comments

  • hiddenknight821hiddenknight821 The whole Shebang! Member Posts: 1,209 ■■■■■■□□□□
    Thought I should post this here. Just ran into another issue when doing the Cisco IPS stuff, but it's pretty easy to fix. Using the above version I recommended, you should be able to follow this easy guide. Java Runtime Environment has a limited memory by default and cannot run the IPS feature. You probably will see this error: "your current java memory heap size is less than 256mb...blah, blah blah." So basically, you just have to change the parameter of the executable in the Java Control Panel. Here's the link that will help you step by step.

    Sun Java Plugin - How to Increase the Java Applet Memory Limit
  • spd3432spd3432 Senior Member Member Posts: 224
    I ran into the same java memory issue. However, I wasn't able to get it to stay locked. Turned out I had two versions of java installed (1.6.0_03 and 1.6.0_31). The latter version showed up because it did an immediate upgrade as soon as it connected to the internet. Uninstalled all java, pulled the network cable, installed the older version, then hit both the java control panel and the registry to prevent automatic updates.

    One other item I ran into was having to enable the browser to allow it to run code from local drive.
    Tools -> Internet Options -> Advanced -> Security -> "Allow active content to run in files on My Computer"
    ----CCNP goal----
    Route [ ] Studying
    Switch [ ] Next
    Tshoot [ ] Eventually
Sign In or Register to comment.