Options

PPPoE via DSL issue - config inside, please advise.

T.AbbasiT.Abbasi Member Posts: 26 ■□□□□□□□□□
Hello everyone,

I've configured a 2611xm router with PPPoE to work with our DSL at work (we have a separate DSL connection for testing purposes). The issue that i'm running into is a little weird.

The configuration (see below), very simple and straightforward, works fine, i'm geting the negotiated external IP address, the router is able to ping all over the place, however, when i connect the router directly to my laptop, i can browse with no issues, but when i connect the router to a switch, i'm unable to browse, only sites that seems to work are google.com and skype. i click on the 'news' link in google, and then when i click on the sublinks, the pages dont load and i get timed out, again this is if connected via a switch)

If i do nslookup google.com, or nslookup for any other site, the dns resolves the same IP address for ALL the sites. again this is connected via the switch. The DNS that we are using is OpenDNS, since this router will be placed out into one of our field offices in Peru.

the subnets, default gateways are all correct and verified. the switch being used is a 2960 48port, nothing crazy on the switch as well. only a banner and login/password configured, right now its just plug and play. we know that the switch works fine since we tested it with other devices.

in the config below i've removed all the passwords for obvious reasons, but the config works (unless you guys think otherwise).

its been very frustrating and any help will be appreciated.

(also, any idea which version of 12.4 supports SSH, my current IOS 12.4(25d) doesnt support SSH)


Current configuration : 1825 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname WCS_Peru
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$8DFv$Yiqx8t6/Rp3qSRmCXieOO0
!
no aaa new-model
memory-size iomem 10
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.11.2 192.168.11.9
!
ip dhcp pool DHCP
import all
network 192.168.11.0 255.255.255.0
default-router 192.168.11.1
dns-server 208.67.220.220 208.67.222.222
lease 7
!
!
ip domain name test.org
!
username tabbasi password 7 <removed for security>
!
!
!
!
interface FastEthernet0/0
description EXTERNAL DSL CONNECTION
no ip address
duplex auto
speed auto
pppoe enable
pppoe-client dial-pool-number 1
!
interface FastEthernet0/1
description INTERNAL LAN CONNECTION
ip address 192.168.11.1 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
dialer pool 1
ppp authentication pap callin
ppp pap sent-username <removed for security> password 7 <removed for security>
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1
!
ip http server
ip nat inside source list 100 interface Dialer1 overload
!
access-list 100 permit ip 192.168.11.0 0.0.0.255 any
!
control-plane
!
banner motd ^C
************************************************************************
This is a secure router. Unauthorized access is strictly restricted.
************************************************************************^C
!
line con 0
exec-timeout 30 0
password 7 <removed for security>
logging synchronous
login
line aux 0
line vty 0 4
exec-timeout 20 0
password 7 <removed for security>
login local
!
end

Comments

Sign In or Register to comment.