OSPF Packet Tracer Problem

whitehat_dreamswhitehat_dreams Registered Users Posts: 4 ■□□□□□□□□□
Problem: Router not appearing in show ip ospf neighors
Scenario: I configured ospf on all routers in a similar manner, then tried pinging different networks to test my configurations. I found out I couldn't ping the networks of the 2 Fast Ethernet connections on Router 4(named BB1), but I could ping the serial interface connecting router 4 and router 1. Since they should (atleast I think they should) have a similar setup with router 3 and router 4, I can't seem to find the problem.

P.S. I replaced the multiple "!" lines with "..." to shorten post.

Outputs:
BB1/Router4
show running-config
Current configuration : 1073 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname BB1
!
...
!
interface Loopback0
description BB1
ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet0/0
ip address 172.16.10.254 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.16.11.254 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
no ip address
clock rate 2000000
shutdown
!
interface Serial0/1
no ip address
clock rate 2000000
shutdown
!
interface Serial0/2
ip address 10.1.1.2 255.255.255.0
!
interface Serial0/3
no ip address
clock rate 2000000
shutdown
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet1/1
no ip address
duplex auto
speed auto
shutdown
!
router ospf 1
log-adjacency-changes
network 172.16.11.0 0.0.0.255 area 0
network 172.16.10.0 0.0.0.255 area 0
network 10.1.1.0 0.0.0.255 area 0
!
ip classless
!
...
!
line con 0
line vty 0 4
login
!
!
!
end

show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 172.16.10.254 YES manual up up

FastEthernet0/1 172.16.11.254 YES manual up up

Serial0/0 unassigned YES unset administratively down down

Serial0/1 unassigned YES unset administratively down down

Serial0/2 10.1.1.2 YES manual up up

Serial0/3 unassigned YES unset administratively down down

FastEthernet1/0 unassigned YES unset administratively down down

FastEthernet1/1 unassigned YES unset administratively down down

Loopback0 5.5.5.5 YES manual up up

show ip ospf interface
FastEthernet0/0 is up, line protocol is up
Internet address is 172.16.10.254/24, Area 0
Process ID 1, Router ID 5.5.5.5, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 5.5.5.5, Interface address 172.16.10.254
No backup designated router on this network
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:03
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 0, Adjacent neighbor count is 0
Suppress hello for 0 neighbor(s)
FastEthernet0/1 is up, line protocol is up
Internet address is 172.16.11.254/24, Area 0
Process ID 1, Router ID 5.5.5.5, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 5.5.5.5, Interface address 172.16.11.254
No backup designated router on this network
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:03
Index 2/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 0, Adjacent neighbor count is 0
Suppress hello for 0 neighbor(s)
Serial0/2 is up, line protocol is up
Internet address is 10.1.1.2/24, Area 0
Process ID 1, Router ID 5.5.5.5, Network Type POINT-TO-POINT, Cost: 64
Transmit Delay is 1 sec, State POINT-TO-POINT, Priority 0
No designated router on this network
No backup designated router on this network
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:02
Index 3/3, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1 , Adjacent neighbor count is 1
Adjacent with neighbor 1.1.1.1
Suppress hello for 0 neighbor(s)

show ip ospf neighbors
Neighbor ID Pri State Dead Time Address Interface
1.1.1.1 0 FULL/ - 00:00:36 10.1.1.1 Serial0/2


Router 1
show running-config
Current configuration : 1086 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
...
!
interface Loopback0
description R1
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0
ip address 192.168.1.17 255.255.255.240
clock rate 64000
!
interface Serial0/1
ip address 192.168.1.49 255.255.255.240
clock rate 64000
!
interface Serial0/2
ip address 10.1.1.1 255.255.255.0
clock rate 64000
!
interface Serial0/3
no ip address
clock rate 2000000
shutdown
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet1/1
no ip address
duplex auto
speed auto
shutdown
!
router ospf 1
log-adjacency-changes
network 192.168.1.16 0.0.0.15 area 0
network 192.168.1.48 0.0.0.15 area 0
network 10.1.1.0 0.0.0.15 area 0
!
ip classless
!
...
!
line con 0
line vty 0 4
login
!
!
!
end


show ip interface brief
Interface IP-Address OK? Method Status Protocol

FastEthernet0/0 unassigned YES unset administratively down down

FastEthernet0/1 unassigned YES unset administratively down down

Serial0/0 192.168.1.17 YES manual up up

Serial0/1 192.168.1.49 YES manual up up

Serial0/2 10.1.1.1 YES manual up up

Serial0/3 unassigned YES unset administratively down down

FastEthernet1/0 unassigned YES unset administratively down down

FastEthernet1/1 unassigned YES unset administratively down down

Loopback0 1.1.1.1 YES manual up up

show ip ospf interface
Serial0/2 is up, line protocol is up
Internet address is 10.1.1.1/24, Area 0
Process ID 1, Router ID 1.1.1.1, Network Type POINT-TO-POINT, Cost: 64
Transmit Delay is 1 sec, State POINT-TO-POINT, Priority 0
No designated router on this network
No backup designated router on this network
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:01
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1 , Adjacent neighbor count is 1
Adjacent with neighbor 5.5.5.5
Suppress hello for 0 neighbor(s)
Serial0/0 is up, line protocol is up
Internet address is 192.168.1.17/28, Area 0
Process ID 1, Router ID 1.1.1.1, Network Type POINT-TO-POINT, Cost: 64
Transmit Delay is 1 sec, State POINT-TO-POINT, Priority 0
No designated router on this network
No backup designated router on this network
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:06
Index 2/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1 , Adjacent neighbor count is 1
Adjacent with neighbor 2.2.2.2
Suppress hello for 0 neighbor(s)
Serial0/1 is up, line protocol is up
Internet address is 192.168.1.49/28, Area 0
Process ID 1, Router ID 1.1.1.1, Network Type POINT-TO-POINT, Cost: 64
Transmit Delay is 1 sec, State POINT-TO-POINT, Priority 0
No designated router on this network
No backup designated router on this network
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:06
Index 3/3, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1 , Adjacent neighbor count is 1
Adjacent with neighbor 3.3.3.3
Suppress hello for 0 neighbor(s)

show ip ospf neighbors
Neighbor ID Pri State Dead Time Address Interface
2.2.2.2 0 FULL/ - 00:00:36 192.168.1.18 Serial0/0
3.3.3.3 0 FULL/ - 00:00:36 192.168.1.50 Serial0/1
5.5.5.5 0 FULL/ - 00:00:35 10.1.1.2 Serial0/2

Comments

  • georgemcgeorgemc Member Posts: 429
    I cut and pasted your configs into PT 5.3 with Router1, Router 4, and the 2 hubs off of Router4 and it worked great. The routes were advertised from R4 to R1 and I could ping from R1 to both FastEthernet interfaces on R4 from R1.
    WGU BS: Business - Information Technology Management
    Start Date: 01 October 2012
    QFT1,PFIT in progress.
    TRANSFERRED/COMPLETED: AGC1,BBC1,LAE1,QBT1,LUT1,QLC1,QMC1,QLT1,IWC1,INC1,INT1,BVC1,CLC1,MGC1, CWV1 BNC1, LIT1,LWC1,QAT1,WFV1,EST1,EGC1,EGT1,IWT1,MKC1,MKT1,RWT1,FNT1,FNC1, BDC1,TPV1 REQUIRED:
  • whitehat_dreamswhitehat_dreams Registered Users Posts: 4 ■□□□□□□□□□
    Uhmm, sorry if I got this wrong but... this means it SHOULD be working right? T_T
    So can you help me figure out what is wrong with my setup? Would have attached pkt file here but it doesn't to be allowed.
  • Darthn3ssDarthn3ss Member Posts: 1,096
    I have no useful response at this time, but who uses hubs? :P
    Fantastic. The project manager is inspired.

    In Progress: 70-640, 70-685
  • whitehat_dreamswhitehat_dreams Registered Users Posts: 4 ■□□□□□□□□□
    Darthn3ss wrote: »
    I have no useful response at this time, but who uses hubs? :P
    Ehehe, was originally using switches (switches can still be seen in topology, just not connected) used hubs temporarily to see if I could isolate problem faster with them (since I'm not used to switches,will be tackling them next module).

    Anyway, I seem to have [strike]fixed[/strike] done something wrong with this configuration. Since I re-made it (using switches this time :P) and it worked. But I don't seem to have noticed me doing anything special.
    Trying to find a way to upload the pkt file with the problem so that someone can teach me what I did wrong.

    P.S. is posting a mediafire link here ok? I didn't notice anything of the sort when I scan thru forum read me.
  • vinbuckvinbuck Member Posts: 785 ■■■■□□□□□□
    OSPFv2 (IPv4) needs the following to match to form an adjacancy:

    Subnet
    MTU
    Area Type
    OSPF Interface Type
    Hello/Dead Timers

    I see one of those on the list that don't match from your output... icon_smile.gif
    Cisco was my first networking love, but my "other" router is a Mikrotik...
  • whitehat_dreamswhitehat_dreams Registered Users Posts: 4 ■□□□□□□□□□
    ... Uhhh, MTU? is that the wild card mask? (sorry don't remember that from lessons).
    Anyway... apparently I made an error somewhere with IP addresses, it worked when I tried to redo the whole network.
    Would appreciate if there is a way (and someone can teach me) how to figure out what I did wrong though.
    Since I can't seem to find where I made the mistake in this setup.

    with problem.pkt <- .pkt file with problem.

    P.S. If the posting of the link is not allowed please remove, since no one commented on it in prior post.
Sign In or Register to comment.