Need help connecting Switch to Router
chiggah
Member Posts: 13 ■□□□□□□□□□
in CCNA & CCENT
Trying to set up a home lab for basic command line practice. Below is my topology and I've emulated a cisco switch into GNS3 as per https://learningnetwork.cisco.com/docs/DOC-13824
Able to ping from R1 to R2
Unable to ping from S1 to R1
Configuration below:
R1 int s0/0
ip address 192.168.1.1 255.255.255.252
no shutdown
R2 int s0/0
ip address 192.168.1.1 255.255.255.252
no shutdown
R1 int f1/0
ip address 172.30.2.1 255.255.255.0
no shutdown
S1 int Vlan 1
ip address 172.30.2.180 255.255.255.0
ip default-gateway 172.30.2.1
no shutdown
Am i doing something wrong here ? Do I need to set up interface f0/0 on Switch 1 ? Does the S1 subnet need to be same as R1 ?
Do i need to do the following ?
int f0/0
switchport mode access
switchport access vlan 1
Able to ping from R1 to R2
Unable to ping from S1 to R1
Configuration below:
R1 int s0/0
ip address 192.168.1.1 255.255.255.252
no shutdown
R2 int s0/0
ip address 192.168.1.1 255.255.255.252
no shutdown
R1 int f1/0
ip address 172.30.2.1 255.255.255.0
no shutdown
S1 int Vlan 1
ip address 172.30.2.180 255.255.255.0
ip default-gateway 172.30.2.1
no shutdown
Am i doing something wrong here ? Do I need to set up interface f0/0 on Switch 1 ? Does the S1 subnet need to be same as R1 ?
Do i need to do the following ?
int f0/0
switchport mode access
switchport access vlan 1
Comments
-
r_durant Member Posts: 486 ■■■□□□□□□□Are both interfaces up/up?
What's the duplex/speed settings on both devices?CCNA (Expired...), MCSE, CWNA, BSc Computer Science
Working on renewing CCNA! -
kurosaki00 Member Posts: 973did you:
interface fastethernet 0/0
if- switchport access vlan 1 ?
also no shutdown on vlan 1 and fa0/0?meh -
chiggah Member Posts: 13 ■□□□□□□□□□kurosaki00 wrote: »did you:
interface fastethernet 0/0
if- switchport access vlan 1 ?
also no shutdown on vlan 1 and fa0/0?
Nah yeah i just figured that out about 20 minutes before your post
Need to assign S1 f0/0 to Vlan 1
Thanks though - will try when I get home