OSPF lab problem
jdballinger
Member Posts: 252
in CCNA & CCENT
So I'm watching the ICND2 CBT Nuggets, and trying to lab everything along with Jeremy. I just finished watching the OSPF configuration vid, and even though I followed along exactly, I can't for the life of me get it to work. I can form a neighbor relationship between R1 and R2, but when I do a 'show ip route' on R1, it isn't populated with any of the OSPF routes.
Here are the appropriate sections from the running configs for all 3 routers:
R1:
interface FastEthernet0/0
description LINK TO CBTSWITCH2
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface Serial0/0/0
ip address 68.110.171.98 255.255.255.224
!
interface Serial0/0/1
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
passive-interface Serial0/0/0
network 192.168.1.1 0.0.0.0 area 0
!
ip classless
R2:
interface FastEthernet0/0
ip address 192.168.1.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.10.1 255.255.255.0
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 192.168.20.1 255.255.255.0
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface Serial0/0/0
ip address 192.168.2.1 255.255.255.0
clock rate 2000000
!
interface Serial0/0/1
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
network 192.168.0.0 0.0.255.255 area 0
!
ip classless
R3:
interface Loopback0
ip address 172.16.0.1 255.255.255.0
!
interface Loopback1
ip address 172.16.1.1 255.255.255.0
!
interface Loopback2
ip address 172.16.2.1 255.255.255.0
!
interface Loopback3
ip address 172.16.3.1 255.255.255.0
!
interface Loopback4
ip address 172.16.4.1 255.255.255.0
!
interface Loopback5
ip address 172.16.5.1 255.255.255.0
!
interface Loopback6
ip address 172.16.6.1 255.255.255.0
!
interface Loopback7
ip address 172.16.7.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.3.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 192.168.2.2 255.255.255.0
!
interface Serial0/0/1
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
network 192.168.0.0 0.0.255.255 area 0
network 172.16.0.0 0.0.7.255 area 1
!
ip classless
Any help would be very much appreciated, as I've wiped them and redone it a few times now with the same results.
Thanks!
Here are the appropriate sections from the running configs for all 3 routers:
R1:
interface FastEthernet0/0
description LINK TO CBTSWITCH2
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface Serial0/0/0
ip address 68.110.171.98 255.255.255.224
!
interface Serial0/0/1
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
passive-interface Serial0/0/0
network 192.168.1.1 0.0.0.0 area 0
!
ip classless
R2:
interface FastEthernet0/0
ip address 192.168.1.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.10.1 255.255.255.0
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 192.168.20.1 255.255.255.0
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface Serial0/0/0
ip address 192.168.2.1 255.255.255.0
clock rate 2000000
!
interface Serial0/0/1
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
network 192.168.0.0 0.0.255.255 area 0
!
ip classless
R3:
interface Loopback0
ip address 172.16.0.1 255.255.255.0
!
interface Loopback1
ip address 172.16.1.1 255.255.255.0
!
interface Loopback2
ip address 172.16.2.1 255.255.255.0
!
interface Loopback3
ip address 172.16.3.1 255.255.255.0
!
interface Loopback4
ip address 172.16.4.1 255.255.255.0
!
interface Loopback5
ip address 172.16.5.1 255.255.255.0
!
interface Loopback6
ip address 172.16.6.1 255.255.255.0
!
interface Loopback7
ip address 172.16.7.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.3.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 192.168.2.2 255.255.255.0
!
interface Serial0/0/1
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
network 192.168.0.0 0.0.255.255 area 0
network 172.16.0.0 0.0.7.255 area 1
!
ip classless
Any help would be very much appreciated, as I've wiped them and redone it a few times now with the same results.
Thanks!
Comments
-
Nate--IRL-- Member Posts: 103 ■■□□□□□□□□"network 192.168.1.1 0.0.0.0 area 0" on R1 should be "network 192.168.1.1 0.0.0.255 area 0"
Nate -
jdballinger Member Posts: 252I had thought that at first too when I watched him do it in the video, but if all I'm advertising is that exact IP address it doesn't HAVE to be 0.0.0.255. Funny thing is that I just rebooted, and opened up the saved Packet Tracer file, and all of a sudden everything is working (with the configs I pasted above too.)
I don't understand why it didn't work before, but who cares, it works now!
Thanks anyways! -
Zartanasaurus Member Posts: 2,008 ■■■■■■■■■□
PT is known to have quirks like this. If something should work, a restart solves it a lot of times.Currently reading:
IPSec VPN Design 44%
Mastering VMWare vSphere 5 42.8%