DHCP Handout from Cisco 3524 XL EN?

kmcintosh78kmcintosh78 Posts: 195Member
Trying to come up with a solution to the following design.
I have a Cisco ASA 5505 and a Cisco 3524 XL EN. Need to have DHCP handed out from 2 VLAN pulls. One to run the PC, the other to run the VoIP Phones.
I have been doing this on 3560s with no issue, but I have hit a roadblock. I can't seem to build the config on the switch to run the DHCP.
Any chance anyone know how to go about this? Can I hand out DHCP from the ASA?

Thanks
What I am working on
CCNP Route (Currently) 80% done
CCNP Switch (Next Year)
CCNP TShoot (Next Year)

Comments

  • drkatdrkat Posts: 703Banned
    Yeah the ASA will do DHCP no problem - if you dont have the license to do 802.1q on the ASA interface then you can setup 2 access ports (voice/data) on your switch and connect them to two ports on the asa configured the same

    here's an example: PC/Phones behind Verizon FIOS/Road Runner


    interface Vlan1
    description Vlan for Voice
    nameif inside
    security-level 100
    ip address 192.168.1.1 255.255.255.0
    !
    interface Vlan2
    nameif outside
    security-level 0
    ip address dhcp setroute
    !
    interface Vlan12
    description Vlan for Data
    nameif Data
    security-level 50
    ip address 192.168.2.1 255.255.255.0

    global (outside) 1 interface
    nat (inside) 1 0.0.0.0 0.0.0.0
    nat (Data) 1 0.0.0.0 0.0.0.0
    dhcpd dns 4.2.2.2
    dhcpd lease 14460
    dhcpd ping_timeout 100
    dhcpd auto_config outside
    !
    dhcpd address 192.168.1.10-192.168.1.15 inside
    dhcpd dns 4.2.2.2 8.8.8.8 interface inside
    dhcpd enable inside
    !
    dhcpd address 192.168.2.20-192.168.2.50 Data
    dhcpd enable Data



    interface Ethernet0/0
    description Connection to Internet Provider
    switchport access vlan 2
    speed 100
    duplex full


    interface Ethernet0/1
    description Data Uplink
    switchport access vlan 12

    interface Ethernet0/2
    description Voice Uplink
    Married to the game but she broke her vows. That's why my bars are full of broken bottles And my night stands are full of open bibles
  • kmcintosh78kmcintosh78 Posts: 195Member
    With that though, I can't set up Site to Site VPN tunneling.
    What I am working on
    CCNP Route (Currently) 80% done
    CCNP Switch (Next Year)
    CCNP TShoot (Next Year)
Sign In or Register to comment.