line protocol for tunnel interface is down

m4rtinm4rtin Posts: 170Member
I have a following physical topology: C1841[Fa0/0] <-> [Fa1/0/1]ME-C3750-24TE. Both in C1841 and ME-C3750-24TE there is a tunnel configured:
C1841#sh run int Tu0
Building configuration...

Current configuration : 150 bytes
!
interface Tunnel0
 ip unnumbered FastEthernet0/1
 keepalive 5 3
 tunnel source FastEthernet0/0
 tunnel destination 10.10.10.1
 tunnel checksum
end

C1841#

ME-C3750-24TE#sh run int Tu0
Building configuration...

Current configuration : 134 bytes
!
interface Tunnel0
 ip unnumbered Vlan100
 keepalive 5 3
 tunnel source Vlan200
 tunnel destination 10.10.10.2
 tunnel checksum
end

ME-C3750-24TE#



The problem is, that while line protocol of Tu0 in ME-C3750-24TE is up, it is down in C1841:
ME-C3750-24TE#sh int Tu0      
Tunnel0 is up, line protocol is up 
  Hardware is Tunnel
  Interface is unnumbered. Using address of Vlan100 (192.168.2.2)
  MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation TUNNEL, loopback not set
  Keepalive set (5 sec), retries 3
  Tunnel source 10.10.10.1 (Vlan200), destination 10.10.10.2
  Tunnel protocol/transport GRE/IP, key disabled, sequencing disabled
  Tunnel TTL 255
  Checksumming of packets enabled
  Last input 00:00:02, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 10
  Queueing strategy: fifo
  Output queue: 0/0 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     1689 packets input, 94576 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     1730 packets output, 96880 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
ME-C3750-24TE#

C1841#sh int Tu0
Tunnel0 is up, line protocol is down 
  Hardware is Tunnel
  Interface is unnumbered. Using address of FastEthernet0/1 (192.168.1.2)
  MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation TUNNEL, loopback not set
  Keepalive set (5 sec), retries 3
  Tunnel source 10.10.10.2 (FastEthernet0/0), destination 10.10.10.1
  Tunnel protocol/transport GRE/IP
    Key disabled, sequencing disabled
    Checksumming of packets enabled
  Tunnel TTL 255
  Fast tunneling enabled
  Tunnel transmit bandwidth 8000 (kbps)
  Tunnel receive bandwidth 8000 (kbps)
  Last input 00:00:02, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 8
  Queueing strategy: fifo
  Output queue: 0/0 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     1691 packets input, 94696 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     1700 packets output, 95192 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
C1841#

Tunnel destinations are reachable:
C1841#sh ip int bri 
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            10.10.10.2      YES manual up                    up      
FastEthernet0/1            192.168.1.2     YES manual up                    up      
Tunnel0                    192.168.1.2     YES TFTP   up                    down    
C1841#ping 10.10.10.1 source 10.10.10.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.1, timeout is 2 seconds:
Packet sent with a source address of 10.10.10.2 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
C1841#

ME-C3750-24TE#sh ip int bri | i Vlan|Tu        
Vlan1                  unassigned      YES unset  administratively down down    
Vlan100                192.168.2.2     YES manual up                    up      
Vlan200                10.10.10.1      YES manual up                    up      
Tunnel0                192.168.2.2     YES unset  up                    up      
ME-C3750-24TE#ping 10.10.10.2 source 10.10.10.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.2, timeout is 2 seconds:
Packet sent with a source address of 10.10.10.1 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/8 ms
ME-C3750-24TE#

Any ideas why line protocol of Tu0 in C1841 router is down?


I have a following physical topology: C1841[Fa0/0] <-> [Fa1/0/1]ME-C3750-24TE. Both in C1841 and ME-C3750-24TE there is a tunnel configured:
C1841#sh run int Tu0
Building configuration...

Current configuration : 150 bytes
!
interface Tunnel0
 ip unnumbered FastEthernet0/1
 keepalive 5 3
 tunnel source FastEthernet0/0
 tunnel destination 10.10.10.1
 tunnel checksum
end

C1841#

ME-C3750-24TE#sh run int Tu0
Building configuration...

Current configuration : 134 bytes
!
interface Tunnel0
 ip unnumbered Vlan100
 keepalive 5 3
 tunnel source Vlan200
 tunnel destination 10.10.10.2
 tunnel checksum
end

ME-C3750-24TE#



The problem is, that while line protocol of Tu0 in ME-C3750-24TE is up, it is down in C1841:
ME-C3750-24TE#sh int Tu0      
Tunnel0 is up, line protocol is up 
  Hardware is Tunnel
  Interface is unnumbered. Using address of Vlan100 (192.168.2.2)
  MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation TUNNEL, loopback not set
  Keepalive set (5 sec), retries 3
  Tunnel source 10.10.10.1 (Vlan200), destination 10.10.10.2
  Tunnel protocol/transport GRE/IP, key disabled, sequencing disabled
  Tunnel TTL 255
  Checksumming of packets enabled
  Last input 00:00:02, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 10
  Queueing strategy: fifo
  Output queue: 0/0 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     1689 packets input, 94576 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     1730 packets output, 96880 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
ME-C3750-24TE#

C1841#sh int Tu0
Tunnel0 is up, line protocol is down 
  Hardware is Tunnel
  Interface is unnumbered. Using address of FastEthernet0/1 (192.168.1.2)
  MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation TUNNEL, loopback not set
  Keepalive set (5 sec), retries 3
  Tunnel source 10.10.10.2 (FastEthernet0/0), destination 10.10.10.1
  Tunnel protocol/transport GRE/IP
    Key disabled, sequencing disabled
    Checksumming of packets enabled
  Tunnel TTL 255
  Fast tunneling enabled
  Tunnel transmit bandwidth 8000 (kbps)
  Tunnel receive bandwidth 8000 (kbps)
  Last input 00:00:02, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 8
  Queueing strategy: fifo
  Output queue: 0/0 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     1691 packets input, 94696 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     1700 packets output, 95192 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
C1841#

Tunnel destinations are reachable:
C1841#sh ip int bri 
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            10.10.10.2      YES manual up                    up      
FastEthernet0/1            192.168.1.2     YES manual up                    up      
Tunnel0                    192.168.1.2     YES TFTP   up                    down    
C1841#ping 10.10.10.1 source 10.10.10.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.1, timeout is 2 seconds:
Packet sent with a source address of 10.10.10.2 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
C1841#

ME-C3750-24TE#sh ip int bri | i Vlan|Tu        
Vlan1                  unassigned      YES unset  administratively down down    
Vlan100                192.168.2.2     YES manual up                    up      
Vlan200                10.10.10.1      YES manual up                    up      
Tunnel0                192.168.2.2     YES unset  up                    up      
ME-C3750-24TE#ping 10.10.10.2 source 10.10.10.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.2, timeout is 2 seconds:
Packet sent with a source address of 10.10.10.1 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/8 ms
ME-C3750-24TE#

Any ideas why line protocol of Tu0 in C1841 router is down?


//I disabled keepalives under ME-C3750-24TE interface Tu0 configuration in order to avoid confusion and ran GRE debugging in C1841 and ME-C3750-24TE:

C1841#show debugging 

General-purpose tunnel:
  Tunnel Interface debugging is on
  Tunnel keepalive debugging is on

C1841#

ME-C3750-24TE#show debugging 
General-purpose tunnel:
  Tunnel Interface debugging is on
  Tunnel keepalive debugging is on
ME-C3750-24TE#

Keepalives under C1841 Tu0 are enabled. Results are following:

Cisco C1841:
C1841#
*Jul 27 11:21:58.574: Tunnel0: sending keepalive, 10.10.10.1->10.10.10.2 (len=28 ttl=255), counter=5
*Jul 27 11:21:58.574: Tunnel0: GRE/IP encapsulated 10.10.10.2->10.10.10.1 (linktype=7, len=56)
C1841#
*Jul 27 11:22:03.574: Tunnel0: sending keepalive, 10.10.10.1->10.10.10.2 (len=28 ttl=255), counter=6
*Jul 27 11:22:03.574: Tunnel0: GRE/IP encapsulated 10.10.10.2->10.10.10.1 (linktype=7, len=56)
C1841#
*Jul 27 11:22:08.574: Tunnel0: sending keepalive, 10.10.10.1->10.10.10.2 (len=28 ttl=255), counter=7
*Jul 27 11:22:08.574: Tunnel0: GRE/IP encapsulated 10.10.10.2->10.10.10.1 (linktype=7, len=56)
C1841#
*Jul 27 11:22:13.574: Tunnel0: sending keepalive, 10.10.10.1->10.10.10.2 (len=28 ttl=255), counter=8
*Jul 27 11:22:13.574: Tunnel0: GRE/IP encapsulated 10.10.10.2->10.10.10.1 (linktype=7, len=56)
C1841#

Cisco ME-C3750-24TE:
ME-C3750-24TE#
04:17:41: Tunnel0: GRE/IP (PS) to decaps 10.10.10.2->10.10.10.1 (tbl=0,"default" len=56 ttl=255)
04:17:41: Tunnel0: GRE decapsulated IP packet (linktype=7, len=2[IMG]https://us.v-cdn.net/6030959/uploads/images/smilies/icon_cool.gif[/IMG]
ME-C3750-24TE#
04:17:46: Tunnel0: GRE/IP (PS) to decaps 10.10.10.2->10.10.10.1 (tbl=0,"default" len=56 ttl=255)
04:17:46: Tunnel0: GRE decapsulated IP packet (linktype=7, len=2[IMG]https://us.v-cdn.net/6030959/uploads/images/smilies/icon_cool.gif[/IMG]
ME-C3750-24TE#
04:17:51: Tunnel0: GRE/IP (PS) to decaps 10.10.10.2->10.10.10.1 (tbl=0,"default" len=56 ttl=255)
04:17:51: Tunnel0: GRE decapsulated IP packet (linktype=7, len=2[IMG]https://us.v-cdn.net/6030959/uploads/images/smilies/icon_cool.gif[/IMG]
ME-C3750-24TE#
04:17:56: Tunnel0: GRE/IP (PS) to decaps 10.10.10.2->10.10.10.1 (tbl=0,"default" len=56 ttl=255)
04:17:56: Tunnel0: GRE decapsulated IP packet (linktype=7, len=2[IMG]https://us.v-cdn.net/6030959/uploads/images/smilies/icon_cool.gif[/IMG]
ME-C3750-24TE#

Looks like the ME-C3750-24TE does not reply to GRE keepalives?

Comments

  • Mrock4Mrock4 Posts: 2,360Banned
    Can you post the physical port (f1/0/1 I believe) config on your ME-3750?
  • m4rtinm4rtin Posts: 170Member
    Mrock4 wrote: »
    Can you post the physical port (f1/0/1 I believe) config on your ME-3750?

    ME-3750 configuration is here:
    ME-C3750-24TE#sh run int Fa1/0/1
    Building configuration...
    
    Current configuration : 111 bytes
    !
    interface FastEthernet1/0/1
     switchport access vlan 200
     switchport mode access
     spanning-tree portfast
    end
    
    ME-C3750-24TE#sh int Fa1/0/1    
    FastEthernet1/0/1 is up, line protocol is up (connected) 
      Hardware is Fast Ethernet, address is 0011.21a3.0103 (bia 0011.21a3.0103)
      MTU 1998 bytes, BW 100000 Kbit, DLY 100 usec, 
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ARPA, loopback not set
      Keepalive set (10 sec)
      Full-duplex, 100Mb/s, media type is 10/100BaseTX
      input flow-control is off, output flow-control is unsupported 
      ARP type: ARPA, ARP Timeout 04:00:00
      Last input 00:00:53, output 00:00:00, output hang never
      Last clearing of "show interface" counters never
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue: 0/40 (size/max)
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         82222 packets input, 6555044 bytes, 0 no buffer
         Received 21 broadcasts (4631 multicasts)
         0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
         0 watchdog, 4631 multicast, 0 pause input
         0 input packets with dribble condition detected
         213815 packets output, 17571220 bytes, 0 underruns
         0 output errors, 0 collisions, 1 interface resets
         0 babbles, 0 late collision, 0 deferred
         0 lost carrier, 0 no carrier, 0 PAUSE output
         0 output buffer failures, 0 output buffers swapped out
    ME-C3750-24TE#
    
Sign In or Register to comment.