Getting Owned! Cisco 1841

showboshowbo Posts: 73Member ■■□□□□□□□□
Ok guys, all was well with my test/practice router. It is a cisco 1841, I setup Fa 0/0 with 192.168.1.0/27 and after i turned on SSH and Telnet and used 192.168.1.2 on my Laptop to Telnet to 192.168.1.1 on fa 0/0.

Well I come back today to practice some more, hook up my laptop to Fa 0/0 nothing? Hook back up my console cable and this is what I see:


R1 con0 is now available


Press RETURN to get started.


&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&
This is a test Lab and has no use in RL.....
Please log out A.S.A.P or be punshied by death
&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&
&&&&&&&&&&&&&&&&&&&
O'Hi Thar!
&&&&&&&&&&&&&&&&&&&

User Access Verification
Password:
R1>en
Password:
R1#sho run
Building configuration...
Current configuration : 1420 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$y2EX$sFcDWSuPJM4gLYfuZl8EG1
!
no aaa new-model
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
no ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
no ip ips deny-action ips-interface
no ip domain lookup
ip domain name home.com
!
!
!
!
username cisco privilege 15 secret 5 $1$tZc6$tp0MmPYyrbrYiSFxTied8/
!
!
!
!
!
interface FastEthernet0/0
description This is a test Lab 192.168.1.0/27
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
ip address 192.168.1.33 255.255.255.224
!
ip classless
!
no ip http server
no ip http secure-server
!
!
!
control-plane
!
banner login ^C
&&&&&&&&&&&&&&&&&&&
O'Hi Thar!
&&&&&&&&&&&&&&&&&&&
^C
banner motd ^C
&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&
This is a test Lab and has no use in RL.....
Please log out A.S.A.P or be punshied by death
&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&
^C
!
line con 0
exec-timeout 0 0
password 7 0822455D0A16
logging synchronous
login
line aux 0
password 7 1511021F0725
login
line vty 0 4
exec-timeout 0 0
password 7 094F471A1A0A
logging synchronous
login local
transport input telnet ssh
!
end
R1#

Well when I run sh interface I see this on my Fa 0/0 and 0/1:
FastEthernet0/0 is up, line protocol is down
Internet protocol processing disabled
FastEthernet0/1 is administratively down, line protocol is down
Internet protocol processing disabled

Ok. No clue what I borked? All was well the other day and now it says Internet protocol processing disabled? The only thing left is my description with whicn I put the IP subnet of what it was 192.168.1.0/27!????

After I was done the other day I did a copy run start and then just turned off the router and put it up. Today I get this and can't assign an address because it always says its a bad subnet? Any help please! Thanks in advance! icon_redface.gif

Comments

  • NetworkVeteranNetworkVeteran Posts: 2,338Member
    showbo wrote: »
    Today I get this and can't assign an address because it always says its a bad subnet? Any help please! Thanks in advance! icon_redface.gif
    showbo, think like an engineer. That's what you're aiming for. Don't you think it *might* help if you provided the actual command you attempted and the exact error message you received?
    I setup Fa 0/0 with 192.168.1.0/27
    That can't be precisely what you configured on Fa0/0. It would reject 192.168.1.0/27.

    192.168.1.0/27
    11000000.10110000.00000001.00000000
    nnnnnnnn.nnnnnnnn.nnnnnnnn.ssshhhhh

    IOS wouldn't accept this all-zero host address.

    What did you configure?

    I'd love to help if only you'd provide some specifics to go on.
  • showboshowbo Posts: 73Member ■■□□□□□□□□
    showbo, think like an engineer. That's what you're aiming for. Don't you think it *might* help if you provided the actual command you attempted and the exact error message you received?

    My issue is this which I did post at the bottom of my post:

    Well when I run sh interface I see this on my Fa 0/0 and 0/1:
    FastEthernet0/0 is up, line protocol is down
    Internet protocol processing disabled
    FastEthernet0/1 is administratively down, line protocol is down
    Internet protocol processing disabled

    Why does it say that now? That's what I can't figure out.

    R1#config t
    Enter configuration commands, one per line. End with CNTL/Z.
    R1(config)#int fa 0/0
    R1(config-if)#ip address 192.168.1.0 255.255.255.224
    Bad mask /27 for address 192.168.1.0
    R1(config-if)#ip address 192.168.1.1 255.255.255.224
    Bad mask /27 for address 192.168.1.1

    Tried both 1.0 and 1.1, again no clue what I borked all I did was power off the router and turn it back on.
  • showboshowbo Posts: 73Member ■■□□□□□□□□
    showbo, think like an engineer. That's what you're aiming for. Don't you think it *might* help if you provided the actual command you attempted and the exact error message you received?


    That can't be precisely what you configured on Fa0/0. It would reject 192.168.1.0/27.

    192.168.1.0/27
    11000000.10110000.00000001.00000000
    nnnnnnnn.nnnnnnnn.nnnnnnnn.ssshhhhh

    IOS wouldn't accept this all-zero host address.

    What did you configure?

    I'd love to help if only you'd provide some specifics to go on.


    Ok, I do remember I setup Fa with 192.168.1.1 so, when it was working the other day I entered it like so:

    config t
    int fa 0/0
    ip address 192.168.1.1 255.255.255.224


    I figured it out :) for some reason before I shutdown the router the other day I ran 'no ip subnet-zero'

    After going into config t and enableing 'ip subnet-zero' I was able to assign my Fa 0/0 the 192.168.1.1/27 address and assign my Se 0/0/0 its 192.168.1.33/27 address!

    Thanks NetworkVertern. The comment where you said to think like an engineer made me look at my config a thrid and fourth time over!
  • mella060mella060 Posts: 196Member
    Yeh that makes sense. You wouldn't be able to use the 1st or zero subnet with no ip subnet-zero configured.

    So you wouldn't be able to use subnet 192.168.1.0 /27 but you could use 192.168.1.32 /27
  • drkatdrkat Posts: 703Banned
    it'd never be able to use .0 as a valid host address regardless of ip subnet zero enabled
    Married to the game but she broke her vows. That's why my bars are full of broken bottles And my night stands are full of open bibles
Sign In or Register to comment.