Options

6509-E Sup2T

MonkerzMonkerz Member Posts: 842
Anyone have experience with the Sup2T 12.2SY/15.1 and QoS? I'd like to pick your brain a bit if possible.

Trying to plan for QoS, but seems the syntax has changed a bit.

Comments

  • Options
    MonkerzMonkerz Member Posts: 842
    So I was able to create a queuing policy after reading everything I could find on the Sup2t, but unfortunately my hardware doesn't support class maps matching DSCP on Gig interfaces.

    Can someone enlighten me as to the best practices when using CoS vs DSCP? I'm thinking I may just need to classifiy via CoS everywhere and DSCP only across Serial links.

    Forgive my ignorance...
  • Options
    MonkerzMonkerz Member Posts: 842
    Well, I haven't received any feedback so I can only assume that the Sup2T is just too new. See the lack of documentation on Cisco's site, I kind of expected that.

    Anyway, I was able to get a working config between the 6509 and some 3750s. Saturated the links and trickled some VoIP and Video traffic across it without a single "interesting traffic" drop. I have attached the topology of my lab and the configs of the switches I was able to get working (after many many head scratching moments). I still have to lab up the other portions of my topology, but its a start.

    Oh, and does anyone know if there is a command equivalent to "show mls qos interface <interface> stat" for the Sup2T? The closest I could find was "show queueing interface <interface> details" but it just doesn't give was the other command does. I want to be able to see CoS/DSCP ingressing and egressing the ports...




    TEST_6509
    !
    hostname TEST_6509
    !
    table-map cos-discard-class-map
     map from  0 to 0
     map from  1 to 8
     map from  2 to 16
     map from  3 to 24
     map from  4 to 34
     map from  5 to 46
     map from  6 to 48
     map from  7 to 56
    !
    class-map type lan-queuing match-any Guaranteed_Traffic
      match cos  1  2  3  6  7
    class-map type lan-queuing match-any Realtime_Traffic
      match cos  4  5
    !
    policy-map type lan-queuing Egress_Queuing
      class Guaranteed_Traffic
        bandwidth remaining percent 50
        queue-limit multiple-type-based
        queue-limit cos values  1 percent 70
        queue-limit cos values  2 percent 80
        queue-limit cos values  3 percent 90
        queue-limit cos values  6 7 percent 100
      class Realtime_Traffic
        priority
        queue-limit multiple-type-based
        queue-limit cos values  4 5 percent 100
      class class-default
        queue-limit multiple-type-based
        queue-limit cos values  0 percent 100
    policy-map type lan-queuing Ingress_Queuing
      class Realtime_Traffic
        bandwidth percent 20
        queue-limit multiple-type-based
        queue-limit cos values  4 5 percent 100
      class class-default
        queue-limit multiple-type-based
        queue-limit cos values  0 1 2 percent 80
        queue-limit cos values  3 percent 90
        queue-limit cos values  6 7 percent 100
    !
     platform qos queueing-only
    !
    !
    interface GigabitEthernet1/48
     description FAUX_MetroE_TO_SITE1-3750
     ip address 10.199.254.1 255.255.255.252
     speed 100
     duplex full
     platform qos trust cos
     service-policy type lan-queuing input Ingress_Queuing
     service-policy type lan-queuing output Egress_Queuing
    !
    interface GigabitEthernet2/23
     description UPLINK_TO_IDF-Stack
     ip address 10.199.252.1 255.255.255.252
     platform qos trust cos
     service-policy type lan-queuing input Ingress_Queuing
     service-policy type lan-queuing output Egress_Queuing
    !
    interface GigabitEthernet2/48
     description UPLINK_TO_T1-EDGE-RTR
     ip address 10.199.254.5 255.255.255.252
     service-policy type lan-queuing input Ingress_Queuing
     service-policy type lan-queuing output Egress_Queuing
    !
    

    TEST-IDF_Stack
    !
    hostname TEST-IDF_Stack
    !
    !
    mls qos map cos-dscp 0 8 16 24 34 46 48 56
    mls qos srr-queue input bandwidth 90 10
    mls qos srr-queue input threshold 1 80 90
    mls qos srr-queue input priority-queue 2 bandwidth 20
    mls qos srr-queue input cos-map queue 1 threshold 2 3
    mls qos srr-queue input cos-map queue 1 threshold 3 6 7
    mls qos srr-queue input cos-map queue 2 threshold 1 4
    mls qos srr-queue input dscp-map queue 1 threshold 2 24 26
    mls qos srr-queue input dscp-map queue 1 threshold 3 48 56
    mls qos srr-queue input dscp-map queue 2 threshold 1 34
    mls qos srr-queue output cos-map queue 1 threshold 3 4 5
    mls qos srr-queue output cos-map queue 2 threshold 1 2
    mls qos srr-queue output cos-map queue 2 threshold 2 3
    mls qos srr-queue output cos-map queue 2 threshold 3 6 7
    mls qos srr-queue output cos-map queue 3 threshold 3 0
    mls qos srr-queue output cos-map queue 4 threshold 1 1
    mls qos srr-queue output dscp-map queue 1 threshold 3 34 46
    mls qos srr-queue output dscp-map queue 2 threshold 1 16 18 32
    mls qos srr-queue output dscp-map queue 2 threshold 2 24 26
    mls qos srr-queue output dscp-map queue 2 threshold 3 48 56
    mls qos srr-queue output dscp-map queue 3 threshold 3 0
    mls qos srr-queue output dscp-map queue 4 threshold 1 8 10
    mls qos queue-set output 1 threshold 1 100 100 75 400
    mls qos queue-set output 1 threshold 2 80 90 75 100
    mls qos queue-set output 1 threshold 3 100 100 50 100
    mls qos queue-set output 1 threshold 4 100 100 100 100
    mls qos
    !
    !
    interface GigabitEthernet1/0/1
     description UPLINK_TO_6509
     no switchport
     ip address 10.199.252.2 255.255.255.252
     srr-queue bandwidth share 1 30 35 5
     priority-queue out
     mls qos trust dscp
    !
    interface GigabitEthernet1/0/2
     description TO_END-USER
     switchport access vlan 2
     switchport mode access
     srr-queue bandwidth share 1 30 35 5
     priority-queue out
     mls qos trust dscp
     spanning-tree portfast
    

    TEST_Site1_3750
    !
    hostname TEST_Site1_3750
    !
    mls qos map cos-dscp 0 8 16 24 34 46 48 56
    mls qos srr-queue input bandwidth 90 10
    mls qos srr-queue input threshold 1 80 90
    mls qos srr-queue input priority-queue 2 bandwidth 20
    mls qos srr-queue input cos-map queue 1 threshold 2 3
    mls qos srr-queue input cos-map queue 1 threshold 3 6 7
    mls qos srr-queue input cos-map queue 2 threshold 1 4
    mls qos srr-queue input dscp-map queue 1 threshold 2 24 26
    mls qos srr-queue input dscp-map queue 1 threshold 3 48 56
    mls qos srr-queue input dscp-map queue 2 threshold 1 34
    mls qos srr-queue output cos-map queue 1 threshold 3 4 5
    mls qos srr-queue output cos-map queue 2 threshold 1 2
    mls qos srr-queue output cos-map queue 2 threshold 2 3
    mls qos srr-queue output cos-map queue 2 threshold 3 6 7
    mls qos srr-queue output cos-map queue 3 threshold 3 0
    mls qos srr-queue output cos-map queue 4 threshold 1 1
    mls qos srr-queue output dscp-map queue 1 threshold 3 34 46
    mls qos srr-queue output dscp-map queue 2 threshold 1 16 18 32
    mls qos srr-queue output dscp-map queue 2 threshold 2 24 26
    mls qos srr-queue output dscp-map queue 2 threshold 3 48 56
    mls qos srr-queue output dscp-map queue 3 threshold 3 0
    mls qos srr-queue output dscp-map queue 4 threshold 1 8 10
    mls qos queue-set output 1 threshold 1 100 100 75 400
    mls qos queue-set output 1 threshold 2 80 90 75 100
    mls qos queue-set output 1 threshold 3 100 100 50 100
    mls qos queue-set output 1 threshold 4 100 100 100 100
    mls qos
    !
    interface GigabitEthernet1/0/1
     description FAUX_MetroE_to_6509
     no switchport
     ip address 10.199.254.2 255.255.255.252
     speed 100
     duplex full
     srr-queue bandwidth share 1 30 35 5
     priority-queue out
     mls qos trust dscp
    !
    interface GigabitEthernet1/0/2
     description TO_END-USER
     switchport access vlan 2
     switchport mode access
     srr-queue bandwidth share 1 30 35 5
     priority-queue out
     mls qos trust dscp
     spanning-tree portfast
    
  • Options
    cisco_troopercisco_trooper Member Posts: 1,441 ■■■■□□□□□□
    Kind of curious. What did you pay for the SUP-2T? It is a sweet piece of hardware but I can't imagine too many private companies would have a need for that class of hardware. Are you using 10G switch modules at all? Anything else? 40G? I just outfitted a pair of 6509-E with dual Sup-720-3bxl and it should be more than I need for quite a while.
  • Options
    MonkerzMonkerz Member Posts: 842
    Price, couldn't disclose that information without getting myself in trouble. 10G, yes and lots of it. 40/100G, not yet but probably soon.

    Setting ourselves up for the future...
  • Options
    DPGDPG Member Posts: 780 ■■■■■□□□□□
    Monkerz wrote: »
    Price, couldn't disclose that information without getting myself in trouble. 10G, yes and lots of it. 40/100G, not yet but probably soon.

    Setting ourselves up for the future...

    It sucks that Cisco didn't make them capable of holding more routes than the 720-3BXL. The IPv4 routing table size is going to be huge soon.
Sign In or Register to comment.