ip-helper address for multiple vlans

phoeneousphoeneous Member Posts: 2,333 ■■■■■■■□□□
So I've got two 2901's connected. R1 is main router and acting dhcp/dns server. R2 is a temporary placement due to lack of switchports. Bother routers have 8 Port GE POE EHWIC Switch module installed (EHWIC-D-8ESG-P).
Short config:
R1
int g0/0.1 - 10.5.10.1/24
encapsulation dot1q 10 native)
int vlan10 - 10.0.200.1/24
int vlan20 - 10.0.202.1/24
ip dhcp pool ***LAN***
network 10.0.200.0 255.255.255.0
default-router 10.0.200.1
domain-name company.com
dns-server 10.0.200.1
ip dhcp pool ***VOICE***
network 10.0.202.0 255.255.255.0
domain-name company.com
default-router 10.0.202.1
R2
int g0/0.1 - 10.5.10.2/24
encapsulation dot1q 10 native
int vlan10 - 10.0.204.2/24
ip helper-address 10.0.200.1
int vlan20 - 10.0.206.2/24
ip helper-address 10.0.202.1
Each routers switchports are configured like this:
interface GigabitEthernet0/3/0
switchport access vlan 10
switchport voice vlan 20
no ip address
!
interface GigabitEthernet0/3/1
switchport access vlan 10
switchport voice vlan 20
no ip address
!
interface GigabitEthernet0/3/2
switchport access vlan 10
switchport voice vlan 20
no ip address
!
interface GigabitEthernet0/3/3
switchport access vlan 10
switchport voice vlan 20
no ip address
!
interface GigabitEthernet0/3/4
switchport access vlan 10
switchport voice vlan 20
no ip address
!
interface GigabitEthernet0/3/5
switchport access vlan 10
switchport voice vlan 20
no ip address
!
interface GigabitEthernet0/3/6
switchport access vlan 10
switchport voice vlan 20
no ip address
!
interface GigabitEthernet0/3/7
switchport access vlan 10
switchport voice vlan 20
no ip address

When I plug a device into R2's g0/3/X, it is not obtaining an IP.
Both routers can ping all of each others ip's.
Thoughts?

Comments

  • drkatdrkat Banned Posts: 703
    I'd start off with debugging dhcp and trying to statically assign a pc in that vlan and see if you can ping the dhcp helper address

    a complete show run may be helpful too

    you dont specify how the two connect together?
  • ZartanasaurusZartanasaurus Member Posts: 2,008 ■■■■■■■■■□
    Nevermind.
    Currently reading:
    IPSec VPN Design 44%
    Mastering VMWare vSphere 5​ 42.8%
  • georgemcgeorgemc Member Posts: 429
    Try not trunking (don't us subinterfaces) between the two routers. To me, this along with using vlan 10(which encompasses a different subnet on each router) as the native vlan adds unnecessary complexity to you network.

    I think I'm going to lab this up and break out wireshark to see what is happening to the DHCP discoveries....
    WGU BS: Business - Information Technology Management
    Start Date: 01 October 2012
    QFT1,PFIT in progress.
    TRANSFERRED/COMPLETED: AGC1,BBC1,LAE1,QBT1,LUT1,QLC1,QMC1,QLT1,IWC1,INC1,INT1,BVC1,CLC1,MGC1, CWV1 BNC1, LIT1,LWC1,QAT1,WFV1,EST1,EGC1,EGT1,IWT1,MKC1,MKT1,RWT1,FNT1,FNC1, BDC1,TPV1 REQUIRED:
  • BroadcastStormBroadcastStorm Member Posts: 496
    I thought R.O.S. is used on a Router that is connected to a L2 Switch if I'm not mistaken this is the scenario R.O.S. is best implemented, are these 2 devices both routers? as it says R1 and R2.

    R1 (L3 routed i/f)
    R2 (L3 routed i/f)

    I'm not sure about this design/configuration I got confused, I'm not saying it won't work.

    Typically on routed i/f the link is configured as a P2P L3 running a routing protocol, from there you create VLAN SVI that includes IP helper-address that you inject into your routing protocol/static routing.

    Now if R2 is a router and have a L2 switch NM module which I've done on a 2821 router, then the IP DHCP pool should be run there instead, and R1 should know how to reach the prefixes in R2.
  • phoeneousphoeneous Member Posts: 2,333 ■■■■■■■□□□
    The trunking works fine. Actually, isnt the trunking necessary because of the switchport modules installed?

    The problem was right in front of me I feel like a r'tard. I forgot to create dhcp pools for 10.0.204.0 and 10.0.206.0.
  • BroadcastStormBroadcastStorm Member Posts: 496
    phoeneous wrote: »
    The trunking works fine. Actually, isnt the trunking necessary because of the switchport modules installed?

    The problem was right in front of me I feel like a r'tard. I forgot to create dhcp pools for 10.0.204.0 and 10.0.206.0.

    Trunking is done on L2 interfaces in your case if you're connecting to a routed interface then it should be L3 routing, now if you connect R1 to a NM module L2 port then you can do R.O.S.

    Ideally since the R2 is acting as a L3/L2 routing/switching, then you can directly create your VLAN SVI in R2, no need for R1 to have some of this IP DHCP Pool or VLAN SVI to make things simple traffic doesn't need to leave the router when it's a L3/L2 (NM Module,) but in a case where R1 has to be able to reach some of this prefixes/segment in R2, then you create a P2P /30 transit link between R1 and R2 running either a static routing or a routing protocol for reachability.

    But again this is for best possible implementation in this case, but if you're just doing a lab then you're free to move things around just be careful cause you don't want to confuse yourself.
Sign In or Register to comment.