Emergency Help: Packet Tracer
Bullitt
Registered Users Posts: 5 ■□□□□□□□□□
in CCNA & CCENT
I've been off the equipment for awhile working on the SATCOM side of things for the last 3 years, but I'm trying to put together a simple LAN network in packet tracer, and for the life of me I cannot add an IP address to a switch. The routers work fine, but when I try and add an IP address to a switch its not even an option...
I know there has to be an easy explanation, and I've probably gone into full idiot, but I can't figure it out.
This is what I'm getting
Switch(config)#int fa 0/1
Switch(config-if)#ip add 192.168.0.1 255.255.255.224
^
% Invalid input detected at '^' marker.
Switch(config-if)#?
cdp Global CDP configuration subcommands
channel-group Etherchannel/port bundling configuration
channel-protocol Select the channel protocol (LACP, PAgP)
description Interface specific description
duplex Configure duplex operation.
exit Exit from interface configuration mode
mac-address Manually set interface MAC address
mls mls interface commands
no Negate a command or set its defaults
shutdown Shutdown the selected interface
spanning-tree Spanning Tree Subsystem
speed Configure speed operation.
storm-control storm configuration
switchport Set switching mode characteristics
tx-ring-limit Configure PA level transmit ring limit
Switch(config-if)#
and this is my show run:
show run
Building configuration...
Current configuration : 968 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
no ip address
shutdown
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end
I know there has to be an easy explanation, and I've probably gone into full idiot, but I can't figure it out.
This is what I'm getting
Switch(config)#int fa 0/1
Switch(config-if)#ip add 192.168.0.1 255.255.255.224
^
% Invalid input detected at '^' marker.
Switch(config-if)#?
cdp Global CDP configuration subcommands
channel-group Etherchannel/port bundling configuration
channel-protocol Select the channel protocol (LACP, PAgP)
description Interface specific description
duplex Configure duplex operation.
exit Exit from interface configuration mode
mac-address Manually set interface MAC address
mls mls interface commands
no Negate a command or set its defaults
shutdown Shutdown the selected interface
spanning-tree Spanning Tree Subsystem
speed Configure speed operation.
storm-control storm configuration
switchport Set switching mode characteristics
tx-ring-limit Configure PA level transmit ring limit
Switch(config-if)#
and this is my show run:
show run
Building configuration...
Current configuration : 968 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
no ip address
shutdown
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end
Comments
-
mapletune Member Posts: 316try
int vlan 1
ip address x.x.x.x m.m.m.m
no shutdown
=]Studying: vmware, CompTIA Linux+, Storage+ or EMCISA
Future: CCNP, CCIE -
4_lom Member Posts: 485You cannot add an IP to a switch interface unless it is a layer 3 switch. I don't believe PT has layer 3 switches. And if you were using layer 3 switches, you would not necessarily need routers. If you would like to add an IP to a switch for management purposes (telnet, ssh, snmp, etc), just add it to the vlan. So rather than typing in "interface fa0/1" or something similar, type in "interface vlan 1" and then add the IP address ( ip address 192.168.1.2 blah blah blah). Hope this helps. Let me know if you have more questions.Goals for 2018: MCSA: Cloud Platform, AWS Solutions Architect, MCSA : Server 2016, MCSE: Messaging
-
Bullitt Registered Users Posts: 5 ■□□□□□□□□□Got the Switch and the computers talking, but it still won't let me program the fa ports between the routers... (2950 switches)
J6A(config)#int fa 0/1
J6A(config-if)#?
cdp Global CDP configuration subcommands
channel-group Etherchannel/port bundling configuration
channel-protocol Select the channel protocol (LACP, PAgP)
description Interface specific description
duplex Configure duplex operation.
exit Exit from interface configuration mode
mac-address Manually set interface MAC address
mls mls interface commands
no Negate a command or set its defaults
shutdown Shutdown the selected interface
spanning-tree Spanning Tree Subsystem
speed Configure speed operation.
storm-control storm configuration
switchport Set switching mode characteristics
tx-ring-limit Configure PA level transmit ring limit
J6A(config-if)#
Show Run
J6A#show run
Building configuration...
Current configuration : 983 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname J6A
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
ip address 192.168.0.3 255.255.255.224
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end -
Ltat42a Member Posts: 587 ■■■□□□□□□□There is a layer 3 switch in Packet Tracer (3560-24). If you're wanting to connect switch to switch, remember to use a crossover cable. If you're wanting to connect router to router via the Fa0/0 ports, use a crossover cable. IP addresses do not get assigned to ports on a switch. You must assign an IP to the Fa0/0 ports on the routers in order for them to communicate.
Are you able to post your packet tracer file? If need be...put it in a ZIP file.
hth -
atorven Member Posts: 319As already mentioned you can't IP assign addresses to physical ports on layer 2 switches.
What are you trying to do exactly? -
Bullitt Registered Users Posts: 5 ■□□□□□□□□□Nevermind, I found the layer 3 3560. Lemme see how this goes.
-
Bullitt Registered Users Posts: 5 ■□□□□□□□□□Nevermind, I found the layer 3 3560. Lemme see how this goes.
Still not able to assign ports on the 3560. I swear, last time I touched one in person I didn't have this much of a problem. -
Bullitt Registered Users Posts: 5 ■□□□□□□□□□Are you able to post your packet tracer file? If need be...put it in a ZIP file.
-
atorven Member Posts: 319On the 3560 go to the port you want to assign an ip address and type no switchport this will change it to a layer 3 port.
-
Eildor Member Posts: 444On the 3560 go to the port you want to assign an ip address and type no switchport this will change it to a layer 3 port.
^ This ^ -
Ltat42a Member Posts: 587 ■■■□□□□□□□Here's an example in Packet Tracer
Crossover cable from router to switch
Switch>
Switch>enable
Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#interface FastEthernet0/1
Switch(config-if)#no switchport
Switch(config-if)#ip address 192.168.1.2 255.255.255.0
Switch(config-if)#end
Switch#
Switch#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
Switch#show run
!
hostname Switch
!
!
interface FastEthernet0/1
no switchport
ip address 192.168.1.2 255.255.255.0
duplex auto
speed auto
! -
spiderjericho Registered Users, Member Posts: 896 ■■■■■□□□□□There are a few bits of erroneous information in this thread.
With MDIX Auto-sensing ports, you don't need crossover cables. The port will do all of the automatic to switch the send and receive pairs.
Layer 3 switches can have IPs assigned to logical and physical interfaces. The first thing you want to do is enable ip routing on the switch then configure the interfaces (or interfaces if you want to use Etherchannel).
The one thing I hate about the old packet tracer is you can't configure default gateways on the 3560s. Not sure if they're going to correct it in the new version. -
lantech Member Posts: 329Not all switches and routers have MDIX auto sensing ports. So the type of cabling being used could be important. You'd be surprised at what you might find still in use out there.
I didn't see anyone say a layer 3 switch couldn't have an IP assigned to an interface. When the OP was starting out he was using a 2950. Which we all should know isn't a layer switch. Then he found the 3560 layer 3 switch and started using that.2012 Certification Goals
CCENT: 04/16/2012
CCNA: TBD