pc connected to cisco phone not grabbing dhcp in diff scope

I'm a bit confused. I have my laptop connected to a cisco ip phone 7945g. To my understanding if I use a helper address under the voice subinterface on the router it should assign the dhcp DATA scope to the pc. I did a ipconfig on my laptop and I keep getting the ip address from the VOICE scope not the DATA scope.


I have 2 dhcp pools named VOICE and DATA running on a 1760 setup as a dhcp server. CME is running on a 2811. I setup router on a stick on the 2811 for vlans 10 VOICE and vlan 50 DATA. The phone is assigned to vlan 10 on the switch. I know since its in VOICE vlan 10 thats why the pc is getting the dhcp scope from that vlan but wouldn't the helper address point it to the right direction. What am I missing? I thought the reason of creating 2 separate vlans was to remove the pcs from seeing any voice traffic.

This is the config on the 2811:

interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 10.10.10.1 255.255.255.0
ip helper-address 192.168.2.3
!
interface FastEthernet0/0.50
encapsulation dot1Q 50
ip address 192.168.2.1 255.255.255.0


This is the output for the dhcp server which is the 1760.

Router#sh ip int bri
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 192.168.2.3 YES manual up up
Router#



Router#sh run | s dhcp
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.2.1 192.168.2.10
ip dhcp excluded-address 10.10.10.1 10.10.10.10
ip dhcp pool DATA
network 192.168.2.0 255.255.255.0
default-router 192.168.2.1
dns-server 4.2.2.2
ip dhcp pool voice
network 10.10.10.0 255.255.255.0
default-router 10.10.10.1
dns-server 4.2.2.2
option 150 ip 10.10.10.1
Router#

This is the output for the switch.
CoreSW#sh ip int bri
Interface IP-Address OK? Method Status Protocol
Vlan1 unassigned YES unset administratively down down
Vlan10 10.10.10.2 YES manual up up
Vlan50 192.168.2.2 YES manual up up

10 VLAN0010 active Gi0/1, Gi0/2, Gi0/3, Gi0/4
Gi0/5, Gi0/6, Gi0/7, Gi0/8
Gi0/9, Gi0/10, Gi0/11, Gi0/12
50 VLAN0050 active Gi0/13, Gi0/14, Gi0/15, Gi0/16
Gi0/17, Gi0/18, Gi0/19, Gi0/20
Gi0/21, Gi0/22, Gi0/23

Comments

  • RakuraiRakurai A+/N+/Sec+, CCNA/NP, CCDA/DP Posts: 84Member ■■■□□□□□□□
    Lets hope my brain can work while in night shift... Can you paste a copy of the switchport the phone is plugged into? Another thing to look for is the switchport access vlan 50 and switchport voice vlan 10 on that port, which will assign the proper vlan information for both the phone and pc. As far as the ip helper-address you will need it for the voice vlan because the voice traffic is on a different subnet than the DHCP server.
  • drkatdrkat Posts: 703Banned
    We use a helper so that the dhcp server can be on a different subnet. It does not effect the behavior.

    I'm gonna assume you have a vlan issue and the packet is tagged as voice vlan rather than 50 for your PC traffic
    Married to the game but she broke her vows. That's why my bars are full of broken bottles And my night stands are full of open bibles
  • Legacy UserLegacy User ■□□□□□□□□□ Posts: 0Unregistered / Not Logged In ■□□□□□□□□□
    This is interface the phone is connected too.

    CoreSW#sh int g0/6
    GigabitEthernet0/6 is up, line protocol is up (connected)
    Hardware is Gigabit Ethernet, address is 001e.79b4.9486 (bia 001e.79b4.9486)
    MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    Keepalive set (10 sec)
    Full-duplex, 100Mb/s, media type is 10/100/1000BaseTX
    input flow-control is off, output flow-control is unsupported
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input 00:00:05, output 00:00:00, output hang never
    Last clearing of "show interface" counters never
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: fifo
    Output queue: 0/0 (size/max)
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 2000 bits/sec, 1 packets/sec
    18238 packets input, 1775687 bytes, 0 no buffer
    Received 3414 broadcasts (1622 multicasts)
    0 runts, 0 giants, 0 throttles
    1 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog, 1622 multicast, 0 pause input
    0 input packets with dribble condition detected
    36833 packets output, 11388522 bytes, 0 underruns
    0 output errors, 0 collisions, 1 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier, 0 PAUSE output
    0 output buffer failures, 0 output buffers swapped out
    CoreSW#


    @drkat correct I have int 1 - 12 in vlan 10 and int 13 - 23 in vlan 50. That specific phone is connected to int g0/6 which is in vlan 10
  • drkatdrkat Posts: 703Banned
    Well there ya go :)

    The ip helper doesnt change the fact the DHCP Discover is coming from 10.x subnet it just allows the discover/offer to traverse subnets
    Married to the game but she broke her vows. That's why my bars are full of broken bottles And my night stands are full of open bibles
  • RakuraiRakurai A+/N+/Sec+, CCNA/NP, CCDA/DP Posts: 84Member ■■■□□□□□□□
    Make sure that the interface is configured with both switchport access vlan 50 and switchport voice vlan 10 so the phone will tag its voice frames with 10 and leave the pc's packets untagged when it sends them to the switch.
  • Legacy UserLegacy User ■□□□□□□□□□ Posts: 0Unregistered / Not Logged In ■□□□□□□□□□
    Yea Rakurai as I was looking at my sh vlan brief. It suddenly clicked and I realized I never did the sw voice vlan. Sure enough got the right ip address on the laptop. Had a saturday night brain fart going. Thanks guys for the input though.
Sign In or Register to comment.