grouping ip policy route maps
does anyone know how or where i can find a link to group multiple route maps into 1 list that can be assigned to an interface
heres what i have so far
access-list 100 permit ip 0.x.x.0 0.15.255.255 any
access-list 100 permit ip 1.x.x.0.0 0.7.255.255 any
access-list 100 permit ip 2.x.x.0.0 0.1.255.255 any
access-list 101 permit ip 3.x.x.0 0.0.63.255 any
access-list 102 permit ip 4.x.x.0 0.0.63.255 any
access-list 103 permit ip 5.x.x.0 0.0.63.255 any
route-map Wireless permit 10
match ip address 103
set ip next-hop x.x.x.4
!
route-map Public permit 10
match ip address 102
set ip next-hop x.x.x.0
!
route-map Staff permit 10
match ip address 101
set ip next-hop x.x.x.1
!
route-map OLD permit 10
match ip address 100
set ip next-hop x.x.x.2
!
route-map Group permit 10
heres what i have so far
access-list 100 permit ip 0.x.x.0 0.15.255.255 any
access-list 100 permit ip 1.x.x.0.0 0.7.255.255 any
access-list 100 permit ip 2.x.x.0.0 0.1.255.255 any
access-list 101 permit ip 3.x.x.0 0.0.63.255 any
access-list 102 permit ip 4.x.x.0 0.0.63.255 any
access-list 103 permit ip 5.x.x.0 0.0.63.255 any
route-map Wireless permit 10
match ip address 103
set ip next-hop x.x.x.4
!
route-map Public permit 10
match ip address 102
set ip next-hop x.x.x.0
!
route-map Staff permit 10
match ip address 101
set ip next-hop x.x.x.1
!
route-map OLD permit 10
match ip address 100
set ip next-hop x.x.x.2
!
route-map Group permit 10
Become the stainless steel sharp knife in a drawer full of rusty spoons
Comments
-
keenon Member Posts: 1,922 ■■■■□□□□□□i got it working all by myelf
it turns out that in order to do it the route map statement must look like
route-map Group permit 10
match command
set ip next hop
route-map Group permit 20
match command
set ip next hop
and so on
when assigned to an interface it only looks at the name and not the additional permit clauses and filters accordingly .. this will help out those doing BGP
lolBecome the stainless steel sharp knife in a drawer full of rusty spoons -
darkuser Member Posts: 620 ■■■□□□□□□□